Beta login error?

90 Human Warlock
10625
Hello all.
So I just got my beta invite today, about 2 hours ago. Upon attempting to log in to the beta, it gives me the error message:
"There was a problem logging in with this account. You may not have a World of Warcraft game attached to your account, or you may be logging into a region different from the one you created the account in. If you continue having trouble, please contact customer service."

Note that I have not logged into the beta at all yet, therefore I cannot have chosen a different region from my own. Is anyone else having this problem? And does anyone have an idea as to how to fix it?
Reply Quote
62 Human Priest
485
Did you choose WoW2 for your account when prompted upon trying to log in? And have you chosen a Battletag name yet?

Blue also posted that changing your password can sometimes fix errors like this, though Im not sure why? I'll try and find a link to that thread.
Reply Quote
90 Human Paladin
11310
04/18/2012 10:03 PMPosted by Alymayhem
And have you chosen a Battletag name yet?

BattleTag has nothing to do with it.

OP: Log in with "WoW2" (or the most recent license added, could be able to WoW10). It doesn't use your normal account for the beta.
Reply Quote
90 Tauren Paladin
8535
change your password it will prompt the drop down menu
Reply Quote
90 Blood Elf Death Knight
7925
Yeap change your password. It worked for me right now.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]