Default UI issues - help

91 Troll Shaman
5340
I just started healing LFR. Never really been a healer and am just getting my bearings. My question has to do with an issue that keeps coming up with the Default raid frames. When I try to target someone using the raid frames, sometimes it targets someone else, or worse, no one at all. I think this happens when someone leaves the raid mid-fight. Once this occurs it becomes impossible to use the raid frames to target anyone cause you're never sure who you'll end up targeting.

Has anyone else encountered this problem? Any suggestions on how to fix it? I don't use any raid frame addons, but could they help? If so does anyone have suggestions for someone that is just starting to heal?
Reply Quote
Nope, the only know workaround is really convoluted and wonky.

You just have to deal with it.
Reply Quote
91 Troll Shaman
5340
k this is apparently a well known issue. should have searched a bit more before posting. so I'll try to be helpful and post links to other threads from helpful folks that have addressed this issue. The problem is caused by 3rd party addon issues.

There are at least 2 approaches one can use:

1) get rid of the addon that is causing the problem. Go the link below for an explanation on how to identify that addon:

http://us.battle.net/wow/en/forum/topic/4768689845

2) the problem may be solved by toggling an option that would reset the raid frames. you'd have to do this every time the raid frames get corrupted but it might be less of a hassle than getting rid of an addon you like. Link below explains how to do this:

http://us.battle.net/wow/en/forum/topic/5978461110
Reply Quote
90 Blood Elf Priest
13110
07/03/2012 11:13 AMPosted by Drattz
The problem is caused by 3rd party addon issues.


No, it's not.

It's the way Blizzard deals with the raid frames. Blizzard locks the raid frames during combat, preventing them from changing or adapting when someone joins or leaves your raid group, as long as you are in combat.

There is no way to fix the issue, though certain addons appear to have some form of work around (Kaels has posted fairly extensively on the subject).

I repeat, this is not caused by an addon. It's caused by how Blizzard has chosen to deal with the raid frames during combat, and has been an issue since BC.
Reply Quote
91 Troll Shaman
5340
07/03/2012 11:19 AMPosted by Tiriél
There is no way to fix the issue, though certain addons appear to have some form of work around (Kaels has posted fairly extensively on the subject).


so its not related to having an addon? does that mean that even when all addons are gotten rid of the problem may still persist? that would suck if true. I'm new to this problem so am just repeating things I've read in other threads.
Reply Quote
90 Blood Elf Priest
13110
07/03/2012 11:24 AMPosted by Drattz
There is no way to fix the issue, though certain addons appear to have some form of work around (Kaels has posted fairly extensively on the subject).


so its not related to having an addon? does that mean that even when all addons are gotten rid of the problem may still persist? that would suck if true. I'm new to this problem so am just repeating things I've read in other threads.


It will persist.

Again, it is a result of Blizzard locking the raid frames during combat.
Reply Quote
100 Tauren Druid
20035
Eh, you can just type in "/reload ui" (without the quotes) and it should fix itself. That shouldn't be a problem as you should have time to reload without causing a wipe. Pretty much the only one-shot mechanics these days is Hagara's Ice Wall, and possibly the Black Blood phase on Morchok. I have the same problem in Tol Barad.

If you don't have time to reload, you can always just keep focus on a tank by clicking on his/her toon, rather than clicking the raid frame, until you have time to reload.

If there is a constant flow of people in and out of the raid group, you may have issues more serious than targetting problems...
Reply Quote
85 Draenei Shaman
6690
Reload UI has always worked for me. And I've seen this issue in dungeons in general if someone leaves. Doesnt happen often but, my 2 cents
Reply Quote
90 Human Paladin
15450
I never had this problem with Vuhdo, and I used to do plenty of LFR on 4 toons (2 of them healers).
Reply Quote
100 Blood Elf Priest
12745
Vuhdo, Grid, and Pitbull do not have this issue.

By the way, this thread:

07/03/2012 11:13 AMPosted by Drattz
http://us.battle.net/wow/en/forum/topic/4768689845

is inaccurate and misleading. Addons do not cause this issue. Blizzard's own code causes it and then blames it on a random addon that has nothing whatsoever to do with the raidframes. The taint system is obnoxious as hell.
Edited by Kaels on 7/6/2012 2:45 PM PDT
Reply Quote
91 Night Elf Druid
9335
I've had it before a few times. That and the stupid res icon staying on someone indefinitely also sometimes happens.

I always try /reload or just relog, relog always fixes. It's crazy crazy rare, but yeah it happens.
Reply Quote
90 Draenei Priest
11815
07/03/2012 06:21 PMPosted by Kaels
is inaccurate and misleading. Addons do not cause this issue. Blizzard's own code causes it and then blames it on a random addon that has nothing whatsoever to do with the raidframes. The taint system is obnoxious as hell.


That's good to know. I switched from x-perl to the default raid frames, and it "corrupts" on me, quite a lot. I select me and it doesn't pick me, it picks someone else, it picks an enemy, etc. I've reloaded ui at least 5x just tonight while pvping. Super frustrating.

That thread mentioned, it blames it on X-perl, which I still prefer to use for target, target target, and focus. I've disabled all other parts of it. It also blamed power auras which I disabled but it kept happening. But knowing it's not my add ons, is nice.
Reply Quote
85 Blood Elf Paladin
10010
I've had it before a few times. That and the stupid res icon staying on someone indefinitely also sometimes happens.

I always try /reload or just relog, relog always fixes. It's crazy crazy rare, but yeah it happens.


Yeah, I always just /reload mid combat. There aren't any fights in LFR where you can fit in a /reload, unless your computer is terrible and takes 5 minutes.
Reply Quote
100 Human Priest
10290
07/03/2012 11:32 AMPosted by Pipikaula
Eh, you can just type in "/reload ui" (without the quotes) and it should fix itself


Yeah, this is all i do. With a half-decent computer it only takes a couple seconds
Reply Quote
90 Human Paladin
15450
Why suffer an inferior product when there are better options out there. If your computer is good enough to do a UI reload in the middle of battle, it should be good enough to run Vuhdo or Grid 2.
Reply Quote
90 Draenei Priest
11815
Why suffer an inferior product when there are better options out there. If your computer is good enough to do a UI reload in the middle of battle, it should be good enough to run Vuhdo or Grid 2.


For me I'll probably work my way over to Vuhdo at some point. But if something is broken, a fix would be better than "well go use something else".

The irony is I quit using x-perl because it also had this problem, but now the default UI has the same thing. siiiigh :)
Reply Quote
100 Blood Elf Priest
12745
I wnder how hard it would be to whip up a fix for the defaults. I haven't really looked at them...I'm kind of scared of Blizzard's code :-/
Reply Quote
90 Blood Elf Paladin
10565
Have definitely encountered this problem and in fact, I just spoke with a gm about it yesterday, much to my surprise.

The problem exists when someone leaves/joins while in combat. The fastest way to fix this while in a dungeon/bg/raid, is to /reload

Yes it really sucks, yes I've raged hundreds of times, and yes, I've even wiped on H Morchok (TWICE!) because I forgot to reload before we started the fight. The most you can really do is keep submitting bug reports. Also, it never hurts to screenshot it, so that Blizzard actually has some "proof". (*super sad faces* do not work on gms)

http://img12.imageshack.us/img12/7054/wowscrnshot070512193706.jpg
Notice where it says "Flamee joins party." An yet he doesn't show up in my bars.
Reply Quote
07/03/2012 06:21 PMPosted by Kaels
Vuhdo, Grid, and Healbot do not have this issue.


Healbot definitely does have this issue. My healing frames can get really messed up when people drop from the raid, and half the time I lose most of the raid after the opening cinematic of Spine of Deathwing. I was just doing research to find out if switching to VuhDo would help, but it seems to have the same issue based on the comments on curse.
Reply Quote
90 Blood Elf Priest
13110
07/06/2012 11:12 AMPosted by Savvas
Vuhdo, Grid, and Healbot do not have this issue.


Healbot definitely does have this issue. My healing frames can get really messed up when people drop from the raid, and half the time I lose most of the raid after the opening cinematic of Spine of Deathwing. I was just doing research to find out if switching to VuhDo would help, but it seems to have the same issue based on the comments on curse.


It happens with all of the addons except, I think, with Pittbull (Kaels found a workaround using it, or some such!).

It seems to happen less frequently with Vuhdo and Grid versus the default raid frames, however. I don't know how often it happens with Healbot.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]