Mac OS X 10.5 Not Supported for Mists of Pandaria

(Locked)

Support Forum Agent
As of the Mists of Pandaria pre-patch, we will no longer support Mac OS X 10.5. Players will no longer be able to launch the game using Mac OS X 10.5 or previous versions of the Mac OS. This change will be implemented on August 28th. We recommend Mac users upgrade their systems to Mac OS X 10.7.4 (or newer) as soon as possible. Technical support will still be available for Mac OS X 10.8 and Mac OS X 10.7 per the policy noted here. Visit the support site for more Mac-related information and help.
Edited by Machkhan on 8/15/2012 11:07 AM PDT
90 Human Mage
10710
08/06/2012 03:00 PMPosted by Machkhan
Players will no longer be able to launch the game using Mac OS X 10.5 or previous versions of the Mac OS.


does this mean ANY versions prior to 10.7.4? or does this mean 10.5 and older? specifically, will 10.6.x run?
90 Blood Elf Mage
12945
08/07/2012 06:06 PMPosted by Prelimar
Players will no longer be able to launch the game using Mac OS X 10.5 or previous versions of the Mac OS.


does this mean ANY versions prior to 10.7.4? or does this mean 10.5 and older? specifically, will 10.6.x run?


As it says, 10.5 and older.

10.6.x should run fine.
86 Human Mage
6185
How many people are still using Leopard anyways? Good luck trying to find a legal copy of Snow Leopard if you still plan to play WoW on a Mac.
85 Blood Elf Hunter
4915
Eh, heh heh (scratches back of her neck nervously), I'm still running Snow Leopard. Too expensive to upgrade.

I'm switching to Ubuntu and will be running the game in WINE so as to avoid that pesky problem.
90 Human Mage
10710
well, that was my first thought, but i was just wondering why it would bother mentioning "we recommend Mac users upgrade their systems to Mac OS X 10.7.4 (or newer)" if it's 10.5 or older that will no longer be supported, and 10.6+ is fine. it just confused me.
MVP - Technical Support
90 Human Warrior
18580
08/07/2012 06:57 PMPosted by Zessica
How many people are still using Leopard anyways? Good luck trying to find a legal copy of Snow Leopard if you still plan to play WoW on a Mac.

it's actually not that hard.
08/01/2012 09:13 AMPosted by Machkhan
So, we contacted Apple and Snow Leopard is still available.
08/01/2012 09:13 AMPosted by Machkhan
Currently the only way to purchase 10.6 disk is to contact Apple (1-800-MY-APPLE) and purchase the 10.6 DVD from them for $29.99. Online orders are no longer available.


08/07/2012 07:54 PMPosted by Prelimar
well, that was my first thought, but i was just wondering why it would bother mentioning "we recommend Mac users upgrade their systems to Mac OS X 10.7.4 (or newer)" if it's 10.5 or older that will no longer be supported, and 10.6+ is fine. it just confused me.

click the "here" link on his post. 10.5 is being dropped immediately. 10.6.8 support in near future. you're being heeded now to get 10.7.4+ so you don't get short notice later.
Edited by Omegal on 8/7/2012 8:46 PM PDT
75 Orc Death Knight
0
Honestly, I am disappointed, as some of us, don't have that kind of money.
Blizzard Employee
Just to clarify the current cost of upgrading.

10.5 to 10.6 is $29.99
10.6 to 10.8 is $19.99
For more info : http://us.battle.net/support/en/article/mac-software-updates-software-upgrades

We will continue to support 10.6 as long as possible, so you do not have to upgrade to 10.8 now.

We are doing this because Apple is now releasing a new OS every year and they drop support for the previous OS as soon as they release a new one.
75 Orc Death Knight
0
Why is it that I can still run it though. Even with the "World of Warcraft Requires 1.6" message on the launcher.
Blizzard Employee
Are you using the beta?
Support Forum Agent
08/08/2012 03:39 PMPosted by Draxeth
Why is it that I can still run it though. Even with the "World of Warcraft Requires 1.6" message on the launcher.

This change won't happen until the Mist of Pandaria Pre-patch, not the current retail version.
90 Human Mage
6810
Uh, it SAYS that the MINIMUM is 10.7.4... which means 10.6.8 will be invalidated as soon as 5.0 hits.

So Blizz puts enough into it so it can run an EIGHT YEAR old M$ OS, but only the very latest for Mac users? 10.6.x was the top barely a year ago!

How about some serious explanation why they are forcing this on us? Far as I know, there is absolutely NO technical reason...
Support Forum Agent
You can still play MoP on 10.6.8 systems for awhile. Its like how min system specs for cata was 10.5.8, but 10.4 users can still play.
90 Goblin Hunter
3900
This really annoyed me... On your page about the mac OS requirements you state that "We are committed to updating our Mac community well in advance of any changes to supported operating systems." yet I didn't receive a single email regarding this update, I tried to log after the patch and wasn't able to. I then went to Apple and they didn't have the disks and had to call and order them and they will be here in a week. I did just update my time too which means a week of game play that I paid for I wont be able to use. Also in order to update all the way to mountain lion and actually run my computer smoothly with my work apps and WOW I needed to upgrade my RAM which was 99$ plus tax so my upgrade to snow leopard ran me 140$ instead of the 30$ it should've cost and yes the RAM was necessary. Next time at least give me fair warning so I don't waste my money on game time I cant use.

EDIT: I didn't realize until i read above that I can still run WOW without the update. Still annoyed though
Edited by Nutzo on 8/9/2012 10:21 AM PDT
90 Human Mage
6810
08/09/2012 09:17 AMPosted by Machkhan
You can still play MoP on 10.6.8 systems for awhile. Its like how min system specs for cata was 10.5.8, but 10.4 users can still play.


The page at:

http://us.battle.net/support/en/article/minimum-system-requirements-for-world-of-warcraft

clearly states that 10.7.3 is the MINIMUM OS for Mac users. So exactly what does "for a while" mean? It could easily be the next week. And given what I've seen in the past, it could we might be given all of a weeks notice.

But beyond that, the fact is you are supporting an 8 year old OS in XP, but say that only Mac users who have purchased an OS in the past 8 months can play the game seems very odd. You clearly seem to ignore that many of us rely on professional software that got deprecated when the Rosetta framework was abandoned and may not be able to afford as much as 500-1000 dollars to upgrade (in case where one CAN upgrade). I see no reason whatsoever in any actual technical sense for you to do this.
MVP - Technical Support
90 Human Warrior
18580
it means, if 10.6.8 breaks, it breaks. they will make sure it works, but not bend over backwards for it anymore. if it can be fixed easily it will be fixed, if it sacrifices functionality for newer technology, they will ignore it.

also, rest of your argument, i pretty much explain here
http://us.battle.net/wow/en/forum/topic/6293869364#6
90 Gnome Mage
14815
OK, so if i get this right. I am running 10.5(not sure if this has an animal name), the only way to upgrade to Mountain Lion is to purchase Snow Leopard or Lion (which I cant do online must be done in store or phone)? As well after reading some posts I should also expect to upgrade my RAM? If all of this is true it will make me a sad panda.
Edited by Beetlee on 8/10/2012 3:25 PM PDT
85 Blood Elf Rogue
6135
.
Edited by Crenshaw on 8/10/2012 11:45 PM PDT
70 Gnome Rogue
5785
08/10/2012 03:18 PMPosted by Beetlee
OK, so if i get this right. I am running 10.5(not sure if this has an animal name), the only way to upgrade to Mountain Lion is to purchase Snow Leopard or Lion (which I cant do online must be done in store or phone)? As well after reading some posts I should also expect to upgrade my RAM? If all of this is true it will make me a sad panda.


You are running Leopard. Yes, you must at least update your computer to 10.6.8 - Snow Leopard to get access to the Mac App Store, and if you want you can get Mountain Lion.

System requirements

2 GB of RAM
8 GB of available hard disk or solid state storage
To upgrade from an old version of OS X, the computer must be running at least v10.6.8.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]