Optimization/Reconfiguring freeze solutions.

90 Human Warrior
This thread I would like dedicated to potential work-arounds for the problem of the Optimization process freezing or lagging excessively during the update to the 5.0.4 patch.

Please do not post here that you are having the problem, its established that a number of people are experiencing it and there are other threads on the topic.

My solution to the problem was as follows:

Exit the Launcher (if still open).
Go into Program Files--World of Warcraft and delete the WTF and Cache folders.
Move your Interface file to the Desktop.
Disable your Anti-virus (in my case Avast!).
Disable your Firewall (Windows).
Restart the launcher.

After this the download still moved incredibly slow...approximately 1% every 5-7 minutes until it hit the 10% mark then it immediately shot to complete and began the actual patch (which was done in less than 5 minutes).

Hope this helps some of you.
Reply Quote
90 Human Warrior
It seems another potential work-around is to uninstall and reinstall the game, doing so apparently bypasses the optimization process. Confirmation of this would be appreciated.
Reply Quote
90 Blood Elf Paladin
Same problem, solution not helping.
Reply Quote
90 Human Warrior

Those whom are stuck at the updater with 0% follow these simple instructions:
1. Open Task Manager via CTRL + ALT + DELETE
2. Click on Processes tab
3. Locate process titled " Agent.exe*32 "
4. Highlight process and end it using the "End Process" button at the bottom right of your taskbar

All thanks and credit to Kelhan for this fix.
Reply Quote
90 Human Warrior
I was stuck for 2 and a half hours.
If you are stuck running it as administrator (right click run as admin) then try running it in safe mode. I ran it in safe mode with networking, took 4 mins to install.

Restart comp, F8 at post (start up) So spam it if you're unsure...run safe mode with networking. Choose admin as log in or log in regularly as admin. Install patch.


All thanks and credit to Theworstname for this fix.
Reply Quote
90 Tauren Warrior
Same problem here. None of the above solutions have solved it. Running it in safe mode with networking caused it to be stuck even before the optimizer. Ending the "Agent.exe*32" causes the optimizer to crash and the whole process must restart. And turning off firewall/anti-virus did nothing...

Need a mod or something to give some help.
Edited by Daemonen on 8/28/2012 3:24 PM PDT
Reply Quote
90 Orc Warrior
When you say freeze do you mean just stuck at 0 or 1% or the window has frozen completely. Thanks just need some clarification before I start troubleshooting.
Reply Quote
37 Night Elf Druid
Has it been confirmed that reinstalling the game will bypass the need to optimize?

Also the window isn't frozen, the progress just doesn't move past 0%.
Reply Quote
90 Blood Elf Mage
I'm at the same sad state. 0% for 15 mins now
Reply Quote
90 Troll Priest
im doin the wow optization thingnd im stuck at 0percent for two hours what do i do :(?
Reply Quote
85 Dwarf Warrior
Tayledras' first solution worked for me. But when I moved the Interface file to the desktop, I got an error message and the launcher closed. So I moved it back to my WoW folder, and got the update in less than 30 minutes. Thanks for the help!
Reply Quote
85 Draenei Mage
I get an error message that says "Failed to download required update. Check your internet connection and try again." I have disabled Avast! and Windows firewall and everything else talked about here with no success. Opened a ticket but have not gotten a response. I have tried the repair utility as well with no luck.
Reply Quote
85 Human Hunter
What if you don't have your game discs anymore? I moved recently and got rid of some stuff, and don't have game discs anymore. What can I do?
Reply Quote
85 Draenei Death Knight
The solutions didn't work for me, so I went ahead, uninstalled and re-downloaded the game.
Doing so skips the optimization process (as you won't have a previous WoW installation to be optimized).

It worked. Client downloaded completely (20GB download) with no need for patching/optimizing.

Might take a while to re-download the client, but sure seems to be faster than waiting on an optimization process that you aren't sure is even being performed.

Hope this helps whoever still has this problem.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)