HELP! Patch 5.0.4 ruined my game client!!

(Locked)

90 Blood Elf Paladin
11005
Do both of you have gma x3100 as well?
Check in "about this mac" -> More Info -> Graphics/displays
90 Blood Elf Paladin
11005
08/28/2012 04:16 PMPosted by Catawumpus
How old are those computers? Just wondering. I have a mid 2010 mbp and wondering if it'll get me through the next few years of wow like beyond mop


At this rate itll be useless next year.
90 Blood Elf Paladin
11005
08/28/2012 04:46 PMPosted by Drimp
What if I reinstalled my game client altogether??


Sadly i tried this already, no luck at all. All environmental details are glitching
90 Draenei Shaman
10590
Yes I have same graphics card. Looks like I won't be playing anymore if there's no workaround, sucks.
81 Goblin Hunter
700
This sucks so much.. all that money blown on all those discs just to not be able to play a week later... Thanks Blizz! Yeah i have the same graphics card as yall.
Yes, I have the same ... gma x3100.
90 Blood Elf Paladin
11005
Pretty devastated here. Id kill for someone to find a work around...
81 Goblin Hunter
700
Calling Blizzard tomorrow.. and if they don't know of a way to fix this, they better be ready to compensate me for the game and all of the expansions I bought. But if they help me fix it, ill come back here and tell you folks what to do fer sure!!
Support Forum Agent
If you're on an unsupported graphics card/chipset and have updated to patch 5.x, then this is why the login screen has graphic issues. Patch 5.0.4 uses the system requirements that Mists of Pandaria will be using.

For a full list of supported/unsupported graphic cards, look here: http://us.battle.net/support/en/article/world-of-warcraft-graphic-card-support-mac
Edited by Machkhan on 8/28/2012 5:23 PM PDT
That is not helpful, Blizzard. We've all spent quite a bit of money to play this game, have enjoyed it, and without warning we can no longer play. We all logged in today excited to see the new features and instead are sorely disappointed to find we've basically been kicked out. You don't seem to care.
90 Blood Elf Paladin
11005
Well I knew the card might not be supported. Sadly it doesnt mean I can afford to change that.

The odd part about it is it is mostly characters (numbers and letters) and the ground.
Not clutter or spells, distance related issues or high particle density. Most characters behave normally with some small issues. Is there any chance it could be changed because it seems to be related to one or 2 particular items in game?
90 Draenei Shaman
0
08/28/2012 03:25 PMPosted by Machkhan
Chipset Model: GMA X3100

This chipset isn't supported with patch 5.x since it doesn't meet the system requirements.


We have a Mac with Chipset GMA 950. Can anyone tell me if it is supported?

My wife can play the game perfectly fine. It patched without any trouble and she can login and see buildings and people and seems to be able to play. The only problem is that the ground appears wrong.

She played a character in Orgrimmar - the ground looks like lava.
She played a character questing in the Ruins of Gilneas - the ground is black and appears to have stars or sparkle.

I've cleared the cache and WTF folders, disabled addons, restarted the machine and WoW. I'd appreciate any help.
90 Tauren Death Knight
4205
Chipset GMA 950 is no longer supported.

http://us.battle.net/support/en/article/world-of-warcraft-graphic-card-support-mac

Same with my daughters MacBook. She is on the play for free setup, and I WAS going to subscribe her for real and up to Mists.

Ain't now.
90 Dwarf Priest
4970
08/28/2012 04:16 PMPosted by Catawumpus
How old are those computers? Just wondering. I have a mid 2010 mbp and wondering if it'll get me through the next few years of wow like beyond mop


2008/2009. Oddly enough, the MoP beta worked fine on my MacBook, and 5.0.4 runs fine on my 2007 19" iMac.
90 Draenei Shaman
0
Chipset GMA 950 is no longer supported.

http://us.battle.net/support/en/article/world-of-warcraft-graphic-card-support-mac

Same with my daughters MacBook. She is on the play for free setup, and I WAS going to subscribe her for real and up to Mists.

Ain't now.


I saw this a few minutes after posting.

I'm extremely disappointed with this decision. We've been playing together for a few years and now that's been brought to a halt by the decision to drop support. There's no way we can afford a new computer - especially not just to play World of Warcraft. I already canceled my wife's subscription, and it's likely that I'll follow soon too.

The game is great, but I'm not going to spend tons of time playing if she cannot play too.
90 Human Warlock
13995
2008/2009. Oddly enough, the MoP beta worked fine on my MacBook, and 5.0.4 runs fine on my 2007 19" iMac.


My MacBook is from 2008 (with the GMA X3100 chipset) and also ran the beta client well. I was a little surprised to see the flickering graphics on it after having used the beta on it.

I know this happens with video games - couldn't play Diablo 3 on this thing either - but it's disappointing nonetheless.
Edited by Cynwise on 8/28/2012 6:12 PM PDT
90 Dwarf Paladin
4410
This is crap. My entire family came back to the game 2 months ago.. dropped ALOT of money on restoring our accounts to pre-MoP.. knowing that our chipset wouldn't support MoP but we didn't plan to buy MoP.. just play the Cata content and earlier..

Everything working perfectly yesterday.. and today, graphics are completely shot in almost every zone. GMA 950 chipset.

My question is this... I bought Cataclysm (And WoTLK, BC, Classic) - all of which worked perfectly on my machine. I didn't buy a new game, didn't upgrade - but my game has been retroactively disabled.

That is seriously messed up. There was no warning about this, no notice sent out to those users running Macs that if they didn't drop a couple grand they're games were being disabled. Seriously, wth?

How do we fix this? Is there a workaround? A way to undo the 5.04 patch? We'd really like to play the game we bought - the game that was fully supported when we bought it.
85 Human Paladin
1400
Ok sooo.. I opened the game and it started to upload had an issue so I disbaled my firewall and did it again.. It made my comp crash. Finally have my comp up and running.. it updates all the way but then instead of letting my play the game or hit the play button it opens a World of Warcraft Setup window. It has been running over 2 hours and is still only at around 66%. I have restarted it once. Also I tried repairing and it is still doing it. Any suggestions I want to play sooo badly!
90 Dwarf Paladin
4410
I note the following from the sticky note at the top of Mac support forum:

Minimum System Requirements*
Mac® OS X 10.5.8, 10.6.8, 10.7.x or newer
Intel processor
2 GB RAM or higher
25.0 GB available HD space
4X DVD-ROM Drive
Broadband Internet connection

Note: Due to potential programming changes, the Minimum System Requirements for this game may change over time.

*There's no requirement for video cards because all video cards that shipped for Intel Macs are supported.

I don't own MoP. I bought Cataclysm. According to your own site, ALL VIDEO CARDS SHIPPED FOR INTEL MACS ARE SUPPORTED. So why can't I play?
81 Goblin Hunter
700
It's just so unfair!
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]