Discussion for Failed To Launch Critical File

While the circumstances of me getting to this problem are likely very different from the rest of you, I did figure out how to fix it for me, so I'd like to know if it happens to work for others as well.

1.) Go to the directory C:\ProgramData

2.) Rename the files "Battle.net" and "Blizzard Entertainment" to "Battle.net -backup" and "Blizzard Entertainment -backup"

3.) Go to your World of Warcraft directory (Default: C:\Program Files (x86)\World of Warcraft)

4.) Open the "Temp" folder and delete the file "5.0.4 Migration"

5.) Run the launcher normally


If it worked you will begin downloading "Update Tools" from the Cataclysm launcher, World of Warcraft Setup will launch (Possibly asking for User Account Control) and then the new MoP launcher will open and begin the optimization process.

If it did not work, go back to C:\ProgramData and rename your backup files to their original names.

Let me know how it works or if anyone else has some good suggestions to try.

(On a site note, if / when the optimizer does begin, it is completely normal that it will stay at 0% for an eternity, wait it out and don't stop it, you'll only cause more problems)
Reply Quote
90 Human Warlock
8085
sir if this works i officially thank you are an epic person, attempting it now
Edited by Aveilanna on 8/31/2012 4:39 PM PDT
Reply Quote
90 Night Elf Hunter
7915
IT WORRKS!!!!!!!!!!!!!!!!!!! thanks mate you're a lifesaver
Edited by Dratherion on 8/31/2012 4:42 PM PDT
Reply Quote
08/31/2012 04:36 PMPosted by Aveilanna
sir if this works i officially thank you are an epic person, attempting it now


Any luck? I've had two people tell me it worked for them so at least some good is coming of it.

IT WORRKS!!!!!!!!!!!!!!!!!!! thanks mate you're a lifesaver


Glad to help! This solution shouldn't cause any problems but it is admittedly a "short cut," if I could find what exact files are making it happen (rather than just the entire folders) Blizzard could make a fix for it on their side, however I'm having no such luck so far.
Reply Quote
90 Undead Priest
0
I didnt have the temp folder..so it didnt work for me. damnit! :(
Reply Quote
08/31/2012 05:03 PMPosted by Konvict
I didnt have the temp folder..so it didnt work for me. damnit! :(


The deletion of temp file "5.0.4 Migration" shouldn't technically be needed, I added that step more so for good practice and making sure you get a fresh download of update tools. Did you try regardless? As soon as "Update Tools Downloading" begins, that temp folder will have the "5.0.4 Migration" file in it.
Edited by Gashan on 8/31/2012 5:26 PM PDT
Reply Quote
90 Undead Priest
0
Yes i tried and it didnt work. I still dont have any temp folder. I am going to try deleting and uninstalling again and try your method. Anything else u are thinking?
Reply Quote
100 Blood Elf Mage
13115
I'm getting the same problem. I have in my temp folder only 5.0 Migration and I do not have files "Battle.net" and "Blizzard Entertainment".

I tried to do what you said, but it did not work. Very frustrating since the restore didn't fix my primary issue either. now I have more problems. :( Any help would be greatly appreciated.
Edited by Shalindria on 8/31/2012 7:56 PM PDT
Reply Quote
10 Blood Elf Paladin
250
where is blizzard entertainment file i cant find it
Reply Quote
10 Blood Elf Paladin
250
where is it
Reply Quote
I'm getting the same problem. I have in my temp folder only 5.0 Migration and I do not have files "Battle.net" and "Blizzard Entertainment".

I tried to do what you said, but it did not work. Very frustrating since the restore didn't fix my primary issue either. now I have more problems. :( Any help would be greatly appreciated.


09/01/2012 07:24 AMPosted by Painbringa
where is blizzard entertainment file i cant find it


Are you checking in the directory C:\ProgramData ? You will have to type that directly into Windows Explorer (The window that lets you view files) and hit enter. These files are NOT in your main World of Warcraft install directory. There shouldn't be any issue of not having these files if you've run the launcher at some point in time, they are re-made every time it is launched.
Reply Quote
Alternatively to manually typing in C:\ProgramData to Windows Explorer, you can also use the "click through" navigation by first allowing hidden files to be seen.

The following steps are credited to Blizzard's support site:

Click Start
Click Control Panel
If you are in Classic View:

Open Folder Options

Click on the View tab

If you are in Category View:

Click on Appearance and Personalization

Click Show Hidden Files and Folders
Under the Hidden files and Folders section, select Show hidden files and folders
Click OK


After doing this open your Start Menu (The "Windows Pearl" in the bottom left) and select "Computer" then click your C:\ drive and then look for the folder "ProgramData" you should see "Battle.net" and "BlizzardEntertainment" in there
Reply Quote
85 Draenei Shaman
2260
To get the battlenet folder in program data u need to enable seeing hidden files.
Reply Quote
09/01/2012 07:44 AMPosted by Thexy
To get the battlenet folder in program data u need to enable seeing hidden files.


The actual files within ProgramData are not hidden by default, only the folder "ProgramData" is. If you manually type in C:\ProgramData you can bypass this step, but you are right for mentioning this, I may be confusing people who are used to click navigation of directories.
Edited by Gashan on 9/1/2012 7:48 AM PDT
Reply Quote
85 Draenei Shaman
2260
Didn't work for me. I didn't have a temp directtory either.
Reply Quote
90 Orc Warrior
5105
Thank you op. You are a gentleman and a scholar.
Reply Quote
09/01/2012 07:51 AMPosted by Thexy
Didn't work for me. I didn't have a temp directtory either.


Then it seems that this only works with people who have had the same situation as me (they mentioned it in their own threads and I directed them here). People who successfully installed WoW and had it running, then ran a Windows System Restore to a time prior to the patch were getting this issue, and so far this fixed it for about 4 people with that issue. I really wish I could help with other reasons people are getting this though... I'll ask a few of my friends and see if any of them have that problem and try to get a chance to mess with their computer. Problems are a lot easier to solve when you're physically at the computer with the issue... I'm sorry this didn't help you.
Reply Quote
09/01/2012 07:53 AMPosted by Ragequitlife
Thank you op. You are a gentleman and a scholar.


I'm glad it worked for you! If you have time do you mind telling me if you ran a System Restore recently or if you came across this error just by regularly running the launcher?
Reply Quote
85 Draenei Shaman
2260
09/01/2012 07:55 AMPosted by Gashan
Didn't work for me. I didn't have a temp directtory either.

Then it seems that this only works with people who have had the same situation as me (they mentioned it in their own threads and I directed them here). People who successfully installed WoW and had it running, then ran a Windows System Restore to a time prior to the patch were getting this issue, and so far this fixed it for about 4 people with that issue. I really wish I could help with other reasons people are getting this though... I'll ask a few of my friends and see if any of them have that problem and try to get a chance to mess with their computer. Problems are a lot easier to solve when you're physically at the computer with the issue... I'm sorry this didn't help you.


Not a problem, it was worth a try anyway. Other uses have been more help thus far than a Blue. Thanks anyway:)

Just for an FYI, my WoW was a fresh install so definately no Window System Restore, so looks like I vary off your situation.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]