[Mac] Common 5.1.0a Errors and Troubleshooting

(Locked)

Support Forum Agent
Hey Mac Community!

This thread has been created to help troubleshoot common 5.0.4 issues that have been reported such as:

  • "An internal error occurred, please restart."
  • "Failed to launch a critical file."
  • Glitchy, weird graphics
  • Stuck on "Updating Setup Files"

This list is a living document, and may change over time, so please check back from time to time for updates.
Support Forum Agent
"An internal error occurred, please restart."

    Symptoms
      When attempting to launch World of Warcraft, the error "An internal error occurred, please restart." appears.

    Issue
      The World of Warcraft Launcher.app was copied to the desktop or moved out of the World of Warcraft install folder to the desktop. This breaks the client, as there are now 2 launchers, and WoW is unable to properly detect the game install.

    Resolution
      1. Move the World of Warcraft Launcher back to the /Applications/World of Warcraft directory.
      2. If you require a desktop shortcut, create and Alias instead: http://support.apple.com/kb/PH10609

    Additional Information
Edited by Machkhan on 9/12/2012 9:55 AM PDT
Support Forum Agent
"Failed to launch a critical file."

    Symptoms
      When attempting to start World of Warcraft from the launcher, you encounter the error:

      Failed to launch a critical file. Please close all other applications, temporarily deactivate your anti-virus software and try again. Alternatively, log in as an administrator and try again.

    Issue
      This indicates that a critical file is missing from the World of Warcraft folder, such as World of Warcraft.app or World of Warcraft-64.app.

    Resolution
      Double-check the /Applications/World of Warcraft directory to ensure it has both World of Warcraft and World of Warcraft-64 app files: http://i50.tinypic.com/2isuxch.png

      If any files have been moved to the desktop for a shortcut or into the trash, please move them back to the World of Warcraft directory and create an Alias instead: http://support.apple.com/kb/PH10609
Support Forum Agent
Red Realms/Servers

    Symptoms
      When logging into World of Warcraft, you notice realms/servers are red, and you are unable to connect to any server.

    Issue
      This indicates that your copy of World of Warcraft did not patch, and is not the same version as the realm/server. This is mainly caused by opening World of Warcraft.app/World of Warcraft-64.app directly instead of using the World of Warcraft Launcher.

    Resolution
      This can be resolved by ensuring that you are using the World of Warcraft Launcher to open the game, thus patching. Make sure your World of Warcraft game folder looks like this: http://i50.tinypic.com/2isuxch.png

    • If your launcher is not working due to an ' Internal Error', please see this post to learn how to fix it.
    • If the World of Warcraft was moved to the desktop to create a desktop shortcut, please move it back and create an Alias instead.
    • If you are just missing the World of Warcraft Launcher and cannot find it in the Trash or elsewhere; but not World of Warcraft.app/World of Warcraft-64.app (see example), then download the 5.0 World of Warcraft Setup from Battle.net and run the installer. Make sure it is point to your install directory, as this will just reinstall the Launcher.
      Note: If you are missing World of Warcraft.app/World of Warcraft-64.app from the WoW directory, the installer will redownload ~20 GB of data.

    Additional Information

    Make sure the client you are logging into is up to date. We just dropped a new patch it seems. (5.0.5a). The launcher wasn't updating until now.

Edited by Machkhan on 9/13/2012 6:01 PM PDT
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]