Failed to download a required update....

90 Blood Elf Mage
1820
...Failed to download a required update. Please check your Internet connection and try again."

This error has occurred continuously on the updating the game screen (the one that came with 5.04 and takes 15-60 minutes) where I am updating the game on my laptop. At first I thought it was stuck at 0% because of problems with firewalls, etc. I turned off that, uninstalled windows security essentials, tried deleting cache, temp, WTF, battle.net folder in programdata, everything. After it still didn't work, I eventually got that error.

A Google search took me to the technical problems page and recommended that I verify my internet connection (check) and then uninstall the game and re download the client.

My dumb question: If I uninstall the game, I can still get it right back on here without having to repay anything, or do anything like that right? Do I have to verify anything?

Or is there an alternative? Thanks a lot.
Reply Quote
90 Gnome Warlock
13475
My issue is quite like yours, but queston: how is your net speed? are you shaped?
Reply Quote
90 Gnome Warlock
13475
09/03/2012 04:44 AMPosted by Walmartoo
Now background downloader says it will take 200+ hours to download, so I had to click "don't throttle" under view/preferences and it sped right up.


Im trying that now aswell, sounds like we have the same prob.
Reply Quote
90 Troll Shaman
0
Same issue, have done all they suggest but getting nothing past 1% before it gives that message.
Reply Quote
90 Orc Warlock
13315
/facedesk with this error here as well.
Reply Quote
90 Blood Elf Mage
1820
I have a new problem now. I went through with redownloading WoW from the clients page on this site, and it is taking forever, at about 55% right now (started last night), but the bar at the bottom isn't moving, and the option the "playable" option hasn't appeared even though it is past 11.1 GB. Will it recognize when the game is downloaded?
Reply Quote
I'm having this problem as well....Still no solution to this? SMH
Reply Quote
having the same problem, anyone find a solution?
Reply Quote
25 Human Warrior
4610
Best I can tell you is to reinstall the game. I got the Mists Of Pandaria launcher right away and was able to get into the new main screen. Am still downloading.

That is the old solution and usually the best.

Before I uninstalled I had a 32 GBS file. The download is 20 Gbs.

Plus do you trust Blizzard with consolidating something on your hard drive. What about the drive? You won't be able to play at all if you drive gets messed up.

I am really disappointed. The last 2 optimizations I ran before this worked fine.
Edited by Yorick on 9/3/2012 1:08 PM PDT
Reply Quote
Same problem here, had to do this on my backup computer which hasn't been updated in a few months. Tried manually adding updates, just screwed this up worse. Had to just uninstall WOW and remove all WOW leftovers from the registry. Did a fresh download and install. Can play again.
Edited by Gerlic on 9/3/2012 1:12 PM PDT
Reply Quote
85 Human Paladin
6105
09/03/2012 04:44 AMPosted by Walmartoo
I haven't played in a while and for whatever reason my background downloader didn't download the 4.3-5.04 patch, so I had to go to my WoW folder, then click background downloader.


Thank you for the tip. I was in the same boat. I couldn't get through the texture.mpq part of the optimization process. So I downloaded the 5.04 patch just like Walmartoo and Litlerock. It downloaded successfully in about 2 hours, but I eventually got the same "failed to download a required file, check your internet connection" message again.

At this point, I'm forced to believe, after all I've read on all the forums, that it's simply an internet bottleneck situation. I've tried everything except re-installing WoW from scratch. I'm resigned to the fact that I'm paying $.50/day without being able to play until the servers come back on line. It's as simple as that. I REALLY hope MoP is worth it after all this!
Reply Quote
90 Human Paladin
7335
I found the solution on another thread. I don't know why this works but it worked for me and many others.

Simply move your "data" folder to your desktop and start the download.

Apparently there is something in the folder that chokes the optimizer. Again no idea why but after trying the 20 different solutions that failed, this worked and I'm playing again!
Reply Quote
90 Orc Warlock
13315
I found the solution on another thread. I don't know why this works but it worked for me and many others.

Simply move your "data" folder to your desktop and start the download.

Apparently there is something in the folder that chokes the optimizer. Again no idea why but after trying the 20 different solutions that failed, this worked and I'm playing again!


Just tried this, currently at 10%... that's 10% more than I've been able to get trying everything else. Will update!
Reply Quote
90 Blood Elf Paladin
0
T

I found the solution on another thread. I don't know why this works but it worked for me and many others.

Simply move your "data" folder to your desktop and start the download.

Apparently there is something in the folder that chokes the optimizer. Again no idea why but after trying the 20 different solutions that failed, this worked and I'm playing again!


Just tried this, currently at 10%... that's 10% more than I've been able to get trying everything else. Will update!


This has worked for me as well. I was going to try the downloader suggestion but tried this first and I am almost 70% in. I also don't know why this is working. Tried all the other troubleshooting tips and none worked until I did this.
Reply Quote
same issue, it was trying to verify all the SW ( it's a fresh install as of last week... -_- and then kept telling me that not all the updates were done, so i had to manually go to the background launcher to force start the update DL. now it seems to be fine.
Reply Quote
90 Tauren Shaman
6845
This works and actually you can just outright delete the "Data" folder all together.
Reply Quote
Thanks extremely!

Moving the "Data" folder (that's the one that's in the "\Users\Public\Games\World of Warcraft" folder on a Windows 7 machine, along with "Interface", "Logs", "Screenshots" and so on) somewhere else seems to have fixed the problem for me also; the upgrade process has re-created the Data folder, and I'm now at 70% of the actual patch download, in the "Playable" zone.

Before that, I'd tried running the background updater and lots of other things short of a full re-install, and nothing'd helped, always got the "Failed to download a required update" message (and my internet connection is just fine!).

Seems like one that Blizzard ought to push out a fix for...
Reply Quote
90 Orc Warlock
2900
Disappointing, Blizzard!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]