How I've Fixed Error 134 (Multiple Times)

(Locked)

90 Pandaren Shaman
9895
Over the past several days I have received, and then fixed, Error 134 on several machines that my wife and I use to play the game. All of our Error 134 Crashes indicated World.mpq as the culprit, and these are the steps I took to fix it each and every time:

PLEASE NOTE: That these Fixes are all based on a Windows 7 Install, I do not run Windows XP and can not guarantee that the Folders and Files referenced will be in the exact same locations.

ALSO NOTE: That these Fixes will most likely not result in a Repaired Install unless they are ALL completed. I have tried variations of these methods and the most effective, least frustrating method of resolution is to complete them all in one go.

1) Navigate to your World of Warcraft Install. By default his could be located at "C:\Users\Public\Games\World of Warcraft", "C:\Program Files(x86)\World of Warcraft". or "C:\Program Files\World of Warcraft".

2)Rename your Fonts, Interface, and WTF Folders

3)Open the Folder named "Data" and Locate the Files "World.MPQ" and "World.MPQ.lock"

3)Delete BOTH of these Files

4)Navigate to C:\ProgramData\Battle.net and Locate the Folders "Agent", "Client", and "Setup"

5)Delete ALL THREE(3) of these Folders

6)Open Control Panel and Navigate to Systems and Security and locate the Option "Allow a program through Windows Firewall" under the Heading of "Windows Firewall".

7)Click the "Change Settings" button IF the "Allow another program..." button below is grayed out, and then click on the "Allow another program..." button

8)Click the "Browse" button and navigate to your World of Warcraft Install Folder (Referenced in Step #1)

9)Select "World of Warcraft Launcher.exe" and Click "Open" and then "Add". This must be REPEATED for both "Wow.exe" AND "Wow-64.exe". (Wow-64.exe only if applicable)

10)Right-Click your "World of Warcraft" Desktop Icon and Choose the "Properties" option.

11)Navigate to the "Compatibility" Tab and Check the Box for "Run this program as an administrator" under the "Privilege Level" Heading. Click the "Apply" button and then Click the "OK" button

12)Start World of Warcraft from your Desktop Shortcut. "World.MPQ" will either begin to download right away or after a short setup runs after you select "Play" that will then download "World.MPQ". "World.MPQ" is a roughly 3.13 GB file and will require 10-20 minutes to download.

13)Attempt to load a character in to the world and run around any areas that have been crashing you to validate that the repair was completed successfully.

14)Close the game and re-enable your addons by deleting the newly created "Interface" and "WTF" Folders and renaming your previously renamed Folders (step #2) back to the original.

15)Repeat step #13 and you should be good to go.

Adding links to responses where I've tried to catch most of the issues and the concerns provided throughout the thread so far. As the holiday weekend is now over, supporting this thread so determinedly may be beyond me starting today. I'll give it my best, but don't get discouraged if your post goes unanswered for a while.
http://us.battle.net/wow/en/forum/topic/6490599131?page=4#70
http://us.battle.net/wow/en/forum/topic/6490599131?page=7#125

IF THESE FIXES WORK FOR YOU: Please rate this post and then link to it in other threads where others are experiencing similar issues. Hopefully this thread's new Blue tag will get it more attention and help more people. Thank you all.
Edited by Ankerman on 9/4/2012 2:44 AM PDT
90 Pandaren Shaman
9895
REPOSTING POSTS THAT GOT BURIED IN THIS THREAD

Ok am I the only one who cant find battle.net folder.........why is this?


I'm sorry Brewtaul, not explaining that these folders were Hidden by default was an "intentional" oversight, as I knew the explanation of the process of Showing Hidden Files was probably a detour the majority of people wouldn't need, props to Jurannok for providing such a succint article to explain the process.

hey i have the same problem but i have it with the file wow-64 can you help me thx


Hi Badgirlz, you're probably "seeing Wow-64.exe" in the "header" of the crash log. You'll want to jump down to the next section, directly under where it says "ERROR #134", to determine which file is crashing you.

The 32-bit client now works...still can't get the 64-bit client to work, but it's progress.


Hey Malstrom, I would make sure you added "Wow-64.exe" in step 9, as that is the 64-bit client.

Where is the Font's folder?

The "Fonts" Folder is a Folder that is usually added if you have downloaded an addon "compilation", such as one that provides a complete UI overhaul. Most people probably won't have this folder but I included it in the steps anyway, sorry for the confusion this caused.

2)Rename your Fonts, Interface, and WTF Folders

I wish i knew what to rename the folders to....


Eyonox, as Thunderkitti explained, these folders can be renamed to anything that you'll recognize at a later time, such as "InterfaceOld", "Interface1", or "InterfaceMINE".

Well, after doing all this I can't even get to the character screen now. I get a "Failed to Load Critical File" when I launch wow.


I'm sorry that this didn't work for you Tasker, is the crash you are receiving now prompting you with any kind of log or report? Is it referencing a specific File as the original Error 134 log you were receiving did?

I actually didn't delete those because I couldn't find them, figured it was a difference in mine since I'm running the Mac version.


Hey Thunderkitti, the Apple file structure is indeed different, and the same files and folders may not exist across Operating Systems. HUGE thanks to you for keeping this thread going while I was out fixing my tractor and finally getting my yard mowed today.

I did everything that was stated, but now I can't load the game. Telling me to check my network connection.


Schmokel, the only time that I received this specific error was when I skipped steps 4-9 from my original post. If that isn't the case for you then it's outside of my purview on this topic. =(

Soo..what if you're downloading the client again after a year long break and you don't have those files to delete, and you're still getting a 134 error AND an Agent.exe error?


Hi Luri, if you're still attempting to download the client fresh, at what point exactly are you receiving those errors?
Edited by Ankerman on 9/4/2012 5:41 PM PDT
90 Pandaren Shaman
9895
AGAIN REPOSTING BURIED RESPONSES

i get lost at 7 8 and 9 im not sure what to do at that point Help!!


Hi Kloanpoke, those steps actually begin with step 6. Have you made it as far as the Systems and Security section of Control Panel?

After following your steps, it looks like my game launcher is actually re-downloading the whole patch. Is this what it's supposed to do? I assumed it would simply re-download the MPQ file...

Is it normal for the game launcher to re-download the whole patch?


Lulublue, the World.MPQ file itself is ~3GB, and should take quite a while to download, and may give the appearance that you are re-downloading the entire patch.

Unfortunately, this did not work for me as I had high hopes from all the positive feedback. Everything looked good right up to the log in screen but now as soon as I hit the enter world button I get an immediate Error 134 message.


Sorry to hear that Syyin, if you would post your "new" Error 134 I could look it over and see where we could go from there.

doesnt seem to work for me but im thinking that im not really deleting my world.mpq files, they seem to be getting restored instantly with no download, does anyone know if im missing something that would cause this?


Hi Dlz, the only time I encountered this particular issue is when I attempted to start the game from the launcher before all of the steps were completed. This was particularly puzzling because it would instantly create a 3.16GB file every time I deleted it and tried to launch unsuccessfully. At one time I had ~19GB of World.MPQ in my Recycle Bin, which is pretty troubling for someone who runs WoW from quite a small SSD.

Hello Ankerman, I saw this just before i uninstall the game, the solution to my problem, so if i install the game again will this problem happen again>?


Glad to hear this at least got you back in the game Oneshót. There have been several people in this thread that have indicated they believe the issue to be coming from downloading corrupted parts of the install from peer sources. I have had no indication in my personal experience that this is the case but, if this possibility troubles you, you can turn off peer-to-peer for your next attempted install.

However as I log into the game with the character that the problem started I am still experiencing extremely high world latency 20k+

What more can I do to resolve this and enjoy my beloved World of Warcraft again?

Thromm and Thaladread, in my (admittedly limited) experience high latency shouldn't necessarily be related to your original Error 134 issue, as the Error is an immediate reaction to the game attempting to reference a corrupted file and failing.

well I did all the instructions and got a different type of Error 134

[111] err=0 text=SFileReadFile - World\Maps\Kalimdor\Kalimdor_32_22.adt - Data\world.MPQ


Sorry to see that this didn't get you up and running right away Eyonox. Your crash log is still referencing World.MPQ as a trouble file. I'm wondering if you should attempt the advice given by others in this thread and turn off peer-to-peer downloading when you next attempt to download this file.
Edited by Ankerman on 9/4/2012 5:44 PM PDT
90 Blood Elf Paladin
13955
This appears to have worked so far. I didn't download world.mpq however, i swapped it with a copy from my laptop which was not corrupted.
I tried this and it did´t work for me.
90 Draenei Paladin
0
This is at least letting me redownload the file. Couldn't even do that before b/c it wouldn't delete properly. So thanks. Hoping it'll be good from here.
90 Draenei Paladin
0
Download completed. It worked for me. Thanks so much!
90 Draenei Shaman
17775
ty am hoping this helps, odd thing is all those lock files were gone today from my folder. when the error was happening they were all there but now they left on theri own.
88 Night Elf Druid
11155
This has worked for me, thanks a bunch!
85 Night Elf Druid
7300
Nope.avi
90 Human Paladin
8725
Followed the steps you mentioned and it appears to be working fine for me now.
90 Pandaren Shaman
9895
Bumping it again one last time for the night because it appears to be helping some people.
86 Orc Warrior
5925
I should be paying Ankerman instead of these so called Blizzard Tech Support. Thanks dude! For the horde!
90 Dwarf Warrior
4450
well that didnt work
90 Blood Elf Paladin
8490
So far so Good
90 Goblin Mage
9365
This is allowing me to download the file, Thank you very much. I had already removed my nortons and attempted it without success. Some step in here was the key to allowing the download to occur as it should.
100 Night Elf Priest
13725
THank you very much. It seems to be working! :)
90 Pandaren Shaman
9895
Good morning everyone, bumping again to keep helping people. Also, since I seem to be coming back to this thread more than I thought I would, if these steps DIDN'T work for you, please indicate what symptoms you're still experiencing:

1)Did World.MPQ not successfully downloaded after the steps were completed?
2)Did all of the indicated steps work as they were supposed to and you're still crashing?
a)Does the crash log still indicate World.MPQ as the problem file?
b)Are you now experiencing crashes that are indicating a different file?

Hope this continues to help most people.
90 Goblin Mage
6425
So far it worked for me
THANKS
85 Blood Elf Paladin
3820
Good morning everyone, bumping again to keep helping people. Also, since I seem to be coming back to this thread more than I thought I would, if these steps DIDN'T work for you, please indicate what symptoms you're still experiencing:

1)Did World.MPQ not successfully downloaded after the steps were completed?
2)Did all of the indicated steps work as they were supposed to and you're still crashing?
a)Does the crash log still indicate World.MPQ as the problem file?
b)Are you now experiencing crashes that are indicating a different file?

Hope this continues to help most people.


Thanks for the helpful post!
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]