unable to establish connection to server

90 Blood Elf Hunter
9990
Ive been using mobile armory for about 5 months and its been working fine. I changed my email address today and when i try to log in mobile armory i get the unable to establish connection to server message. I searched online and i found a few other people with the same problem. I tried using wifi like some people said to try and it works with wifi. When i try to go to any blizzard websites including this one i get a white page with at message at the top saying something about not being able to resolve what im trying to do. I tried reseting the phone and reseting my 3g connection and it still wouldnt work. Armory was working fine this morning so im not sure what the problem is.

verizon HTC incredible 3g
Reply Quote
Quality Assurance
Thanks for the report. I'm looking into this for you.
Reply Quote
85 Human Paladin
2105
I have the same issue, i never try logging in when i got wifi because i could just log in at that point,all got is a 3g connection on my phome though
Reply Quote
Quality Assurance
11/03/2012 03:28 PMPosted by Palegeo
I have the same issue, i never try logging in when i got wifi because i could just log in at that point,all got is a 3g connection on my phome though


How long ago did you change your Battle.net email address?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]