Workaround to Nvidia Crashes

90 Human Warrior
11280
*** PROBLEM SOLVED temporary solution ***

First I want to thank Ultrapotato for posting the information on this thread and others to get me here to this one :). After days and days of updating drivers, formatting and reading forums i found this thread.

Here is what you do:
1 - Start WoW as you always do
2 - Go into the game menu
3 - Click on "System"
4 - Click on "Advanced" (on the left had side of the menu)
5 - Click on "Graphics API" heading
6 - Then Change Directx11 to --> Directx9
7 - You will then have to restart WoW to make the changes take place.
DONE !!

I have only had this error since patch 5.04, so I can only assume that it is some sort of bug that will be fixed in the future. Until then i'm happy to play using Directx9 and HAVE no more problems.

I have been playing for about 5 hours now without an issue. Now remember as mentioned above, "The downside is that you will not be able to use the DX11 API in WoW until the issue is solved by Nvidia and WoW Dev" But this seems to only be an issue with WoW.

Hope the simple direction helps

:)
Reply Quote
90 Blood Elf Paladin
11790
Using the 9800 gtx with driver 306.23 current as of 08/30/2012. Win 7 Ultimate 64 bit.

I understand that the 9800 series is having problems on 64-bit since 5.0.5 with DX11. That said I seem to be having a somewhat unique error. When trying to downgrade to DX9, the game does in fact run more smoothly but the majority of the models fail to load in game. Orgrimmar becomes filled with floating enchants/particle effects. Even parts of the environment fail to load. All shadows and other effects load as normal, and the majority of the environment does as well, but no character/weapon models do, and only MY mount does.

I have been able to play the game on ultra with nearly 60 fps even with 5.0.4. The only degradation to my framerate has resulted from using the new SSAO graphics option. Once 5.0.5 hit the game crashes in almost random intervals and the card does in fact cause system crashes with Warcraft. after repeated flickers and nvidia display errors and recoveries the game slaps me with that BSOD that others are experiencing and I get a reboot.

While I know most of my information isn't new, I found the failure to load models with DX9 to be exceptionally odd.
Reply Quote
Hi,

I have a 460gtx m with i7 laptop which was running absolutely fine pre patch 5. Now I'm experiencing the constant freezing that forces me to shut off the computer with pressing the power off button.

Tried every single solution to no avail. any help ?
Edited by Milanna on 9/16/2012 12:31 PM PDT
Reply Quote
90 Worgen Druid
6005
Having this problem too. I am running Nvidia GE Force 650-- I had no trouble until I dowloaded the lates driver yesterday... today the game has crashed 7 times now... always in SW

Error:

World of WarCraft: Retail Build (build 16057)

Exe: C:\Program Files (x86)\World of Warcraft\Wow-64.exe
Time: Sep 15, 2012 10:40:17.756 PM
User: Fluffy
Computer: FLUFFY-PC
------------------------------------------------------------------------------

This application has encountered a critical error:

ERROR #132 (0x85100084) Fatal exception!


That is not that same issue. The issue this thread is about is the Nvidia driver crashing.
You are having WoW itself crash.

09/16/2012 05:11 AMPosted by Azrea
I understand that the 9800 series is having problems on 64-bit since 5.0.5 with DX11.


9800GTX does not support DX11

09/16/2012 12:35 AMPosted by Scryeden
Then Change Directx11 to --> Directx9


This is not a solution or fix, This is a work around to avoid the real problem that needs fixed.
Reply Quote
90 Human Warrior
11280
This thred is related to Display driver stopped working and has recovered error.

For example, I was getting the following error when playing Worldofwarcraft and only world of warcraft:

- Display Driver has stopped responding and has recovered. Display Driver NVIDIA Windows Kernel Mode Driver, Version 306.23 stopped responding and has successfully recovered -

Again the information I provided above has a downside. That being you will not be able to use the DX11 API in WoW until the issue is solved by Nvidia and WoW Dev.

So yes it is a work around. But much better than getting the error all the time and better than nothing.

:)
Reply Quote
90 Worgen Rogue
14085
I would like to ask the OP to amend the thread title, as this is not a solution to the problem. Here is the best way to look at the situation:

You have two televisions, Television A (DX11), and Television B (DX9).

Television A (DX11) randomly shuts off, and powers back on. Your provided "solution" is for them to just watch Television B (DX9).

Television A (DX11) is still broken, and having people switch to Television B (DX9) isn't going to fix Television A (DX11).

I bring this up, because if people see the word "solution" and switch back to DX9 without providing system information, and details of the problem they are having... it's going to take longer for the root cause to be addressed.

I do agree that switching back to DX9 is a good idea for those that are unable to get DX11 to work at all right now, but it is not a solution. Also DX9/11 can be changed directly from the launcher by clicking on: "Options -> Game Preferences -> Graphics API".
Reply Quote
40 Human Rogue
8550
09/16/2012 06:54 PMPosted by Complexity
I would like to ask the OP to amend the thread title, as this is not a solution to the problem. Here is the best way to look at the situation:

Hey Complexity,

I have renamed the thread as suggested. After being a derp and realising you're able to do that. Thanks for the suggestion. Perhaps I should've worded it this way in the first place.

Hi,

I have a 460gtx m with i7 laptop which was running absolutely fine pre patch 5. Now I'm experiencing the constant freezing that forces me to shut off the computer with pressing the power off button.

Tried every single solution to no avail. any help ?


Haven't heard of this one yet. I'd suggest rolling back to DX9, seeing if that's stable. Then getting back to us here.
Edited by Ultrapotato on 9/16/2012 9:03 PM PDT
Reply Quote
40 Human Rogue
8550
Using the 9800 gtx with driver 306.23 current as of 08/30/2012. Win 7 Ultimate 64 bit.

I understand that the 9800 series is having problems on 64-bit since 5.0.5 with DX11. That said I seem to be having a somewhat unique error. When trying to downgrade to DX9, the game does in fact run more smoothly but the majority of the models fail to load in game. Orgrimmar becomes filled with floating enchants/particle effects. Even parts of the environment fail to load. All shadows and other effects load as normal, and the majority of the environment does as well, but no character/weapon models do, and only MY mount does.

I have been able to play the game on ultra with nearly 60 fps even with 5.0.4. The only degradation to my framerate has resulted from using the new SSAO graphics option. Once 5.0.5 hit the game crashes in almost random intervals and the card does in fact cause system crashes with Warcraft. after repeated flickers and nvidia display errors and recoveries the game slaps me with that BSOD that others are experiencing and I get a reboot.

While I know most of my information isn't new, I found the failure to load models with DX9 to be exceptionally odd.


Yes, well unfortunately you're trying to use DX11 on a 9800GTX which only supports DX10c to my knowledge. Hence your issue to render some of the models etc. You'll have to stay with DX9 API until you buy a newer card. So that's all I can really say on your issue.
Reply Quote
Fix the disconnecting servers!
Reply Quote
90 Troll Shaman
12455
I have now been playing for about 9-10 hours without crashing since changing to dx9 (not constantly =) ) so ty for this
Edited by Yaaboo on 9/16/2012 8:58 PM PDT
Reply Quote
40 Human Rogue
8550
09/16/2012 08:58 PMPosted by Yaaboo
I have now been playing for about 9-10 hours without crashing since changing to dx9 (not constantly =) ) so ty for this


Not a problem. Glad I could help just making knowledge of an easy way to play the game in a stable manner until the issue is resolved.
Reply Quote
Haven't heard of this one yet. I'd suggest rolling back to DX9, seeing if that's stable. Then getting back to us here

Did that, but still getting the freezing issue.
Edited by Milanna on 9/17/2012 4:52 AM PDT
Reply Quote
90 Worgen Druid
4460
I'm running a recently purchased Alienware 17x. The GPU is a 680m. changing to Dx9 corrected my issue but my performance went down about 30%.

Hopefully there will be a permanent fix to Dx11 soon.
Reply Quote
90 Human Rogue
17515
Just to add to the data pool...
I also had this problem, which was solved by switching DX11 -> DX9. Have played 10+ hours since the switch without a single crash, when it was crashing every 5-10 minutes before then.

I am running Win7 64 bit, dual display adapters (nVidia Optimus):
Intel HD 4000
nVidia GEForce GTX 680M

Drivers for both are the newest available, and the laptop is brand new so it's not all junked up with stuff (only installs are WoW, Vent, and Mumble). All vendor bloatware is gone due to wipe and clean reinstall of Windows.

My dxdiag can be seen here: http://us.battle.net/wow/en/forum/topic/6572358208
Edited by Tamiller on 9/17/2012 11:42 PM PDT
Reply Quote
90 Night Elf Druid
8560
This thred is related to Display driver stopped working and has recovered error.

For example, I was getting the following error when playing Worldofwarcraft and only world of warcraft:

- Display Driver has stopped responding and has recovered. Display Driver NVIDIA Windows Kernel Mode Driver, Version 306.23 stopped responding and has successfully recovered -

Again the information I provided above has a downside. That being you will not be able to use the DX11 API in WoW until the issue is solved by Nvidia and WoW Dev.

So yes it is a work around. But much better than getting the error all the time and better than nothing.

:)


Try http://support.microsoft.com/kb/2665946 and apply that fix. I was getting hard lock up in dx11 mode too and had to use dx9 until I found this fix. Now I'm back to using dx11 and haven't encounter any lock up since.
Reply Quote
90 Human Priest
7725
Okay. I have a 580 gtx. I have been trying to fix this issue since the patch. I have NO heat issues, I have tried downclocking, running dx9 and dx11, different drivers, all settings on min, running on the onboard video, full screen, windowed, just about everything.

What I have found out is that certain spell effects/textures cause the crashes. I am almost 100% about this. I can do a full bg without issue on all settings min, but almost every dungeon will cause crashing and if I quickly turn my camera the crashes will stop until i see those effects or textures.
Reply Quote
40 Human Rogue
8550
I'm running a recently purchased Alienware 17x. The GPU is a 680m. changing to Dx9 corrected my issue but my performance went down about 30%.

Hopefully there will be a permanent fix to Dx11 soon.


That's unfortunate that your performance went down due to having to use the DX9 workaround. I concur. The sooner a fix is released the better.

Okay. I have a 580 gtx. I have been trying to fix this issue since the patch. I have NO heat issues, I have tried downclocking, running dx9 and dx11, different drivers, all settings on min, running on the onboard video, full screen, windowed, just about everything.

What I have found out is that certain spell effects/textures cause the crashes. I am almost 100% about this. I can do a full bg without issue on all settings min, but almost every dungeon will cause crashing and if I quickly turn my camera the crashes will stop until i see those effects or textures.


Interesting to see that DX9 workaround didn't work for you Azriul. I would possibly suggest then the issue is down to a combination of things then. Let us know if you're able to find a solution or work around. Mind posting your other specs, we may be able to see if it's related to RAM/CPU & 32/64bit clients. Etc

Good luck,

Ultrapotato.

This thred is related to Display driver stopped working and has recovered error.

For example, I was getting the following error when playing Worldofwarcraft and only world of warcraft:

- Display Driver has stopped responding and has recovered. Display Driver NVIDIA Windows Kernel Mode Driver, Version 306.23 stopped responding and has successfully recovered -

Again the information I provided above has a downside. That being you will not be able to use the DX11 API in WoW until the issue is solved by Nvidia and WoW Dev.

So yes it is a work around. But much better than getting the error all the time and better than nothing.

:)


Try http://support.microsoft.com/kb/2665946 and apply that fix. I was getting hard lock up in dx11 mode too and had to use dx9 until I found this fix. Now I'm back to using dx11 and haven't encounter any lock up since.


Thanks for linking this, Zelf. I will try applying said 'fix' and running under the DX11 API again and post here what the results are.

Ultrapotato.
Reply Quote
40 Human Rogue
8550
Haven't heard of this one yet. I'd suggest rolling back to DX9, seeing if that's stable. Then getting back to us here

Did that, but still getting the freezing issue.


Have you tried other drivers? Try uninstalling the 3D vision components of the Nvidia suite too.

List what drivers you've tried and get back to me if you find one that works in a stable manner.

Some individuals have suggested around the 26X.XX mark was performing in a stable manner.

Thanks,

Ultrapotato
Reply Quote
09/13/2012 07:34 PMPosted by Minecraft
GTX580 constant crashing here since patch.
GTX 580 here and no problems at all in Dx11. One Nvidia driver ruined my framerate but that was easily solved by rolling back to my previous driver. I will be trying the newest Nvidia driver this morning once my Starcraft2 update is completed.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]