32 Bit won't launch

(Locked)

100 Goblin Shaman
10490
I cannot get 32 bit WoW to launch. 64 bit continually freezes for me when zoning.

When I try to open 32 bit, it will open in my processes, but no screen comes up. I've tried reinstalling and deleting my bnet folders. What is my next step?

EDIT: To add, I've tried from both the launcher and from wow.exe. I'm on Windows 7.
Edited by Puthi on 9/18/2012 5:43 PM PDT
90 Worgen Warrior
4300
What kind of hardware are you running? Tried updating video display drivers?
100 Goblin Shaman
10490
Yes, I updated all my of drivers. I turned off outside programs, including my AV.

I'm using an i5 3570. I cannot remember what video card I use, but it was bought within the last year so it is not too old.
100 Goblin Shaman
10490
Bump.

I have a GTX 460. I've just tried reinstalling windows, which also didn't work.
100 Goblin Shaman
10490
I'm now on Windows 7 32 bit.... I can only launch in 32, but it still does the same thing. It will open under task manager, but nothing pops up. Not sure what to do now :(
100 Goblin Shaman
10490
Bump. Apparently I'm the only one having this problem.

Maybe there is some type of program needed updating for 32 bit to run?
Edited by Puthi on 9/20/2012 6:45 AM PDT
100 Goblin Shaman
10490
Log Name: Application
Source: Application Error
Date: 9/20/2012 1:00:33 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Ryan-PC
Description:
Faulting application name: Wow.exe, version: 5.0.5.16057, time stamp: 0x504e57af
Faulting module name: appinit_dll.dll_unloaded, version: 0.0.0.0, time stamp: 0x4f2e6809
Exception code: 0xc0000005
Fault offset: 0x6a5daa33
Faulting process id: 0x143c
Faulting application start time: 0x01cd975172820afb
Faulting application path: C:\Program Files\World of Warcraft\Wow.exe
Faulting module path: appinit_dll.dll
Report Id: b070df9c-0344-11e2-ae7b-bc5ff42c2ae0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-09-20T17:00:33.000000000Z" />
<EventRecordID>1052</EventRecordID>
<Channel>Application</Channel>
<Computer>Ryan-PC</Computer>
<Security />
</System>
<EventData>
<Data>Wow.exe</Data>
<Data>5.0.5.16057</Data>
<Data>504e57af</Data>
<Data>appinit_dll.dll_unloaded</Data>
<Data>0.0.0.0</Data>
<Data>4f2e6809</Data>
<Data>c0000005</Data>
<Data>6a5daa33</Data>
<Data>143c</Data>
<Data>01cd975172820afb</Data>
<Data>C:\Program Files\World of Warcraft\Wow.exe</Data>
<Data>appinit_dll.dll</Data>
<Data>b070df9c-0344-11e2-ae7b-bc5ff42c2ae0</Data>
</EventData>
</Event>
100 Goblin Shaman
10490
Fixed it. Apparently a problem with some Asrock MB's. Just had to rename the .dll file.
90 Human Priest
8880
09/20/2012 10:17 AMPosted by Puthi
Fixed it. Apparently a problem with some Asrock MB's. Just had to rename the .dll file.


I'm having a very similar problem. How exactly did you fix it?
I'm getting the same problem - I have an ASRock mobo as well. How did you fix it?
90 Orc Death Knight
6840
how did u do that, I also could not launch it
90 Orc Death Knight
6840
i am dying to know how did u make it work
90 Orc Death Knight
6840
09/20/2012 10:17 AMPosted by Puthi
Fixed it. Apparently a problem with some Asrock MB's. Just had to rename the .dll file.


please reply
100 Goblin Shaman
10490
I just got an in game mail to reply to this, didn't realize anyone had posted here.

All I did was rename the appinit_dll.dll to something different (anything, it doesn't matter). Worked perfectly fine after that.
90 Undead Priest
8690
Hey,
ive tried renaming the Dll
but the same error still comes up
was there anything else you did
what did you rename your dll too
sorry for the last post
just frustrating
100 Blood Elf Priest
19410
ok, i just had this problem as well, after changing out my mobo to an ASRock model... to be clear, the earlier instructions worked, but they could have been a bit more thorough.

the appinit.dll.dll file is in TWO places on your computer. I renamed both. they are located in

c:\windows\system32
c:\windows\SysWOW64

i renamed mine to appinit.dll.dll.renamed

this worked.

hope this helps anyone else with the same problem.
Support Forum Agent
Locking thread as it's last update was in March 2013.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]