MBP Retina acting up w/ WoW GFX

85 Night Elf Priest
6155
Hey guys,

I just bought a brand new Macbook Pro Retina and installed WoW on it a couple of days ago. The specifications are:

OSX Mountain Lion
2.3 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel HD Graphics 4000 512 MB

When I log into WoW past the character screen, the graphics constantly had this weird flickering effect. I turned them down from the 2880x1800 resolution and changed the graphics from "good" to "low" with the exception of view distance. It still occurs randomly.

Not only that but the game has randomly just completely closed down by itself. I don't get a crash reporter or any error message, it'll just completely close. I'm not sure why. Otherwise I'm really enjoying this computer as it's been running the game very very well.
Reply Quote
90 Human Warlock
14105
you dont say if you on 10.8.2 or not but when i updated to 10.8.2 it got rid of the flickering when opening a window.

i have rMBP and its running the game great imo. Im getting constant 30fps with most my settings ultra. (2.6 i7, 8gig RAM) Also make sure that in System Preferences -> Energy Saver that Automatic Graphic Switching is NOT check marked so that you are always using the Nvidia 650M graphics card.

these are my settings and a pic of my fps:

http://i45.tinypic.com/2pqmc28.png

http://i49.tinypic.com/eryf09.png

On the Advanced options everything is Enabled and my max fps is set to 60.
Reply Quote
100 Night Elf Priest
6930
The flickering has gone, and I have figured out the "crashing." I'm actually playing without a mouse because mine recently got stolen and I have yet to replace it and I accidentally hit "Command Q" consistently while playing. I've gone into Mac Options and turned off the Mac OSX Shortcuts but "Command Q" still works unfortunately. Does anyone know how I can fix this?
Edited by Kynalla on 9/26/2012 12:07 AM PDT
Reply Quote
MVP - Technical Support
100 Draenei Mage
6945
09/25/2012 10:40 PMPosted by Kynalla
The flickering has gone, and I have figured out the "crashing." I'm actually playing without a mouse because mine recently got stolen and I have yet to replace it and I accidentally hit "Command Q" consistently while playing. I've gone into Mac Options and turned off the Mac OSX Shortcuts but "Command Q" still works unfortunately. Does anyone know how I can fix this?


Try this :

http://us.battle.net/wow/en/forum/topic/6412494938#5

Credit : Scratchybear of Ursin (Alliance)


To change the Quit menu item in WoW to something other than Cmd-Q (Mac OS 10.8 instsructions):

1. Open System Preferences.
2. Click "Keyboard".
3. Select "Keyboard Shortcuts".
4. Select "Application Shortcuts" from the left menu.
5. Click the "+" button.
6. Set the Menu Title field to "Quit World of Warcraft".
7. Set the Keyboard Shortcut field to whatever you want (I set it to Alt-F4).

I highly recommend doing this and then seeing if your silent crashes go away.


One cavaet : You have to make sure you spell the menu item correctly.

It should be _exactly_ how it appears in the menu. When you add it in the keyboard pref it will have a few symbols after it denoting which keys are used. You can test it's there by opening the world of warcraft client , going to windowed mode and pulling down the File menu. You should see those symbols after the "Quit World of Warcraft" menu item. If you don't see those symbols there it's possible you didn't spell it correctly.

I also think you need to quit and re-open the program it's altering but I'm not sure on that.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]