Swiftmend mouseover macro does not work

90 Blood Elf Priest
8885
I have recently gotten a resto druid to 85 in preparation for Mists, and have been working on mouseover macros for healing. All of my macros work perfectly except for my swiftmend macro. It is identical to the macros for all my other hots, but when I use it when moused over a frame that can be swiftmended, about 50% of the time, instead of using swiftmend, it'll give me a blue hand that makes me click on the target frame to cast it.

Here's my macro; let me know if there's anything wrong with it (it might be a bit overkill, but it works fine with all my other hots and abilities):

#showtooltip swiftmend
/cast [@mouseover,help,exists,nodead] swiftmend; [@target,help,exists,nodead] swiftmend; [@player] swiftmend
Reply Quote
90 Human Warrior
10830
Same thing happens to me. Did you ever get this resolved?
Reply Quote
90 Night Elf Priest
14340
http://www.wowinterface.com/downloads/info21638-SpellStopTargetingButton.html
http://us.battle.net/wow/en/forum/topic/6470987568#3
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]