Videotron: Cant log in, Stuck as "success"


100 Gnome Warlock
Did your IP address changed or anything Ecliptica ?

I'm really a sad, sad panda now...
90 Human Priest
the ping thing i said earlier.....
then to verify my firewall...i entered all port by hand to make sure its not blocked.....wasnt working....and 10 min finally connected to server... so i dont know if its something i did or it just finally connected by itself
90 Human Priest
seems not still 192..

u can try run CMD windows as admin
100 Gnome Warlock
I just talked with a Videotron rep that clearly had no idea what the hell was going on...
he read me an official note that they have within tech reps saying that their Internet service was in no way responsible for the situation, and asked me to call a Blizz tech rep...

Today might be a bad bad day to call Blizz, or even hope that Blizz will read this thread, or work on fixin this issue.

Sad, sad launch...
100 Troll Shaman
can u tell me wich port number u entered so i can try it.........i want to try anything!!!!! im sooo not happy right now and Blizz still doing nothing not even a update about the probleme /sight
100 Troll Shaman
refund ...ur wish will not come true, Blizz don't care about us having issue with the game cus
we are a few that having trouble when logging and why in the hell i can log with my low toon but not my 85.. im so not happy right nowwwwwwwwwwwwwwwwww
Edited by Noldarie on 9/25/2012 8:48 AM PDT
lol...theres a bunch of tech on the forum right now but they clearly ignoring the thread lol..pathetic.
100 Gnome Warlock
I don't think calling them pathetic will actually help... but I understand how people can become very emotional when it seems the two parties say it's not their fault, and you're stuck in between...

I'd bet 5 bucks it's Videotron's fault.. This has to be addressed though... by far the most viewed and talked thread in the whole tech support forum atm

Never give up
Go Blizz !
100 Gnome Warlock
I was finally able to login, no thanks to either Videotron or Blizzard... here is my step by step :

1- go to your command prompt (within the Start menu, it's called Run in Windows versions previous to 7)

2- type ipconfig /release (there is a space between the config and the forward slash)

3- you will lose internet connection, during that time, slap your modem hard time, or punch it if you're very angry (I'm watching YOU). When this is done, either unplug your modem if it doesn't have an internal battery, or if it does, press the reset button and hold it down for TWO LONG MINUTES. This will cause a hard reboot on your Ip

4- Release the reset button, or plug your modem in... it should generate a new IP address.

My old address was, and has been changed to a functionning

Logged in first try after these steps.
Good luck.. and don't hesitate to re-do these steps if you're unlucky and generate another problematic IP address.
Edited by Lycer on 9/25/2012 9:26 AM PDT
90 Night Elf Druid
I have a varierety of problems..
some characters stucks at 90% loading, some will load but are "frozen" - I can see people around, moving, but cant do anything not even logout. Some others will load normally, though. And they are all on the same realm.

I am with Videtron, but can hardly see how a Videtron problem could fit with this erratic behavior from the game.
90 Goblin Hunter
Seriously im stuck at the !@#$ing same place SUCCESS like 3 day ago and i cant install MOP.... and no one answer my ticket....

Videotron or Blizzard the problem ???

I just want to play ....

Seriously blizzard wake up plz
I just did what lycer said

and it worked (for the moment)
100 Tauren Hunter
4 days.... stuck at success
90 Human Warrior
Ignore this post, I found the answer to my question!
Edited by Ragestarved on 9/25/2012 2:02 PM PDT
90 Tauren Druid
Worked 30 min for me yesterday, today nothing ... this is really getting annoying.
100 Night Elf Druid
I tried to change my ip today, did not work at all... /sigh

I'm getting tired of this, in one week we'll have quit Videotron for another company, can't wait...
49 Blood Elf Hunter
Ok, im really tired of this matter.

I make a ticket and then Blizz guide through every step i could do.

When i download the game its downloading perfectly.

They say that my router may not be open, i called the Isp and they say that they dont block any port and even check it again and say that my connection is normal.

I was playing WoW a phew days ago then, suddenly i lost connection then when i try to log back, i got stuck at connecting.

anyone can tell me, which side got the problem ?
Edited by Aelyss on 9/25/2012 6:01 PM PDT
85 Undead Warlock
Try installing spotflux...
I tried everything and that was the only thing that got me in the game.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)