NVIDIA Surround Crashing WoW

90 Human Rogue
15345
Anyone else playing WoW in 64 bit mode and the game crashes the entire pc? I noticed this is only happening with WoW. All three of my pc screens will shut off on their own, and then the pc will freeze. Non responsive to CTRL-ALT-DEL, ALT-F4, or windows button. I can still hear skype and music in the background. I have to force restart my PC at this point. When I play in window mode or Single monitor no problems. Is it the 64 bit client or is WoW not optimized for NVIDIA surround?

Can't be Windows, I just did a fresh OS install of Windows 7 Enterprise. Hardware isn't a issue since I am running 60+ FPS on BF3 in NVIDIA Surround for hours with no issues. Can't be WoW since I freshly installed it and downloaded it. I have no add-ons what soever. Already deleted my WTF, Cache, and Interface folders.

Any suggestions would be helpfulM
Reply Quote
100 Blood Elf Paladin
9210
It's probably drivers. Try older nVidia drivers.
Reply Quote
90 Human Rogue
15345
Will do.
Reply Quote
80 Pandaren Monk
0
I'm having the same problem. I'm running a windows 8 preview fresh install on a brand new gaming rig with triple screen display. My specs are:

- i7 intel processor
- Gigabyte nVidia GeForce GTX 660Ti
- 16GB Kingston Red RAM

I'm getting exactly the same issue. It seems to happen when the graphics card is under heavy load. I'd get kicked to the desktop and everything is unresponsive. Wow won't even crash out properly so the input (mouse) still thinks that it's in the game. This makes it unable to kick out using task manager or any other app or program. I have to hard start my computer to fix the issue. Then there's no telling when ill crash again.
Reply Quote
100 Gnome Warlock
8230
Same thing. Updated the drivers.
Reply Quote
100 Human Paladin
2710
Started dropping me today.. Running dual GTX980's in SLI and when running Surround performance sucks and then it just quits...

Seems to be more a problem since going to Windows10 (why oh why did I do that)

Going to try reinstalling the drivers, might consider downgrading back to 7 for a while...
Reply Quote
100 Orc Shaman
6660
08/23/2015 02:17 PMPosted by Maclellan
Started dropping me today.. Running dual GTX980's in SLI and when running Surround performance sucks and then it just quits...

Seems to be more a problem since going to Windows10 (why oh why did I do that)

Going to try reinstalling the drivers, might consider downgrading back to 7 for a while...


Way to Necro an old thread.

In any case, I'm not having this problem. I'm also on Windows 10 and I have dual GTX 980m's running in SLI. The only thing I have noticed are some stutters but definitely not issues with surround performance.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]