Lua Error mousing over pets in guild bank

90 Night Elf Druid
12925
When I try to mouse over pets within the guild bank I'm being thrown a Lua Error. This is occurring every time I try to mouse over pets within the guild bank. I've tried reloading but it's still not solving the problem. I've disable all of my addons and I'm still being thrown this error. I'm not able to actually see what the pet's names are. I CAN remove them from the bank and see them once they are in my bags. I can also place them back into the guild bank. I can not see their names when I mouse over them while they're still in the guild bank.

Note: Upon requesting a friend do the same, she informed me that she also gets an error thrown at her... but it's only on caged pets... which makes sense because those I'm trying to look at have been 'caged'.

Lua Error:
Message: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: attempt to index field '?' (a nil value)
Time: 09/27/12 17:03:00
Count: 4
Stack: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: in function `BattlePetTooltipTemplate_SetBattlePet'
Interface\FrameXML\BattlePetTooltip.lua:20: in function `BattlePetToolTip_Show'
...AddOns\Blizzard_GuildBankUI\Blizzard_GuildBankUI.lua:643: in function `GuildBankItemButton_OnEnter'
[string "*:OnEnter"]:1: in function <[string "*:OnEnter"]:1>

Locals: tooltipFrame = BattlePetTooltip {
0 = <userdata>
BorderBottomLeft = <unnamed> {
}
speciesID = 1
SpeedTexture = <unnamed> {
}
Background = <unnamed> {
}
HealthTexture = <unnamed> {
}
Speed = <unnamed> {
}
BorderTop = <unnamed> {
}
PetType = <unnamed> {
}
BorderTopLeft = <unnamed> {
}
BorderTopRight = <unnamed> {
}
BorderLeft = <unnamed> {
}
Power = <unnamed> {
}
PowerTexture = <unnamed> {
}
PetTypeTexture = <unnamed> {
}
BattlePet = <unnamed> {
}
Name = <unnamed> {
}
Health = <unnamed> {
}
Level = <unnamed> {
}
BorderBottom = <unnamed> {
}
BorderBottomRight = <unnamed> {
}
BorderRight = <unnamed> {
}
}
data = <table> {
speed = "Tree Frog"
power = 10
speciesID = 1
level = 2
maxHealth = 9
breedQuality = 156
}
(*temporary) = <function> defined =[C]:-1
(*temporary) = <unnamed> {
0 = <userdata>
}
(*temporary) = nil
(*temporary) = 156
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field '?' (a nil value)"
Reply Quote
90 Blood Elf Rogue
6385
having the same problem.
Reply Quote
Same here

Message: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: attempt to index field '?' (a nil value)
Time: 09/29/12 17:34:13
Count: 1
Stack: [C]: ?
Interface\FrameXML\FloatingPetBattleTooltip.lua:94: in function `BattlePetTooltipTemplate_SetBattlePet'
Interface\FrameXML\BattlePetTooltip.lua:20: in function `BattlePetToolTip_Show'
...AddOns\Blizzard_GuildBankUI\Blizzard_GuildBankUI.lua:643: in function `GuildBankItemButton_OnEnter'
[string "*:OnEnter"]:1: in function <[string "*:OnEnter"]:1>

Locals:
Reply Quote
85 Human Paladin
3855
Same problem. Solution Blizz?
Reply Quote
Same
Reply Quote
90 Night Elf Hunter
11690
Same issue.
Reply Quote
46 Troll Priest
10995
Same here. Auction House also is having an issue.
Reply Quote
90 Worgen Mage
10190
Same message here when cursoring over a caged pet:

Message: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: attempt to index field '?' (a nil value)
Time: 10/04/12 18:56:35
Count: 1
Stack: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: in function `BattlePetTooltipTemplate_SetBattlePet'
Interface\FrameXML\BattlePetTooltip.lua:20: in function `BattlePetToolTip_Show'
Interface\FrameXML\ContainerFrame.lua:817: in function `ContainerFrameItemButton_OnEnter'
[string "*:OnEnter"]:1: in function <[string "*:OnEnter"]:1>

Locals: tooltipFrame = BattlePetTooltip {
0 = <userdata>
BorderBottomLeft = <unnamed> {
}
speciesID = 175
SpeedTexture = <unnamed> {
}
Background = <unnamed> {
}
HealthTexture = <unnamed> {
}
Speed = <unnamed> {
}
BorderTop = <unnamed> {
}
PetType = <unnamed> {
}
BorderTopLeft = <unnamed> {
}
BorderTopRight = <unnamed> {
}
BorderLeft = <unnamed> {
}
Power = <unnamed> {
}
PowerTexture = <unnamed> {
}
PetTypeTexture = <unnamed> {
}
BattlePet = <unnamed> {
}
Name = <unnamed> {
}
Health = <unnamed> {
}
Level = <unnamed> {
}
BorderBottom = <unnamed> {
}
BorderBottomRight = <unnamed> {
}
BorderRight = <unnamed> {
}
}
data = <table> {
name = "Phoenix Hatchling"
speciesID = 175
level = 1
petType = 7
}
(*temporary) = <function> defined =[C]:-1
(*temporary) = <unnamed> {
0 = <userdata>
}
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field '?' (a nil value)"
Reply Quote
100 Night Elf Druid
12195
also getting this error (no addons active). still an issue.
Edited by Nymirah on 10/7/2012 2:01 PM PDT
Reply Quote
80 Undead Priest
8790
reporting same issues here too.

Also noted that after the error is first thrown icons for deposited items can become confused. Wrong icon/tooltip is displayed once new item is deposited into bank. When returned to bags icon is correct/

Message: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: attempt to index field '?' (a nil value)
Time: Fri Oct 12 20:15:16 2012
Count: 7
Stack: Interface\FrameXML\FloatingPetBattleTooltip.lua:94: in function `BattlePetTooltipTemplate_SetBattlePet'
Interface\FrameXML\BattlePetTooltip.lua:20: in function `BattlePetToolTip_Show'
...AddOns\Blizzard_GuildBankUI\Blizzard_GuildBankUI.lua:643: in function `GuildBankItemButton_OnEnter'
[string "*:OnEnter"]:1: in function <[string "*:OnEnter"]:1>

Locals: tooltipFrame = BattlePetTooltip {
0 = <userdata>
BorderBottomLeft = <unnamed> {
}
speciesID = 1
SpeedTexture = <unnamed> {
}
Background = <unnamed> {
}
HealthTexture = <unnamed> {
}
Speed = <unnamed> {
}
BorderTop = <unnamed> {
}
PetType = <unnamed> {
}
BorderTopLeft = <unnamed> {
}
BorderTopRight = <unnamed> {
}
BorderLeft = <unnamed> {
}
Power = <unnamed> {
}
PowerTexture = <unnamed> {
}
PetTypeTexture = <unnamed> {
}
BattlePet = <unnamed> {
}
Name = <unnamed> {
}
Health = <unnamed> {
}
Level = <unnamed> {
}
BorderBottom = <unnamed> {
}
BorderBottomRight = <unnamed> {
}
BorderRight = <unnamed> {
}
}
data = <table> {
speed = "Blue Moth"
power = 10
speciesID = 1
level = 2
maxHealth = 9
breedQuality = 156
}
(*temporary) = <function> defined =[C]:-1
(*temporary) = <unnamed> {
0 = <userdata>
}
(*temporary) = nil
(*temporary) = 156
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field '?' (a nil value)"
Reply Quote
Also having this problem. It is also keeping the icons in place on the guild vault tab. For example, I stored 3 blue moths. I withdraw them, and when I re-deposit items on those formerly used spaces, the pet icon is displayed rather than that of the actual item. As a result, I now have a near useless page in my guild vault.

Did anyone ever get a solution?
Reply Quote
90 Tauren Warrior
11980
Having the same issue here, disabled all addons. Still does it.
Reply Quote
90 Undead Warlock
14750
Did anyone ever find a solution, because I'm still having this problem :(.
Reply Quote
90 Blood Elf Priest
14705
11/23/2012 10:21 AMPosted by Shadowballz
Did anyone ever find a solution, because I'm still having this problem :(.


Disable showing Lua errors would be the simplest.
Reply Quote
90 Draenei Paladin
14600
Having this exact same error, along with the stuck icon in the guild vault for the two slots.

Hoping Blizzard gets to this soon. It's quite annoying since it's the only error I get, but everybody on my guild experiences it as well.
Reply Quote
90 Dwarf Paladin
8725
Same error
Reply Quote
90 Troll Druid
13725
same problem --- I'm the bank/guild alt for my main and it happens EVERY first time (per login session) my mouse goes over the pets in the guild bank.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]