upgraded to MoP, but its not working..

(Locked)

90 Orc Shaman
8125
So i upgraded to MoP and my battle.net says:

PRODUCT LEVEL
Mists of Pandaria
Standard Edition

But when i log in game it still has the upgrade thing to left and i cant level past 85 or make a monk.
Support Forum Agent
So i upgraded to MoP and my battle.net says:

PRODUCT LEVEL
Mists of Pandaria
Standard Edition

But when i log in game it still has the upgrade thing to left and i cant level past 85 or make a monk.


Did you happen to be logged in when you upgraded?

I'd log all the way out to desktop and relaunch first.
90 Orc Shaman
8125
So i upgraded to MoP and my battle.net says:

PRODUCT LEVEL
Mists of Pandaria
Standard Edition

But when i log in game it still has the upgrade thing to left and i cant level past 85 or make a monk.


Did you happen to be logged in when you upgraded?

I'd log all the way out to desktop and relaunch first.


i did it when the servers were down for maintenance, i even restarted my computer and still nothing.
Support Forum Agent
Just gave this a little tap - please fully relog and see if you see any changes.
90 Orc Shaman
8125
09/28/2012 11:49 AMPosted by Orlyia
Just gave this a little tap - please fully relog and see if you see any changes.


success!
Support Forum Agent
09/28/2012 11:51 AMPosted by Evílyn
Just gave this a little tap - please fully relog and see if you see any changes.


success!


Excellent! Enjoy.
90 Night Elf Druid
4920
This is also a problem for me.

I purchased a digital download card from Wal-Mart, entered the code, and though my account says that it has been upgraded, the game does not recognize the upgrade. This problem has been persistent for the past ten hours.
Support Forum Agent
This is also a problem for me.

I purchased a digital download card from Wal-Mart, entered the code, and though my account says that it has been upgraded, the game does not recognize the upgrade. This problem has been persistent for the past ten hours.


Gave this a little nudge, Enzro. On your next login check for your pet and mount. If those come through, this is resolved - although it may still visually show 'standard' instead of 'deluxe', that is a current display error.
100 Human Priest
10895
I have the exact issue as well...
Support Forum Agent
Check for your pet and mount on your next login, Térra.
4 Pandaren Monk
0
I upgraded from the starter edition but when I start the game it still says starter edition. Do I need a nudge or do I need to re download the game? It also says trial when I start the game.Under my order history, the status is queued. What does that mean? Thanks!
Edited by Minyun on 9/29/2012 10:43 AM PDT
Support Forum Agent
09/29/2012 10:40 AMPosted by Minyun
I upgraded from the starter edition but when I start the game it still says starter edition. Do I need a nudge or do I need to re download the game? It also says trial when I start the game.Under my order history, the status is queued. What does that mean? Thanks!


If you did a digital upgrade, normal time is about 72 hours for full functionality to kick in.

Leveling caps are instantly removed.
4 Pandaren Monk
0
Thank you!
100 Human Priest
10895
Working great now! Thank you!
32 Blood Elf Hunter
390
I have the same problem, got a Digital Deluxe Edition card from Walmart and battle.net says i have standard edition and can't seem to find how to get to The Jade Forest and no mount or pet. Character screen still has Upgrade Now on left hand side.
Support Forum Agent
Check your mail for your pet and mount on your next login, Dundee.

There is a quest that should popup to get to Jade Forrest. That's really not related to this other condition.
Having the same issue with the WalMart Deluxe Edition. No quests, no mounts, nothing. Account even says "pending" for some odd reason. Completely shut down the computer and relaunched everything, still nothing.
Support Forum Agent
09/29/2012 11:44 AMPosted by Ragetiger
Having the same issue with the WalMart Deluxe Edition. No quests, no mounts, nothing. Account even says "pending" for some odd reason. Completely shut down the computer and relaunched everything, still nothing.


Check this on your next login, Rage. It's not going to work until your next login at the earliest.
09/29/2012 11:53 AMPosted by Orlyia
Having the same issue with the WalMart Deluxe Edition. No quests, no mounts, nothing. Account even says "pending" for some odd reason. Completely shut down the computer and relaunched everything, still nothing.


Check this on your next login, Rage. It's not going to work until your next login at the earliest.


That got it going. Had logged out completely 4 times prior when i first saw this thread so I did that a few times before posting. Thanks again.
32 Blood Elf Hunter
390
Thanks, that did it !!! Everything is OK now. You're great, keep up the good work, Blizzard should be proud of you.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]