Upjade Complete!!! TIAN MONASTERY PROBLEM!

90 Blood Elf Death Knight
0
I've been through all of Jade Forest looking for a quest or something to lead me to finish the Tian monastery for credit for the [Upjade Complete!] quest but can't find any leads or connections, and I've found other people having the same problem.
Reply Quote
90 Blood Elf Death Knight
0
Found my own solution! If you can't find anymore quests and you're positive you've done everything restart the game and you should get it when you log back into that character!
Reply Quote
90 Human Death Knight
18480
Had the same problem, just relogged - got the achievement.
Reply Quote
Relogging worked for me, too.
Reply Quote
90 Human Warlock
10075
Same here. Wasted like 30 minutes looking for a quest that was already complete.
Reply Quote
90 Goblin Rogue
10860
I experienced the same problem.
Reply Quote
90 Human Mage
16665
Same. Relog and get achievement.

Please, fix this.
Reply Quote
Same problem as all the others. Just relog and get your achievement!
Reply Quote
90 Tauren Druid
19005
I have scoured Tian Monastery, and the surrounding zones. No quests. Tried relogging. No avail.

/cry

*Edit. It worked when hearthed back to Org. Weird.
Edited by Baurok on 9/26/2012 1:58 PM PDT
Reply Quote
90 Blood Elf Paladin
9610
Confirmed: If you relog and it doesn't work, hearth. I hearthed to Dalaran, and got the achievement marker.

It doesn't pop up...it's just there in green where it wasn't before.
Reply Quote
89 Goblin Warlock
5560
I relogged and hearthed, still didn't show up... keeping me from getting Upjade Complete, kind of disappointing.
Reply Quote
90 Blood Elf Priest
5580
Same here, reloaded and got the achievement
Reply Quote
Quality Assurance
Just added this to the known issues list. Thanks for the reports!
Reply Quote
90 Blood Elf Hunter
12115
Thanks. My friend had this problem the other day and we looked all over trying to figure it out, but never could. He just gave up. And today I was having that problem on my druid and this really helped :) Thanks again.
Reply Quote
90 Blood Elf Warrior
7325
i trued doing this but didnt work for me and i hhave ran up and down the place but no qeast what should i do
Reply Quote
90 Tauren Druid
5065
The same thing has happened. I have reloaded, restarted, hearthstone to Org and nothing has fixed this problem for me.
Reply Quote
90 Worgen Rogue
6280
Had the same problem since i dropped quests left zone then came back decided to complete did some quests the monastery one was missing for achieve i relogging and it worked.
Reply Quote
90 Gnome Priest
5930
I am having the same problem, and I tried all these things, and nothing is working. I even rebooted my computer. Hope this gets fixed soon.
Reply Quote
90 Undead Mage
7455
Had the same problem...relogged did not work...hearthed to Org and that did the trick
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]