Radeon 6950, 23 fps.

90 Worgen Hunter
6035
I've downloaded the latest drivers, including the extra ones released on 9/25 that say they resolve performance issues with the 64bit client of Mists of Pandaria. I'm in Jade Forest and my FPS will not ago above 23, settings at Ultra. We all know a 6950 2g OC edition should get well over 23 FPS with Ultra settings. What's going on?

Btw, SW is abnormally low, as is everywhere else, but higher. Around 30.
Reply Quote
80 Orc Mage
0
Turn down your shadows to High but yes you should be getting higher than that. I have an XFX 6950 2GB

Check your catalyst control centre. Make sure your anti aliasing is set to Use Application settings
Edited by Yousel on 9/26/2012 9:40 PM PDT
Reply Quote
90 Worgen Hunter
6035
AA is already set for app settings. Lowering shadows helps, but not by much, and a 6950 seriously shouldn't have any problems running WoW at all.
Reply Quote
80 Orc Mage
0
In the Pandaren starting zone I am getting 60-100fps depending on what is on screen. In Jade forest I dip down to 35fps at times.

Do you get the same FPS with all addons disabled?
Reply Quote
85 Tauren Warrior
3150
EXACT same problem here.

23fps WITH A RADEON 5970!!!

sigh...Blizzard has really really urked me to looking towards other upcoming companies. I cannot believe Diablo 3 and now THIS. :(

Any fixes let me know Evan.

Wrain
Reply Quote
76 Draenei Hunter
1775
I've downloaded the latest drivers, including the extra ones released on 9/25 that say they resolve performance issues with the 64bit client of Mists of Pandaria. I'm in Jade Forest and my FPS will not ago above 23, settings at Ultra. We all know a 6950 2g OC edition should get well over 23 FPS with Ultra settings. What's going on?

Btw, SW is abnormally low, as is everywhere else, but higher. Around 30.


Those actually weren't drivers, they were an application profile.

They only work for ATI cards in CrossFireX, or multiple cards in one system. If you don't have that, then that won't make any difference for you.
Edited by Hunteryx on 9/27/2012 12:35 AM PDT
Reply Quote
90 Worgen Hunter
6035
Yes they're not exactly drivers, but I was under the impression that the details specifying "does X for X in crossfire mode," are the details pertaining to Xfire. One would think they wouldn't specify Crossfire for certain solutions and not others if the whole profile is made exclusively for Crossfire solutions.

Regardless, it didn't do anything. And yes my FPS doesn't change at all with all addons disabled. Turning shadows down changes the FPS, but i've discovered a few new things as well.

I made 2 new monk characters, one a night elf, one a blood elf. In the Night elf starting zone, all settings were set to ultra. The interesting bit is that there were no shadows when the selector clearly said there were ultra ones. I tried changing the options to high, medium, low, respectively, and all it seemed to do was change a slight blob shadow and what appeared to be basic shaders on things like my character and scenery, along weith the local mobs.

In the blood elf area, same story, except now we have shadows, they're just terrible. I would pin them at looking like Medium quality. There was also no grass. The ground itself was textures fine, but there was no rendered grass or ground clutter whatsoever, despite the selector clearly stating ultra settings. Changing this selector did nothing. As did the shadow selector.

What. The hell. Is going on....?
Reply Quote
90 Night Elf Druid
6105
this is frikked up so u guys with ati having issues... and me i personally bought a new gtx 480 and powersupply for mop and even if i drop all settings to low i get 40 fps sooooooooo freakin crap.. and yes if they dont fix this ill just quit wow until it is... ive tried clean install of drivers even went as far to reinstall windows 7 and wow... still sammmmmme crap! i tried EVEN OLDER DRIVERS SAME!!! CRAP!!! Eerrrrrrrr
Edited by Vikaelz on 9/27/2012 1:13 AM PDT
Reply Quote
87 Undead Warrior
6905
The problem lies within the DirectX files. You have to go to Microsoft.com and download the standalone installer. That should clear up some FPS.

The other issue that is causing it is that if you have a 64bit OS, the program will have issues using over 2 cores.

In order to fix this, you must do this:

Start WoW. Alt-Tab out and open up Task Manager (CTRL-ALT-DEL). Find Wow-64.exe in the Processes tab. Right click it and select "Set Affinity". Un-check the first CPU core (CPU 0). Tab back into WoW and watch your FPS magically be better. You'll need to do this anytime you start up a new WoW.

That only works if you have a 64bit OS installed. Unfortunately, blizzard has not release a hotfix to solve this problem as of yet.
Reply Quote
87 Undead Warrior
6905
Here is a more detailed fix to this problem. Let me know if it helps.

This is a driver/hardware related error. What I have gotten from this is that the main issue is the GPU/DirectX/Multi-core function. I will provide solutions to all of these.

GPU Drivers (Graphics Card):

1) First of all you need to download Driver Sweeper. You can find this online.
2) Use Driver Sweeper to uninstall your Display Drivers. It will look either like ATI Display or nVidia Display.
3) Restart you computer.
4) Once you are back in Windows, Re-download your GPU's "Release" Drivers, Do not download the Beta Drivers. They have been having issues with WoW and other Games.
5) Restart your computer.
6) Now you need to download and update your DirectX. To do this, go to Microsoft.com and click on "Downloads". Then search for "DirectX Runtime". This should send you to a list of options. You want to find the DirectX Runtime installer and download that. It will download a standalone installer that will update your DirectX.
7) Restart you computer.
8) Once back into Windows, run the launcher and attempt to play. It should work.

If by chance it happens again, and you have a Multi-core CPU, you need to follow these instructions every time you play until a hot fix is released.

Start WoW. Alt-Tab out and open up Task Manager (CTRL-ALT-DEL). Find Wow-64.exe in the Processes tab. Right click it and select "Set Affinity". Un-check the first CPU core (CPU 0). Tab back into WoW and watch your FPS magically be better. You'll need to do this anytime you start up a new WoW.

The error should not happen once you do this.

Let me know if this helps!
Reply Quote
85 Gnome Rogue
7865
try this ..

set everything to low , and one by one increse the settings .. it worked for me and my fps never dipped below 60 again !! after 2 days of trying pretty much everything i could think of ... now to finally start questing . :) i hope it works for you guys
Reply Quote
85 Tauren Druid
6355
Hey gang. Just reporting in on my end. JUST built a new machine on Monday. It's a beast (intel 3770k, 8G Gskill Ripjaw, 1k PSU, Ridiculous Asus MoBo). My GPU is a Radeon 7970 ($440 card...) and I get less than 40 FPS everywhere. I can run anything else at stupid-max settings. So, It's not a hardware issue. Period.
Reply Quote
40 Tauren Shaman
3050
.
Edited by Veggießull on 9/27/2012 8:59 AM PDT
Reply Quote
76 Draenei Hunter
1775
Yes they're not exactly drivers, but I was under the impression that the details specifying "does X for X in crossfire mode," are the details pertaining to Xfire. One would think they wouldn't specify Crossfire for certain solutions and not others if the whole profile is made exclusively for Crossfire solutions.

Regardless, it didn't do anything. And yes my FPS doesn't change at all with all addons disabled. Turning shadows down changes the FPS, but i've discovered a few new things as well.

I made 2 new monk characters, one a night elf, one a blood elf. In the Night elf starting zone, all settings were set to ultra. The interesting bit is that there were no shadows when the selector clearly said there were ultra ones. I tried changing the options to high, medium, low, respectively, and all it seemed to do was change a slight blob shadow and what appeared to be basic shaders on things like my character and scenery, along weith the local mobs.

In the blood elf area, same story, except now we have shadows, they're just terrible. I would pin them at looking like Medium quality. There was also no grass. The ground itself was textures fine, but there was no rendered grass or ground clutter whatsoever, despite the selector clearly stating ultra settings. Changing this selector did nothing. As did the shadow selector.

What. The hell. Is going on....?


CrossFire traditionally has problems with some games because they were never coded to take advantage of them to begin with. WoW is one of those games. In fact, using multiple GPU's used to only give you a 20% boost.

If you have a CrossFire system, you need the application profiles to correctly run them. If not, you don't.

Blizzard changed some shaders and lighting with Mists of Pandaria, and it's hitting systems harder than usual. It might be the cause of all the graphical anamolies you see.

The Draenei character select screen now looks horrible, because the lighting in the background is dimmer.
Reply Quote
90 Worgen Hunter
6035
Here is a more detailed fix to this problem. Let me know if it helps.

This is a driver/hardware related error. What I have gotten from this is that the main issue is the GPU/DirectX/Multi-core function. I will provide solutions to all of these.

GPU Drivers (Graphics Card):

1) First of all you need to download Driver Sweeper. You can find this online.
2) Use Driver Sweeper to uninstall your Display Drivers. It will look either like ATI Display or nVidia Display.
3) Restart you computer.
4) Once you are back in Windows, Re-download your GPU's "Release" Drivers, Do not download the Beta Drivers. They have been having issues with WoW and other Games.
5) Restart your computer.
6) Now you need to download and update your DirectX. To do this, go to Microsoft.com and click on "Downloads". Then search for "DirectX Runtime". This should send you to a list of options. You want to find the DirectX Runtime installer and download that. It will download a standalone installer that will update your DirectX.
7) Restart you computer.
8) Once back into Windows, run the launcher and attempt to play. It should work.

If by chance it happens again, and you have a Multi-core CPU, you need to follow these instructions every time you play until a hot fix is released.

Start WoW. Alt-Tab out and open up Task Manager (CTRL-ALT-DEL). Find Wow-64.exe in the Processes tab. Right click it and select "Set Affinity". Un-check the first CPU core (CPU 0). Tab back into WoW and watch your FPS magically be better. You'll need to do this anytime you start up a new WoW.

The error should not happen once you do this.

Let me know if this helps!


That made it worse.
Reply Quote
80 Orc Mage
0
Yeah, don't change the affinity on your processor. WoW uses 4 Cores no problem.
Reply Quote
90 Dwarf Warrior
3635
09/27/2012 05:28 AMPosted by Ozolus
Hey gang. Just reporting in on my end. JUST built a new machine on Monday. It's a beast (intel 3770k, 8G Gskill Ripjaw, 1k PSU, Ridiculous Asus MoBo). My GPU is a Radeon 7970 ($440 card...) and I get less than 40 FPS everywhere. I can run anything else at stupid-max settings. So, It's not a hardware issue. Period.


THIS. THIS. THIS.

I just echoed what you said in another thread that I made about my own graphics problem, it's about the 20th thread I've made in the past three weeks, in yet another attempt to get Blizzard to wake up to this.

This is what Blizzard refuses to acknowledge. That players who have built brand new rigs, in your case, LITERALLY days ago, BRAND NEW, are STILL having this problem.

How can a rig that's brand new, with no corruption, new video card, fresh operating system, fresh install of WoW, plenty of RAM, overkill on everything, only be getting 40 FPS in WoW????????

There is only one answer to what is causing it: THE 5.0.4 BLIZZARD PATCH.

And this concludes my little skit :)
Reply Quote
90 Dwarf Warrior
3635
I've downloaded the latest drivers, including the extra ones released on 9/25 that say they resolve performance issues with the 64bit client of Mists of Pandaria. I'm in Jade Forest and my FPS will not ago above 23, settings at Ultra. We all know a 6950 2g OC edition should get well over 23 FPS with Ultra settings. What's going on?

Btw, SW is abnormally low, as is everywhere else, but higher. Around 30.


OMG, heck YEAH....with a 6950 2g OVERCLOCKED???? You should be getting 100+ FPS EASY!

I'm getting 80-85 FPS out in the normal game environment, with my settings on Ultra(except for shadows and sunshafts which are lower), and I'm getting 80-85 FPS, 50s-70s in cities and in dungeons and raids, and that's with my two year old HD 5870 1g!

This ain't your hardware, this is on Blizzard's end.
Edited by Fori on 9/27/2012 3:32 PM PDT
Reply Quote
90 Tauren Death Knight
10415
Same issue here, HD 7970 graphics card, 8 gigs of ram, and an i5 3570k at 4.2 ghz

I'm struggling to get above 45 fps anywhere when I get 60+ fps in BF3 on ultra. I have no clue what is going on. I built this system last week.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]