Radeon 6950, 23 fps.

90 Dwarf Warrior
3635
09/28/2012 12:07 AMPosted by Vikaelz
Are you guys not listening to what i said??? do a system restore b4 u made critical updates your game will be back to solid smoothness 60 fps its confirmed by others


We gotcha, I know that some players have done as you have, and it's corrected their graphics issues, with regard to FPS.

It's just that a lot of other players have also tried that, and it didn't do anything to help.

To me, this is yet more evidence that the problem lies in Blizzard's Update itself, and has little or nothing do in most cases with troubleshooting individual people's rigs.
Reply Quote
90 Orc Warrior
10025
Still rocking 240fps without any problems. Glad to be a Nvidia owner these days :)
Reply Quote
90 Human Warrior
3690
That moment when my 3 year old GTS 250 is getting 40-50 fps on high.
I thought Radeon drivers had improved, guess not :P
Reply Quote
90 Night Elf Rogue
11305
im running a HiS Radeon 4670 with max everything settings and im running lowest 25 fps, highest 75 fps, so something is deff wrong with his card lol
Edited by Stabzu on 9/28/2012 10:29 AM PDT
Reply Quote
56 Goblin Mage
2240
I'm running a XFX Radeon hd 6950 and i think the crossfire is giving us this issue. everytime i go into combat i would be stuck on the same screen for 5 sec and i cast some stuck again. I can't lvl with this problem. I NEED them to fix this freaking issue asap.
Reply Quote
90 Dwarf Warrior
3635
09/28/2012 10:17 AMPosted by Horrorfilm
Still rocking 240fps without any problems. Glad to be a Nvidia owner these days :)


Horrorfilm...... Are you aware at just how much noone cares what you're saying in this thread?

Um - just go away please? And please go pat yourself on the back for being Master of the Universe somewhere else?

THANKS, you have a great day, take care now, bye bye then!

P.S. - Spend ten minutes browsing the threads.....there are hundreds of posts of players with Nvidia cards who's WoW is crashing or freezing up since the 5.0.4 Update. Not sure what you're taking, but I'd like some as well so I can experience the same level of delusion you are enjoying.
Reply Quote
90 Dwarf Warrior
3635
09/28/2012 10:17 AMPosted by Horrorfilm
Still rocking 240fps without any problems. Glad to be a Nvidia owner these days :)


And.....I hate to break this to you....

But you DO realize that any FPS over 60 is redundant and makes no visual difference in the game. You DO get that right? In FACT, the game actually looks its BEST and plays its BEST when the FPS is kept right at and hovering at 60, when it's in tune with your monitor's refresh rate. What you're doing is simply overkill for nothing more than stroking your own chain.

I can get 100-115 FPS with my HD 5870 if I wanted, but I use Vertical Sync to cap it at 60 FPS because there's no point in having a higher FPS.

I'm sure it feels really nifty for you to brag about....but I could sit here and tell everyone that I'm getting 500 FPS in WoW, and, well, the response is...... ok? And?.......

The only thing you are doing by playing WoW at 240 FPS is working your card harder than it needs to and heating it up more than necessary.
Reply Quote
80 Orc Mage
580
I have a screenshot of me getting 500 fps in WoW...brb

http://i.imgur.com/XQvKw.jpg

BOOM 593!

My card promptly heated up to around 80Celcius
Edited by Yousel on 9/28/2012 2:14 PM PDT
Reply Quote
90 Dwarf Warrior
3635
I have a screenshot of me getting 500 fps in WoW...brb

http://i.imgur.com/XQvKw.jpg

BOOM 593!

My card promptly heated up to around 80Celcius


Exactly!
Reply Quote
90 Worgen Hunter
6035
None of this seems to be helping my problem. Especially the arguing. Things like that deter Blue answers.
Reply Quote
I run around 61-65 FPS on ULTRA (I have it limited) if I remove the limit, I reach around 180+ FPS on the game but it's useless and works my graphic card. It almost stutters the graphics do. They "jolt" every few seconds or so. Almost like someone is thumping the screen and the graphics stutter or jump. It's my character and the scenery around me. I have an 11s ms to home and to world.

I have

Quadcore i7 2720QM
HD 6970M 2gig dedicated graphic ram
8 gigs of dual channel ram DDR3
7200 rpm hard drive
and an extremely fast internet connection
Never had this issue before and it's driving me nuts

The screen literally jolts and almost lags like latency or low FPS but I don't have those issues.

Any help? Thanks.
Reply Quote
80 Orc Mage
580
I run around 61-65 FPS on ULTRA (I have it limited) if I remove the limit, I reach around 180+ FPS on the game but it's useless and works my graphic card. It almost stutters the graphics do. They "jolt" every few seconds or so. Almost like someone is thumping the screen and the graphics stutter or jump. It's my character and the scenery around me. I have an 11s ms to home and to world.

I have

Quadcore i7 2720QM
HD 6970M 2gig dedicated graphic ram
8 gigs of dual channel ram DDR3
7200 rpm hard drive
and an extremely fast internet connection
Never had this issue before and it's driving me nuts

The screen literally jolts and almost lags like latency or low FPS but I don't have those issues.

Any help? Thanks.


You are in luck as I know the answer to this one. Enable Reduce Input Lag and Max Foreground FPS (max it out)
Reply Quote
90 Dwarf Warrior
3635
09/28/2012 05:04 PMPosted by Evanesco
None of this seems to be helping my problem. Especially the arguing. Things like that deter Blue answers.


09/28/2012 05:04 PMPosted by Evanesco
None of this seems to be helping my problem. Especially the arguing. Things like that deter Blue answers.


Evanesco, you're absolutely right, the arguing doesn't help solve the problem, I get caught up in it too easily. I was just trying to get rid of the Nvidia Troll that's all.

Hey, this might seem long a really long shot, but back before the MOP Patch, like around early June, my WoW suddenly dropped into the low 20's FPS. The day before I was getting a solid 60 FPS everywhere, and suddenly it just tanked and bottomed out. A friend and I went through settings, and we solved it by turning "Reduce Input Lag" OFF. It seems that with at least some AMD cards, Reduce Input Lag really kills FPS. Also, I discovered with Reduce Input Lag off, it doesn't affect my gameplay in the least, doesn't have any negative effect to have it turned off. Also, I have my Filtering and Multisampling very low, Multis is 1x, and Filtering is 4x.

Set those three things, and see what happens. Simple, but it makes a big difference. Also, to echo what others have said, DEFINITELY set all CCC Settings to "Application".
Edited by Fori on 9/28/2012 6:17 PM PDT
Reply Quote
90 Dwarf Warrior
3635
09/28/2012 05:04 PMPosted by Evanesco
None of this seems to be helping my problem. Especially the arguing. Things like that deter Blue answers.


Evanesco,

There is ONE strange tidbit I would like to add to my post above.

BEFORE the MOP patch, Having "Reduce Input Lag turned" OFF helped to INCREASE my FPS significantly, as well as keeping Filtering and Multis. low.

NOW, since the MOP patch, it seems like having Reduce Input Lag ON is mysteriously actually helping my performance and is no longer causing FPS problems. But I still have Filtering and Mutlis. low, in fact those are set to WoW's recommended settings. CCC is still left alone. And of course, my Crossfire is disabled.

Last night, I was able to finally make what SEEMS like a fix for the graphics stutter I have been suffering since August 29th, the day of 5.0.4(a day that will live in infamy).

What I did was change the settings to the ones I described above. In addition, I currently have my API switched over to DX 9 instead of DX 11. Also, make sure you have your Max. Foreground and Max. Background FPS both set to about the middle.

I also switched the game over to 32 bit mode.

I also have Vertical Sync and Triple Buffering both Enabled, in order to keep my FPS capped at 60, to jive with my monitor's refresh rate of 60 hertz. I personally believe that Vertical Sync is one of the key settings in all this mess. Because if you allow your video card to just peak out and run at its maximum capacity and capabilities, yes you'll get really cool frame rates of 100-200 FPS, but it doesn't help the appearance of the game at all, and you'll just be heating up your card unnecessarily.

Go figure. This whole mess with this 5.0.4 patch has pushed all of us into Bizarro Land.
Edited by Fori on 9/28/2012 6:19 PM PDT
Reply Quote
90 Worgen Hunter
6035
09/28/2012 06:16 PMPosted by Fori
None of this seems to be helping my problem. Especially the arguing. Things like that deter Blue answers.


Evanesco,

There is ONE strange tidbit I would like to add to my post above.

BEFORE the MOP patch, Having "Reduce Input Lag turned" OFF helped to INCREASE my FPS significantly, as well as keeping Filtering and Multis. low.

NOW, since the MOP patch, it seems like having Reduce Input Lag ON is mysteriously actually helping my performance and is no longer causing FPS problems. But I still have Filtering and Mutlis. low, in fact those are set to WoW's recommended settings. CCC is still left alone. And of course, my Crossfire is disabled.

Last night, I was able to finally make what SEEMS like a fix for the graphics stutter I have been suffering since August 29th, the day of 5.0.4(a day that will live in infamy).

What I did was change the settings to the ones I described above. In addition, I currently have my API switched over to DX 9 instead of DX 11. Also, make sure you have your Max. Foreground and Max. Background FPS both set to about the middle.

I also switched the game over to 32 bit mode.

I also have Vertical Sync and Triple Buffering both Enabled, in order to keep my FPS capped at 60, to jive with my monitor's refresh rate of 60 hertz. I personally believe that Vertical Sync is one of the key settings in all this mess. Because if you allow your video card to just peak out and run at its maximum capacity and capabilities, yes you'll get really cool frame rates of 100-200 FPS, but it doesn't help the appearance of the game at all, and you'll just be heating up your card unnecessarily.

Go figure. This whole mess with this 5.0.4 patch has pushed all of us into Bizarro Land.


None of that did anything and I don't know how to switch bit versions
Reply Quote
90 Dwarf Warrior
3635
I run around 61-65 FPS on ULTRA (I have it limited) if I remove the limit, I reach around 180+ FPS on the game but it's useless and works my graphic card. It almost stutters the graphics do. They "jolt" every few seconds or so. Almost like someone is thumping the screen and the graphics stutter or jump. It's my character and the scenery around me. I have an 11s ms to home and to world.

I have

Quadcore i7 2720QM
HD 6970M 2gig dedicated graphic ram
8 gigs of dual channel ram DDR3
7200 rpm hard drive
and an extremely fast internet connection
Never had this issue before and it's driving me nuts

The screen literally jolts and almost lags like latency or low FPS but I don't have those issues.

Any help? Thanks.


Danvic,

OMG this is the EXACT SAME problem I have been having for a MONTH, since the day they released 5.0.4. And just like you, I NEVER had this problem before this!

My only major difference hardware wise is that I have an ATI HD 5870 1 GB, but otherwise we're running comparable rigs.

Here's two of my original posts so you can see how similar our problems are:

http://us.battle.net/wow/en/forum/topic/6712832704?page=2

http://us.battle.net/wow/en/forum/topic/6572269995

That "jerk" and "stutter" and "jolt" you describe is EXACTLY what I have been experiencing, like you said, almost as if someone is physically "jolting" the terrain in the game as we're moving.

When I am going past a mountain range or a tree, I carefully turn the camera sideways so i can watch the terrain as it passes by. And it's like......normal.....normal........normal.....then suddenly a split-second "jerk" and "twitch", then another three seconds of normal, and then the "jerk" again.

Well, my personal journey with this problem has taken me into the realm of Bizarro World.
You can jump over and read in my other threads all the things I have tried to resolve it, I won't waste redundant time and space here just typing it all over again.

But, as you can clearly see in my other threads, I have tried every known fix that has been thrown at this thing.

In any case, as usual, it's been left up to the players themselves to network and help each other solve this disaster...The Blues are shooting in the dark, insisting that this can be solved by examining people's rigs one at a time, which is almost always redundant and useless.

SO, down to business.

As of YESTERDAY, I was still having the stutter and jerk, and it was still game-wide.

Last night, I tried yet again to do a round of troubleshooting to see if I could fix this thing.

As of last night, I have my CCC Settings all set to "Application" or "Performance", letting applications handle all graphics elements.

I have my WoW Graphics settings all set to "recommended", including Multisampling, which is at 1x, and my Filtering, which is at 4x. The only exceptions to this is that I wanted a little more environmental detail, so I kept Ground Detail and View Distance to "High", even though WoW is recommending "Good".

The first thing I noticed, is that with Multisampling at 1x, the problem with the white pixel dots on the background terrain was suddenly GONE. If I turned it up to 2x, the white pixel dots suddenly RETURNED. So I put it back to 1x, and APPARENTLY that has been fixed, so far so good....after about 3 hours of game testing, the white pixels have not returned.

The next thing I did, just on a whim, was to set my game back to DX 9. I had tried this before and it did nothing, but I did it again just to give it a shot. I also changed my game to 32 Bit Mode, from 64 Bit Mode.

In addition, I ENABLED Vertical Sync, Triple Buffering, and Reduce Input Lag. I had previously had all of these settings DISABLED. Previously, I was allowing my video card to max out and crank up to the maximum possible frame rates possible, and I was getting 100-115 FPS in-game traveling through most zones. Now, with Vertical Sync Enabled, my FPS is capped at 60, which puts in proper sync with my monitor's Refresh Rate of 60 Hertz.

I think that having Vertical Sync Enabled, and capping the FPS at about 60 is a key part of this.

Again, I'm just SURMISING this and making an educated guess to a degree, based on the best logic I can use.

I read on another thread, that when video cards are allowed to run a game like woW at its maximum overkill frame rate, that it can actually cause what amounts to a graphics "timing issue", for lack of a better term.

In other words, because WoW is designed for, and works most efficiently at about 60 FPS, any time you play the game at frame rates of 100+ because of video card overkill, the on-screen graphics actually get "ahead of itself".....the high frame rate can't sync with your monitor's Refresh Rate, and you end up with the stutter, jerk, jolt, and "cheesegrater" effect that you and I are experiencing. This effect will happen EVEN WHEN you are getting high frame rates.

You end up with a syndrome of a having very high FPS, but at the same time horrible on-screen performance.

Another way to think of it is like shooting a movie at a bizarre film speed that's too low or too high, and causing the movie to look jittery or choppy.

HOWEVER, even given the fact that I am describing a problem that seems to not be related to the 5.0.4 Update, but rather an internal issue with Graphics Settings, I STILL believe that the 5.0.4 Update IS THE CAUSE of much of this chaos, simply because people had their games running fine before the Update, and now you have to adjust 40 different settings just to get your game back to a playable status. And of course, not to mention all of the numerous connection and latency issues that people are having with their connections, problems that they were NOT having before the MOP Update!

SO, where I ended up was, I had all my settings set as I described above, and last night I play-tested the game for about 30-45 minutes, just walking, riding, flying on Gryphons.......and LO AND BEHOLD the STUTTER WAS GONE. COMPLETELY GONE.

And the white pixel and black ring anomalies were ALSO SUDDENLY GONE.

Hardly daring to believe it, I continued to play-test for another hour, and everything looked good. I am noticing that every so often, there is a SLIGHT stutter, EVERY so often, but it's more like the ordinary kind that you get sometimes when crossing into a new zone, or just a random movement, or turning around fast, or entering a doorway into a huge room or something like that. But the overall stutter appears to be 99% GONE.

I am almost afraid to go back in tonight and try the game again, I don't want to jinx it LOL.

Now, having said all this, I STILL believe that almost all of this chaos is being caused by Blizzard's Update, and NOT our rigs or our hardware! No way. no way players should have to completely overhaul their settings and suddenly have their graphics going black on them, or crashing, or having an FPS drop, or sudden crashes without explanation.

This is ON Blizzard's end, and we are left to jump through hoops to work around it.

I hope this helps!
Edited by Fori on 9/28/2012 8:10 PM PDT
Reply Quote
90 Dwarf Warrior
3635


Evanesco,

There is ONE strange tidbit I would like to add to my post above.

BEFORE the MOP patch, Having "Reduce Input Lag turned" OFF helped to INCREASE my FPS significantly, as well as keeping Filtering and Multis. low.

NOW, since the MOP patch, it seems like having Reduce Input Lag ON is mysteriously actually helping my performance and is no longer causing FPS problems. But I still have Filtering and Mutlis. low, in fact those are set to WoW's recommended settings. CCC is still left alone. And of course, my Crossfire is disabled.

Last night, I was able to finally make what SEEMS like a fix for the graphics stutter I have been suffering since August 29th, the day of 5.0.4(a day that will live in infamy).

What I did was change the settings to the ones I described above. In addition, I currently have my API switched over to DX 9 instead of DX 11. Also, make sure you have your Max. Foreground and Max. Background FPS both set to about the middle.

I also switched the game over to 32 bit mode.

I also have Vertical Sync and Triple Buffering both Enabled, in order to keep my FPS capped at 60, to jive with my monitor's refresh rate of 60 hertz. I personally believe that Vertical Sync is one of the key settings in all this mess. Because if you allow your video card to just peak out and run at its maximum capacity and capabilities, yes you'll get really cool frame rates of 100-200 FPS, but it doesn't help the appearance of the game at all, and you'll just be heating up your card unnecessarily.

Go figure. This whole mess with this 5.0.4 patch has pushed all of us into Bizarro Land.


None of that did anything and I don't know how to switch bit versions


To change the game to 32 Bit Mode, open the Launcher and look up in the left-hand corner. You'll see "Options". Open that and go into Game Preferences. In that menu, you'll see choices for API settings, and also a setting for "Launch 32 Bit Client". Check the box next to Launch 32 Bit Client and then Click on the OK button. The game client will now run in 32 Bit Mode until you decide to change it back to 64 Bit Mode.
Edited by Fori on 9/28/2012 8:04 PM PDT
Reply Quote
90 Worgen Hunter
6035
Didn't do anything either.
Reply Quote
90 Worgen Hunter
6035
Bump. Getting really tired of people coming onto the tech support forums just to say they don't have problems.
Reply Quote
80 Orc Mage
580
You still haven't posted that GPU-Z snapshot and dxDiag
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]