Temp fix for Water Elemental casting sound.

If you are frost you proboly have notice the casting sound of your water elemental gets stuck in a loop. Dismissing the pet does not stop it, resummoning does not stop it. You can log out and back in. You can reload your UI with the /console reloadui command or you can go to your game menu (hit ESC) go to "System", highlight "Sound" in the left hand column, and uncheck then recheck "Death Knight Voices".

I'm still uncertain what causes this problem but it is the quick walk around until the problem is addressed.

Edit: Water Elemental sound still breaks with DK voices unchecked. Also, I think his sound breaks when a mob he is targeting dies while he is A.) Casting and B.) Moving.

Edit 2: Found useful information, another temp fix. You can remove the pre casting sound completely of waterbolt for the water elemental. To shut it off completely...

Go to your Data folder in your WoW install folder (generally C:\Program Files (x86)\World of Warcraft\Data ) if you do not have a folder called "Sound" make one. In that folder make another called "Spells" (the total path will now be similar to C:\Program Files (x86)\World of Warcraft\Data\Sound\Spells ). Make a text document in the Spells folder and name it PreCastFrostMagicHigh and change it from a .txt to a .ogg file. Restart you World of Warcraft and there you go. No more pre casting sound for your Water Elemental! Remember both the folders and files are CASE SENSITIVE meaning you have to pay attention to capitalization.

Edit 3: A few people are mentioning the same problem with arcane. It is possible the sound that is invoked is made by the mage (like the frost bomb casting which uses the same sound) and not by the water elemental. It could more prevalent on frost mages because frost bomb has a cast time.

Edit 4: I've talked to a couple of mages on my realm and confirmed what they have said with another post here. It seems the sound loop appears to occur from the use of the mage bombs (NT, LB, FrB) and not from the water elemental.
Edited by Rhinhart on 11/5/2012 1:40 AM PST
Reply Quote
90 Worgen Mage
3795
is that a permanent solution or temporary one? just wondering cause i haven't been able to test it yet. i know that checking and unchecking the headphone option worked for me, but only temporarily. i have to do it again and again after a fight.
Reply Quote
I've been running with the deathknight voices unchecked and haven't had the problem. Anyway this is just labeled as a "temp fix" until Bliz fixes the problem.
Edited by Rhinhart on 11/5/2012 1:38 AM PST
Reply Quote
bumped for new info
Reply Quote
100 Human Mage
15065
09/26/2012 04:58 PMPosted by Rhinhart
Go to your Data folder in your WoW install folder (generally C:\Program Files (x86)\World of Warcraft\Data ) if you do not have a folder called Sound make one. In that folder make another called Spells (the total path will now be similar to C:\Program Files (x86)\World of Warcraft\Date\Sound\Spells ). Make a text document in the Spells folder and name it PreCastFrostMagicHigh and change it from a .txt to a .ogg file. Restart you World of Warcraft and there you go. No more pre casting sound for your Water Elemental!


Unless they changed it again, renaming a .txt to .ogg doesn't work as the client just defaults back to the original game files instead. I keep a silent .oog file on Google docs here:
https://docs.google.com/open?id=0Bx7BY-89MQo_YjhoNTFGWkNSdldoWWdiSnhGQkl2UQ

that was originally intended for silencing the ambient water elemental sound. It can be renamed to anything though.
Reply Quote
100 Blood Elf Hunter
17025
This didnt work for me... But, is there a way to write a macro to maybe turn on/off the dk voice sound, or any of the switches in the sound control panel that make it go away? Until Bliz fixes this glaring bs bug?
Reply Quote
Hey Nyteshadè, they must have fixed it because both the silencing of the bubbling and the precasting worked for me by just renaming a blank text document (notepad)

Vernax you also need to make sure that "Hide extensions for known file types" is unchecked under tools (on your file menu), folder options, under the view tab. (it is the second box under "Hidden Files and Folders" in windows 7)

If renamed correctly, you should get a warning that changing the file extension may make it unusable. If you do not receive that warning, you are not renaming the file correctly. Also the names of the folders and files you create are CASE SENSITIVE. Remember Sound is singular and Spells is plural :-)

As for the checking/unchecking of the DK voices I'm absolutely sure there is a macro. However, what that is or how to craft it... I have no clue :-( Anyone else help with that?
Reply Quote
100 Draenei Mage
20790
Are you sure this noise is the pet and not Nether Tempest?
Reply Quote
100 Blood Elf Hunter
17025
Rhinhart! I had Sounds, not Sound. That did it. Thank you so much. This has been driving me INSANE!
Reply Quote
the same problem occurs as arcane. i noticed a stuck sound. it makes the portal casting noise and gets stuck and wont go away. just like the water elemental.
Reply Quote
100 Blood Elf Hunter
17025
For Arcane... Same directories as Rhinhart listed, except for Windows 7:

C:\Users\Public\Games\World of Warcraft\Data\Sound\Spells

The filename to create is PreCastMageLow.ogg
Reply Quote
Thanks for that info Vernax. I have my wow folder just sitting on my D: drive so I have no idea where it auto installs :-) I was taking a shot in the dark ;-)

Hmm I did notice that the same sound was used for my frost bomb because it is likewise silent now. I was 99% certain it was the Water Elemental waterbolt attack. However it is possible that it is a the "bomb" precast sound and I (and everyone else I know) have just overlooked it. Thanks Ryegeleye and Subzera!
Reply Quote
90 Draenei Mage
4520
I play a fire spec and get this sound also ! the only thing frost i use is ice barrier :s
Reply Quote
Any other fire or arcane mages having this trouble?
Reply Quote
100 Gnome Mage
20105
Thanks!
Reply Quote
22 Troll Shaman
2505
I had a problem with the sound of Arcane Blast breaking and then looping ad nauseum when I wasn't even casting, but I fixed it...

...by losing my staff and equipping a dagger and an off-hand. Hasn't happened since.

Submitted a bug report for the breakage and the fix.
Reply Quote
Thats... interesting. I'll have to give that a try and see if it works. lol
Reply Quote
90 Draenei Mage
7990
I'm having the same issue. I figured it was due to the frost bomb cast noise.
Reply Quote
90 Blood Elf Mage
5050
im fire and just started getting the problem today. between lvls 75 to 78 (current). not sure if maybe frost bomb is the cause or maybe combustion? just thinking if new spell i got is what causes me to start getting this as fire spec
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]