Black characters and patches on ground, help?

100 Blood Elf Priest
12640
Character models (pieces of them) turn black the farther you move from them, and every other plot of land has a big rectangular piece that is black or the wrong type (cobblestone in grass for no reason). I tried to update the my video card driver like another thread suggested, but I either did it wrong or that is not the problem.

Can someone confirm whether it is my video card or a game file?

I'm using a Mobility Radien HD 5xxx Series according to the downloader.
Reply Quote
Support Forum Agent
Rdytopwn,

Try switching the game to Directx 9 mode and see if the issue persists.

From the launcher, go to Game Preferences under the options menu and select Directx 9. Then restest the game.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
Reply Quote
100 Blood Elf Priest
12640
I think that did it! Thank you very much!

While I have your attention....

The expansion is beautiful. As a long time player, I'm really proud of the updates made this time around. So glad I can see it clearly now!
Reply Quote
Support Forum Agent
Thanks for the update, Rdytopwn. I'm happy to help.

I'm glad to hear you're having fun too! Go smash some Alliance for me.

________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
Reply Quote
100 Human Paladin
17795
This appears to have solved the same problem for me.

I've also heard and read many comments about how nice the expansion looks and feels...good job.
Reply Quote
90 Blood Elf Paladin
0
My friend was having this issue for weeks, this will probably bring a fix to his issue, so he can finally stop crying about it.

Now....only if I can stop disconnecting... Then everyone will be happy.
Reply Quote
Thanks so much... I had the same problem and it's been driving me crazy! The only thing that has helped has been resetting my graphics settings every 15 minutes or so. I will switch to DirectX 9 mode now. The expansion is lovely... thanks again!
Reply Quote
This reduced my lag to none, and now the patches are gone! Thanks!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]