Char's pets are empty until learning battle

85 Night Elf Hunter
9410
The count is zero and the array is empty for a character such as mine who hasn't logged in since MoP launched. I know things have changed and pets are now "Battle Pets", but maybe this was an oversight?

I can't tell if it's for characters who haven't learned how to battle, or if it's just not logging in. It may apply to new characters as well, but I can't test it.

http://us.battle.net/api/wow/character/stormreaver/Rinn?fields=mounts,pets
Reply Quote
Battle.net Developer
It's only for characters that haven't logged in. The data moved from character information to account wide information.
Reply Quote
89 Draenei Warrior
8970
I made the same mistake in patch 5.0. I was thinking "Where are my mounts... and my pets!?" I asked in traded and was told your pets and mounts only get added to account-wide when you log into all your characters.
Reply Quote
100 Tauren Death Knight
Sin
16750
09/27/2012 04:41 PMPosted by Peratryn
It's only for characters that haven't logged in. The data moved from character information to account wide information.


I'm still having that problem of pets still being shown as not known on the toons that didn't originally have them. Will they be fixing that any time soon?
Reply Quote
90 Troll Shaman
15030
I've logged in and out of this toon multiple times, I have a level 3 pet, and my armor on the armory has even updated. Yet I'm still showing 0 pets (I still show my mounts, but those don't matter as much). Do I literally have to log onto every single last character? THere are about 5 or so characters I haven't logged onto since patch, because I have no reason to do such.
Reply Quote
89 Draenei Warrior
8970
@Dalent
Yes, log into them all. However, Vile's post is curious to me. Try logging into all your characters, and if your stuff doesn't show, there might be a legitimate bug somewhere.
Reply Quote
100 Blood Elf Paladin
18935
Prior to the 25th, the API was returning individual toon pets (instead of account-based pets) even though pets had been changed to account-based.

After the 25th, it works fine, at least for me.

09/27/2012 08:53 PMPosted by Dalent
I've logged in and out of this toon multiple times, I have a level 3 pet, and my armor on the armory has even updated. Yet I'm still showing 0 pets (I still show my mounts, but those don't matter as much). Do I literally have to log onto every single last character? THere are about 5 or so characters I haven't logged onto since patch, because I have no reason to do such.


Huh, weird. http://us.battle.net/api/wow/character/kiljaeden/Dalent?fields=pets

If he has a Battle Pet, it show should up regardless of which toons he's logged into (and he says he does). Sounds like a bug.
Edited by Simca on 9/28/2012 9:26 AM PDT
Reply Quote
Battle.net Developer
There is a bug where some people's pets are not loading at all. We're looking into it but it crosses a bunch of teams here and finding where the issue is is taking some time. Working on it.
Reply Quote
83 Human Warlock
4850
Have to open pets and run through/close little tutorial-then they will load in my experience. Some you have to do all characters on an account some just once. Something to do with the tutorial though in my experience.
Edited by Fearedya on 9/28/2012 10:23 AM PDT
Reply Quote
84 Draenei Death Knight
MVP
3615
I dont have MoP, but my pets are EVERYTHING to me!!!!!!! call me nuts for pets but i blew 3k for all pets... i go to dal and buy pet collars and water pails and everything :D
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]