Patch 5.0 & MOP created bad fps & stutter

(Locked)

90 Night Elf Hunter
14530
I was having no issues graphically speaking Until yesterday. Before the rolling restart October 4th, I was running steadily 40+ FPS even in high trafficing areas at high settings. Afterwards A guildmate and I have had fluctuation FPS in the Single digits. Even while standing still. The pictures stutter if I move badly. I've tried some of the fixes that I can but nothing seem to FIX anything. Why would I suddenly have problems when a few hours prior there WAS no problem. Just another thing Blizzard broke during restarts. This Obviously is on their end or so many of us with different set ups wouldn't be having this issue.
90 Orc Warrior
15610
Bump
90 Blood Elf Paladin
17030
I was running around 100+ fps till a couple days ago new I'm lucky if i get over 17
90 Orc Rogue
4210
Glad that my 2500$ rig that plays every other game on ultra is complete garbage when it comes to blizz games!
This is just sad.
90 Night Elf Druid
5255
Still no comment on this Blizzard?
90 Night Elf Druid
7455
Glad that my 2500$ rig that plays every other game on ultra is complete garbage when it comes to blizz games!
This is just sad.


I'm having a really similar issue...

I highly doubt a blue hasn't read this yet considering it's been on the first page for a few days and now at 5 pages...
Edited by Nevaro on 10/5/2012 8:18 PM PDT
90 Orc Warrior
15610
Bump
90 Blood Elf Death Knight
4785
/signed

been having the fps random drop
temp fix for me is to open launcher and go to options in the top left corner-->game prefrences
-->then click restore defaults
after that do a full restart on computer and relaunch wow
usually clears it up for a few hours...sux when it happens in a heroic or something
85 Human Paladin
4090
/Signed. I can run sleeping dogs on max with hd pack at 60fps solid but WoW drops into the 20s. Been playing since beta and never had so many problems, on a new rig with 7870 all updates etc etc. Oh yeah I also have to run in window-full screen mode or not only do I get bad fps but everything is fuzzy for some reason.
90 Blood Elf Paladin
13375
10/03/2012 10:17 AMPosted by Tatianah
This is silly. My framerate dropped considerable after 5.0 dropped and my graphics stutter all the time MoP zones.


Same, New pc. made over what is min for Mop. Two older pcs in same room sitting on 30+ frames. I'm lucky to get 12 and it drops lower in combat, cannt see me tanking much in this Xpack.

10/01/2012 07:48 PMPosted by Felintra
So the good news is that I have found people with the same issues that I am experiencing! The bad news is that there seems to be no response from Blizzard. I have put in numerous tickets. One person told me to run the DX and MS reports. I did that. However, none of my tickets are showing up, even in the past ticket area, so I have no way of sending the information in to Blizz. ::sigh:: This is ridiculous!


My tickets "disappear" as well.
90 Human Priest
13530
I drop to below 4 fps - in combat on mage and warrior. Locks up on mage in instances. My priest drops to 15 fps in combat.

It seems to be a bug on windows 7 64 bit machines.

/sign my complaint
90 Dwarf Shaman
5075
I drop to below 4 fps - in combat on mage and warrior. Locks up on mage in instances. My priest drops to 15 fps in combat.

It seems to be a bug on windows 7 64 bit machines.

/sign my complaint


I ONLY lagg in combat. THIS IS BS! /SIGN
90 Draenei Paladin
9315
/sign

Having the same problems - brand new retina mac pro running fine on around 60fps before patch. Now barely breaking getting to 20fps as well as freezing up for short bursts periodically as well as a constant "download 0% complete" on the game menu pop up even though fully up to date. Tried playing with visuals, addons, folders and no joy.
90 Draenei Shaman
9190
/sign

FPS dropped almost to 50% of what they were pre-MoP. It's still playable, but it's definitely a huge performance loss, and highly unacceptable at this point. I realize it's an almost twelve year old game engine, but c'mon.

i7-2600K @ 4.6GHz
8GB RAM @ 2200MHz
GTX 580 SLI (x2) w/ 306.23 drivers
Vertex 3 SSD (x2) RAID-0
90 Blood Elf Hunter
4595
/sign

I have also just started experiencing a frame stutter and lower FPS.

I was happily playing Thursday, played for about a 2 hours and suddenly this all started happening and i cant think why.

I have never experienced any lag or low FPS, have always played with settings on high or ultra and i made it to lvl 90 thru all the areas of MoP without a problem.

Its exceedingly frustrating and ruining the game experience and i cant believe that after all the posts that have been made that no one from Blizz has said anything.
90 Orc Warrior
15610
Bump.
90 Troll Mage
9380
I'm having a really similar issue...

I highly doubt a blue hasn't read this yet considering it's been on the first page for a few days and now at 5 pages...


Idk, bro, I've personally submitted these links to tech supports, and we had a blue forum guy post in one of those threads. And...these complaints have been popping up here for over a month in huge quantities, the threads have mostly just died out is all.
85 Worgen Rogue
7245
/sign

I quit playing because of these problems and blizzards lack of acknowledgement.
55 Worgen Death Knight
90
I can't comment too much on this since I have a brand new gaming PC with an overclocked HD 7850 and an overclocked i5 3570K. However, I'm running ultra and I drop to 30 FPS quite often, where as on other games that are MUCH more demanding and newer, I run ultra at 60 fps without any problems.

I agree that there's definitely optimization issues. Nothing severe for me but I can see it being a huge issue for other players.
Edited by Aomber on 10/6/2012 7:55 AM PDT
90 Troll Druid
8065
/sign

These issues really are impossible to deal with. It gets so bad that I can't even play the game. I'll be in bear form trying to kill something and have 4 fps. But as soon as I switch to flight form my fps goes back up to normal? Also sometimes I can't even single target mobs or use any of my single target abilities, it says it's a invalid target but I can AoE it? Lol hope blizzard does something about all this soon.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]