Twilight Skies quest bugged

90 Worgen Druid
6690
I saw some posts from a few years ago about this quest being bugged, and I am having trouble now. When the fleet crosses after the line "Pull up pull down pull something" everyone on the airship and the rest of the fleet vanishes. I cannot complete this quest because of it. I've tried disabling addons and have rebooted everything and tried dropping and trying the quest again numerous time. I have yet to find a work around.
Reply Quote
90 Tauren Paladin
6750
I am having the same problem. The cut scene gets to the part where the orc comments on dwarves living in holes and then all of the NPCs disappear. The zeppelin completes its flight path but never finishes the quest. This is on the Dragonmaw server with my 85 Paladin. I have tried it twice with the same results. I have no addons.
Edited by Gunnharun on 10/6/2012 6:23 AM PDT
Reply Quote
89 Tauren Shaman
1870
Ditto! Same problem. (FWIW)
Edited by Akylax on 10/22/2012 8:12 PM PDT
Reply Quote
1 Night Elf Rogue
0
I am having this issue as well. A few months after other posters. It is quite frustrating.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]