Must Fix Mage Bomb Sound Bug!

90 Human Mage
17410
Please fix the bug that is responsible for the persistent looping sound effect associated with casting mage bomb. It's absolutely terrible, and as a result it just really wrecks the game experience, so dissapointing! It doesn't matter where I am, dugeons, senarios, PvP, questing whatever it is after using mage bomb (not necessarily the first cast but 2nd, 3rd, 4th...) the bomb casting noise doesnt end with the cast going off, it just keeps looping. Honestly, its not just me its everyone of my friends that play a mage or players I just come across in game they all have the same problem, please fix ASAP!

(I am using the 64-bit client.)
• I've tried disabling all my addons.
• I've deleted my WTF. Cache and Interface folders.
• I've tried turning off/on Deathknight voices. The game sound restarts and the mage bomb noise goes away but it doesnt prevent it from coming back when using mage bomb later on.
Reply Quote
90 Undead Mage
0
If you check or uncheack enable reverb in sound options it will stop it for a little while.
Reply Quote
90 Human Mage
17410
Its still broken Ash, still comes back, and still doesnt work as intended. Hard to play and have fun with a constant noise spamming in your background, you know this, you're a mage.
Edited by Kremus on 10/2/2012 2:09 AM PDT
Reply Quote
90 Human Mage
17410
It would be nice to get a blue post on this so at least we can be okay with them working on a fix. Another week of this I am about to stop playing completely.
Reply Quote
90 Undead Mage
0
No I agree it needs to be fixed asap, just saying until they do you can get rid of that annoying sound for a min or 2 :P
Reply Quote
90 Gnome Mage
16535
It amazes me how quiet everything is when I do the temp fix and the sound is normal for a few minutes. When I can actually hear the environment instead of "aaaaaaahhhhhhuuuuuuummmmmm"
Reply Quote
90 Night Elf Mage
6955
I have been having the same issue. It really detracts from the experience. The only way I can get rid of it is by disabling and then re-enabling hardware or sound effects. The problem goes away when sound effects are disabled, but where is the fun in playing a game with no sound?

I found this post in one of the eu.battle.net forums. It had a blue response and a link that they are "working" on the issue.

http://eu.battle.net/wow/en/forum/topic/5492390463
Reply Quote
90 Human Mage
17410
Why can't we get a blue post on this topic from the US. Blizzard is a US based company yet they have better customer service in Europe, I simply don't get it.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]