What causes error 132 and the Bsods, fix.

90 Human Death Knight
11925
A lot of people are suffering from error 132 in wow and in conjunction blue screens and or the resetting of GPU drivers in windows. I found this post from a few days back that explains why the new method of dealing with video cards in WoW's coding causes your cards to overheat. Basically your GPU isn't idling and is always running at 100% during wow if you don't limit your FPS in foreground and background. Over time your GPU slowly overheats and you get 1 of many random BSODs and WoW will probably crash a few times before that. Depending on your setup, case, cooling you will have maybe days between BSODs and WoW crashes or hours or minutes, just depends on how well your computer is set up.

I noticed that this was only happening with WoW and that nothing else ever on my computer in the past 6 months has ever caused a BSOD. HELL I have never even had my computer shut off or freeze or anything, it's pretty much flawless. Yet WOW managed to BSOD me and continue to crash itself with random 10-12 hour intervals of occurrence.

So basically just read this post and limit your fps in background and foreground to about 60 fps and turn up your GPU fan.

This is a repost from the Mac Tech Support forum sticky, brought here because this issue affects all computers, not just Macs.

This is a Public Service Announcement to inform the Mac and PC users of what appears to be a fundamental change in client behaviour regarding the maxFPS and maxFPSbk settings.

In previous versions of the client, if your video card just couldn't muster that juicy 60 FPS no matter what, having the FPS limiter (maxFPS; maxFPSbk) turned off (set to zero) would at least let you eek out as much as you could from your card. The GPU wouldn't run at 100% because it was behaving properly (idling) when it couldn't do anything in a given cycle.

The 5.0.4 client appears to have changed how this works. In 5.0.4 it appears that if you do not cap your FPS, usually to your display's maximum refresh rate, the GPU will no longer idle, but continue working at full load even though it isn't producing any higher framerates.

This has a very detrimental effect: heat.

You see, when a CPU or GPU is incapable of performing any additional action/rendering beyond what it can pull in any given environment, it usually idles to save power. In WoW's case, being that the game client is more CPU bound than GPU bound, that means your FPS is typically primarily dictated by your CPU's core speed and bus speed (and sometimes RAM speed). The more modern the CPU and/or faster it is, the higher your framerate gets.

But now it seems that the Mac client (and possibly PC client too) are somehow causing the GPU to never idle if the FPS is not capped. Here's an example from my system:

I have a Mac Pro 1,1, which has two 2.66 GHz Xeon 5150 CPUs, each with two cores. In the Cataclysm client (4.x), I had my FPS limiter set to zero because other than the old Azeroth zones, I didn't get much more than about 40-45 FPS because my CPU wasn't ultra fast and didn't have a modern bus architecture. I didn't need to limit my FPS because it never got uber high except in a cave or house, or a few dungeons (and certainly never in raids). So I had the FPS limiter turned off and VSync turned on (to prevent tearing).

Fast forward to 5.0.4's launch. My framerates didn't change, nor did any of my settings. My FPS was still not limited and VSync was still enabled. However, I noticed that my Mac Pro's chassis got remarkably hot to the touch around the PCI Expansion Bay. So I opened Hardware Monitor and saw something that shouldn't have been: GPU Load - 100%. It was 100% at the login screen. It was 100% at the character select screen. It was even 100% around Dalaran, where I usually get only 20-30 FPS tops no matter what. And I was still getting only 20-30 FPS there.

So I went through my config.wtf file's settings and one by one eliminated the settings lines after each launch until I found what was causing my GPU to cook itself. Even though my framerates didn't change (because my settings didn't change), the GPU was now heating up in short order. All that changed was how the GPU operated when the WoW client was open. It no longer had any idle cycles. With the FPS limiter turned off, the client was telling the GPU to run as fast as possible, even if it didn't produce more frames per second, and what that amounted to was nothing but extra heat being generated. A lot of heat.

So why am I explaining all of this to you here? So you can prevent the untimely demise of your computer's video card/GPU.

So the old client let your graphics card processor idle when there wasn't enough data to feed to it (i.e. couldn't muster high framerates because of the CPU bottleneck). This client does not do so, and in turn, if you fail to limit your FPS, you could very well cook your computer into an early grave.

So the moral of the story is that as of this client version, under no circumstances should you leave your FPS uncapped. It should be set at the most to your display's maximum refresh rate. Doing so causes the client to allow your GPU to idle when it isn't actively receiving data through the bus instead of burning itself out.

To limit your framerate, you can do one of two things:

Method #1

In the game, from either the login screen or the in-game world do the following:

From the Login Screen:

1) Click the System button.

2) Click the Advanced menu option.

3) Tick the checkboxes for both the Max Foreground FPS and Max Background FPS options.

4) Adjust the slider to your desired position. For LCD owners, this would be putting the slider marker directly under the letter o in the word Background and directly underneath the second o in the word Foreground. Both markers should align with each other if you want as close to 60 FPS as possible using just the sliders.

From the in-game ESC menu

Follow the instructions as listed above for the Login Screen (the buttons are all the same).

Method #2

Open your config.wtf file, located in the /World of Warcraft/WTF/ folder and make sure the following lines are present:

SET maxFPS "60"
SET maxFPSbk "60"

You can (and should) adjust these to lower values if your video card cannot normally handle that high of a framerate naturally.

For laptops and some lesser powered iMacs, it is advisable not to exceed a value of 30 for either of these settings unless you have absolutely awesome cooling available for your computer.

So to recap, as of 5.0.4 failure to limit your framerates will cause your graphics card to never idle, potentially causing it to overheat and/or burn out.

Play it safe and cap your FPS!
Reply Quote
90 Human Death Knight
11925
Switching to DX9 helps a lot of people for a little while but it just prolongs how long it takes your video card to heat up due to it using less resources to render than DX11 and usually people who think they are fixed find that they still get rare crashes/BSODs in DX9 too. I recommend just keeping windows clean, your registry clean, new drivers, make sure your bios are setup properly and that the crashes you are experienced and any BSOD you are experiencing are the direct result of WoW. It took me weeks of testing to come to the conclusion it was only WoW. It is the only game that uses 100% of my GPU 100% of the time I'm in the game. Crysis 2 max edition on max settings doesn't even use 100% of my gpu... So.... ya.

My Setup:

Windows 7 x64 ULT
I7 2600k OC to 5.0 Ghz stable (Liquid cooled H80 corsair)
16gb ddr3 @ 1980 mhz 2T.
2 TB 10,000 RPM HDD
Geforce gtx 580 3gb (running in PCI 2.0 @ x16 )

I just limited the foreground and background FPS of wow to 60 for both and manually turned up my GPU fan a little bit higher and so far I haven't crashed or BSOD in 2 days. Hopefully this will be the fix.
Reply Quote
100 Orc Warrior
12380
Thanks for this post, ever since Mists came out I have been have trouble with my GeForce 680. I would be playing and then - black screen... then to windows 7 desktop and a message stating the driver stopped but has been recovered. I would open WoW again and then the screen would suddenly behave as if it were shut off, the GeForce Card Fan screaming 100% from inside the case. Every attempt to re-power the system the card screams from it's fan. Place it in secondary system and it works no problem, however the second pc hasn't a WoW client installed. No crashes here. Place back in Primary pc and plays WoW for a bit and then the same nonsense. I'll replace the frame rate limiter now. Maybe that will help me. I hope more people with similiar problems arising coinciding with the release of Mists of Pandaria will find this a possible solution as well.
Reply Quote
85 Night Elf Death Knight
3440
I'm having the same issue, attempting this fix now. Except mine only has this problem when the laptop is plugged in, on battery power it's perfectly fine.
Reply Quote
90 Pandaren Monk
9285
I played the game for two hours after trying this fix, and it didn't crash. That's the longest I've gone yet. I'll play it some more tomorrow, but I'm optimistic. If this ends up working, THANK YOU.
Reply Quote
90 Human Warlock
12340
I'm still having a problem, I even lowered the fps to 13 and I was able to play without an interruption for about an hour before it crashed again and my entire system froze.
Reply Quote
92 Goblin Shaman
6915
Here's my scenario:

I ran all of these on DX11 at Ultra settings on 64bit.

I set the limiter to 60 which as you've described set it right below the "o"s and for those who can't quite get it, change the config file which Merck has outlined under method 2.

Crash...

I unticked the limiters

Crash...

I remembered something where playing in both windowed modes (fullscreen) doesn't limit your FPS, as I was getting between 60 - 100+

Changed display mode to FULL.

Crash...

Ticked the limiters and set them right below the "o"s and I've been gaming for almost an hour now...

I'm still quite skeptical and am waiting for a crash so I can throw my hands up in the air and /sigh...

But compared to my last three crashes, which all happened within 10-20 minutes of each other, I'm still going strong on ULTRA settings, DX11 & 64bit.

My GPU temp peaked up to 58c and averaging on 44c. I haven't sped up my fan, it's on auto and averages around 29% peaking at 39%.

There's some visual tearing going on but hey, it's working so far, I guess I just gotta tweak the limiter to find my monitors "sweet" spot.

Hope you guys find this useful as I had found Merck's post.
Reply Quote
92 Goblin Shaman
6915
Well that lasted for 2 hours and a half...
Reply Quote
92 Goblin Shaman
6915
THIS IS BULLPOOP!!!
Reply Quote
10 Orc Warrior
14200
Thanks for the post! I am running a Nvidia GTX 580 and been having issues with WoW. HOPEFULLY blizz is working on a solution for better performance. Would be nice if we could get some one from tech support to comment on it.
Reply Quote
90 Human Paladin
10400
Enjoy the read:

http://us.battle.net/wow/en/forum/topic/6758675915?page=1

Blizzard has no idea what to do to fix this problem. Enjoy your broken, unplayable game. I sure am.
Edited by Fransizka on 10/4/2012 9:19 PM PDT
Reply Quote
90 Pandaren Monk
9285
Yeah, I've started crashing again.

What is Blizzard's official stance, anyway? "It's nvidia's fault" probably. Saves them from having to figure this out themselves.

Well, that's an extra $15 every month I'll be able to spend on candy, at least.
Reply Quote
90 Night Elf Hunter
5280
i had this problem on my girlfriends computer and changed the bit rate to 32-bit on the game options menu from the patch screen because this error wouldnt even allow her to get into the actual log in screen. havent tried the actual game yet as she is doing hw for college finals and such, but she at least got to the log in screen.

will post more if anything else happens
Reply Quote
1 Human Warrior
0
I found the real solution
hello everybody, I had the same problem but I figured it out.
when you click on the icon of game a small windows open, before clicking on play look on corner on top left of screen and select options then game preferences, then select directx 9 instead of direct x11 and ok it.
that's it.
it worked for me.
best luck everybody.
Arash from Afghanistan.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]