Patch 5.0.5b Download Error

90 Pandaren Monk
8260
When I load the launcher, it attempts to "initialize" (shown in the bottom left corner of the window) with "0.0%" shown next to the greyed-out "Play" button. It stalls like this for about 10-15 seconds, then an error pop-up says "Failed to download a required file. Please check your internet connection and try again". No issue with my connection doing anything else, and I've already restarted my Mac with fingers crossed and everything. Ideas?
Reply Quote
100 Night Elf Druid
17095
having same issue. I am also on mac
Seems they messed it up for mac users.
Reply Quote
Support Forum Agent
Can you post your latest AgentError.log? This should be located in /Users/Shared/Battle.net/Agent/Agent.1363 and the format should be AgentErrors-YYYY/MM/DD-[Random Numbers].log .

Make sure you remove any personal information, like computer/username from the log.
Reply Quote
90 Troll Priest
9190
same problem here, but im using windows, i guess it's because my network blocks p2p transfer
is there a way to update even when my network blocks p2p transfer?
Reply Quote
100 Night Elf Druid
17095
having same issue. I am also on mac
Seems they messed it up for mac users.
Reply Quote
100 Night Elf Hunter
7835
I too have a macbook and I too am having the same problem.
Reply Quote
I get a message after about 5 sec of "Failed to load required file. Please close all applications and temporarily disable anit virus.....i turned it off. everything and closed everything and still nothing works.....BTW i am on windows not even Mac so no idea what is going on.
Reply Quote
8 Worgen Warlock
0
Help!!!! I wanna play!!!
Reply Quote
87 Orc Hunter
8280
same issue here on a mac. I'll just be hanging out waiting until Blizzard fixes it...i guess.
Reply Quote
90 Goblin Death Knight
0
My launcher won't even load:

#-----------------------------------------------------------
# System started at 2012-10-10 20:52:26.2835
# system: [REDACTED] MacBook Pro
#-----------------------------------------------------------
20:52:26.2862 Argument[0]: '/Users/Shared/Battle.net/Agent/Agent.1363/Agent.app/Contents/MacOS/Agent'
20:52:26.2863 Argument[1]: '--locale=enUS'
20:52:26.3142 Database Insert: /option
20:52:26.3666 Database Insert: /agent
20:52:26.3669 Database Insert: /
20:52:26.3669 Database Insert: /version
20:52:26.3671 Database Insert: /repair
20:52:26.3672 Database Insert: /update
20:52:26.3674 Database Insert: /install
20:52:26.3674 Database Insert: /gamesession
20:52:26.3679 Database Insert: /agent/download
20:52:26.3680 Database Insert: /backfill
20:52:26.3680 Database Insert: /game
20:52:26.3682 Database Insert: /createshortcut
20:52:26.3702 Database Insert: /game/client
20:52:26.3704 Database Insert: /spawned
20:52:26.3716 Database Insert: /agent/download
20:52:26.3719 Database Insert: /register
20:52:26.3954 Initialize HttpProtocol Server Called.
20:52:26.3977 Agent started on port #6882
20:52:26.3979 Registered Periodic Event: "auth validation event" with a resolution of 10000 and a start delay of 10000
20:52:26.3979 Registered Event: "shutdown event"
20:52:26.3980 Registered Event: "database flush event"
20:52:26.7168 Request Issued: GET /agent

20:52:26.7170 Response: 200
{
"update" : {},
"install" : {},
"backfill" : {},
"pid" : 275.000000,
"state" : 1004.000000,
"playable" : true,
"version" : "1.2.1.1363",
"type" : "retail",
"authorization" : "C289C405F0C730DF0F36B7C83564DFA4"
}
20:52:26.9368 Request Issued: GET /agent

20:52:26.9372 Response: 200
{
"update" : {},
"install" : {},
"backfill" : {},
"pid" : 275.000000,
"state" : 1004.000000,
"playable" : true,
"version" : "1.2.1.1363",
"type" : "retail",
"authorization" : "030824BAF8F62F0F19725CF272F99EB5"
}
20:52:26.9423 Request Issued: GET /game/client

20:52:26.9685 Response: 200
{
"install_dir" : "/Users/Shared/Battle.net/Client",
"launch_path" : "/Users/Shared/Battle.net/Client/Blizzard Launcher.app",
"current_version" : 0.000000,
"supports_multibox" : true,
"switcher" : true,
"use_sparse" : false,
"operations" : [],
"playable" : true,
"ever_playable" : true,
"last_played" : 0.000000,
"update_progress" : 0.000000,
"needs_rebase" : false,
"product" : "Clnt",
"patch_url" : "http://enUS.patch.battle.net:1119/patch",
"config_url" : "",
"mfil_hash" : "00000000000000000000000000000000",
"torrent_hash" : "00000000000000000000000000000000",
"alternate" : false,
"supports_offline" : false,
"installed_locales" : [
""
],
"patch_application_complete" : false,
"download_complete" : false,
"background_download_available" : false,
"background_download_complete" : false,
"perform_ogg_to_wav" : false,
"baseline" : "",
"active_data_sets" : [
"base",
"OSX"
]
}
20:52:26.9710 Request Issued to non-existent Uri: GET - /gamesession/client
20:52:26.9710 Response: 404
(null)
20:52:26.9736 Request Issued: POST /gamesession
{
"uid" : "client",
"launch_arguments" : [
"--gamepath=/Users/colefitz88/Desktop/World of Warcraft/",
"--game=wow_enus"
]
}
20:52:26.9740 Agent::Product::StartSession() - Begin Waiting
20:52:26.9741 Agent::Product::StartSession() - End Waiting
20:52:27.3716 Launching /Users/Shared/Battle.net/Client/Blizzard Launcher.app w/ --gamepath=/Users/[REDACTED]/Desktop/World of Warcraft/
--game=wow_enus
**********************************************
20:52:27.4719 Database Insert: /gamesession/client
20:52:27.4720 Database Insert: /gamesession/client/1
20:52:27.4720 Response: 200
{
"response_uri" : "/gamesession/client"
}
20:52:31.0511 Request Issued: GET /agent

20:52:31.0514 Response: 200
{
"update" : {},
"install" : {},
"backfill" : {},
"pid" : 275.000000,
"state" : 1004.000000,
"playable" : true,
"version" : "1.2.1.1363",
"type" : "retail",
"authorization" : "548C99DC877D7EBDFED7F769B1CE2043"
}
20:52:31.2034 Request Issued: GET /agent

20:52:31.2038 Response: 200
{
"update" : {},
"install" : {},
"backfill
Edited by Coleybear on 10/10/2012 1:56 PM PDT
Reply Quote
59 Undead Death Knight
9320
same problem here, but im using windows, i guess it's because my network blocks p2p transfer
is there a way to update even when my network blocks p2p transfer?

Yes: http://patchup.info/wow/tfil/NA/

And if you are one of those having to wait for 10min+ until the launcher finishes initializing you should update the Agent as well:
http://patchup.info/Blizz/tools/Mac/

BTW, Machkhan mentioned that the devs are looking into this. Lets hope they come up with a definitive solution.
Edited by Barthus on 10/10/2012 2:13 PM PDT
Reply Quote
90 Troll Priest
9190
thanks
it worked!
Reply Quote
88 Human Warrior
2535
Also on a mac, hitting this and a case sensitive volume error (which I've never hit before, though apparently case sensitive volumes are not supported I've never had a problem until now)
Reply Quote
Support Forum Agent
Please keep threads related to the topics they are about. If you don't see a thread about your topic to post constructively on, please create a new thread.
Reply Quote
Support Forum Agent
Let's keep this thread to the original posters topic of "Failed to download a required file. Please check your internet connection and try again".

If you're having issues other than this, please create a new topic.

@Jinno - Did you try the steps what Barthus suggested.
Reply Quote
85 Blood Elf Priest
1840
dude....ty soooo much. i finally got it now
Reply Quote
90 Human Paladin
5430
Wont download. Launcher says "Initializing" for a second, then "Recalibrating" for a second, then "Total Download Remaining 6.30MB" and wont move. Did what Barthus said but that just switches out the WoW.tfil file with a new one with no effect.
Reply Quote
59 Undead Death Knight
9320
10/10/2012 05:37 PMPosted by Aireth
Wont download. Launcher says "Initializing" for a second, then "Recalibrating" for a second, then "Total Download Remaining 6.30MB" and wont move. Did what Barthus said but that just switches out the WoW.tfil file with a new one with no effect.

Download this, save in the Updates folder and try again.
http://dist.blizzard.com.edgesuite.net/wow-pod-retail/NA/15890.direct/Updates/wow-0-16135-OSX-final.MPQ

/Applications/World of Warcraft/Updates/wow-0-16135-OSX-final.MPQ
Edited by Barthus on 10/10/2012 6:16 PM PDT
Reply Quote
100 Worgen Hunter
13195
I had the same error message. Re-downloading the game client from Blizzard's website fixed it for me.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]