[Shadow] Divine Star

91 Night Elf Priest
18280
My guild is working on H Feng and I specced into Divine Star for the first time since beta. Does this spell have no graphic for everyone else other than the shadow outline everyone gets as it passes by them? I have my graphics on ultra and there is no ball/star like there was on beta.

It just rather annoying since I know that there used to be one :P I tried both glyphed and non-glyphed for Shadow and still nothing.
Reply Quote
90 Blood Elf Priest
12435
Sometimes it works, sometimes it goes into the floor, sometimes it doesn't appear at all, but you still get the damage/healing in every case.

It's weird.
Edited by Nixx on 10/10/2012 11:43 AM PDT
Reply Quote
100 Goblin Priest
7815
My guild is working on H Feng and I specced into Divine Star for the first time since beta. Does this spell have no graphic for everyone else other than the shadow outline everyone gets as it passes by them? I have my graphics on ultra and there is no ball/star like there was on beta.

It just rather annoying since I know that there used to be one :P I tried both glyphed and non-glyphed for Shadow and still nothing.


Not sure, yesterday morning there was a star and a long trailing tail of light. As of today I havent been seeing anything at all to indicate. Only way I know is of its CD or green/yellow flashy numbers.
Reply Quote
91 Night Elf Priest
18280
Sometimes it works, sometimes it goes into the floor, sometimes it doesn't appear at all, but you still get the damage/healing in every case.

It's weird.


Oh, crazy. I haven't had it not work or go through the floor yet; its healing/dmg always goes out for me. It's just the visual - which is better than the spell not working, but annoying nonetheless since it'll probably take a bit more time to fix since it'll be lower on priority.

I've been messing with it since last night and have yet to have it show anything at all graphically. D:
Reply Quote
90 Goblin Priest
11785
I've had it bug out graphically a lot. There seems to be no rhyme or reason to it. At first, I thought it was on less common ground textures or slightly elevated areas or something, but that doesn't seem to be the case. Reloading seems to fix it for me usually.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]