Patch 5.04/5.05 with OSx 10.8.2 performance

90 Human Paladin
13770
Hello,

Ever since the MoP patch, I have experienced problems with performance such as ones mentioned on this thread like the FPS stutter on DragonSoul Warmaster Blackthorn encounter. Now, it seems to be happening more often. Whenever I zone in somewhere, after hearthing or logging in, I experience the same stutter for awhile, even with my graphics turned all the way down. This also happens when I am in the Gate of the Setting Sun dungeon, looking out over the gate.

Here are my specs:

Mid 2011 Imac
Processor 2.5 GHz Intel Core i5
Memory 12 GB 1333 MHz DDR3
Graphics AMD Radeon HD 6750M 512 MB
Software OS X 10.8.2

Has there been a fix for this yet? I have tried running with no addons, deleting WTF, Cache, and Interface folders, and resetting the SMC. Still seems to be giving me problems. Am I running an out-of-date OS or something? I have been checking my software update regularly and still see nothing to update.
Reply Quote
Support Forum Agent
Let me ask you this? Did you do a fresh install of WoW when 5.0 dropped, or did you do the migration from 4.x to 5.0?

Some people I've worked with seemed to have better FPS issues after reinstalling with the 5.0 installer, but I don't know why yet. I'm researching this and see if we can find any reason why this is.
Reply Quote
90 Night Elf Mage
12705
You I tired to do that with my game and I still had FPS problems lol
Reply Quote
90 Human Paladin
13770
I did not do a fresh install of WoW when MoP came out, I did just do the migration from 4.x to 5.0. When I get a chance, maybe in the next few days, I will give this a shot and post my results..
Reply Quote
90 Human Paladin
13770
Just did a fresh re-install and have the same performance problems.
Edited by Marc on 10/5/2012 4:04 PM PDT
Reply Quote
90 Human Paladin
13770
also did an apple hardware test to see if anything is wrong. The test result was:

no trouble found.
Reply Quote
90 Human Paladin
13770
I opened a ticket and the customer service representative said:

"Greetings,

OK, so after I sent you the last response I did a little bit more reasarch on the web for this issue.

I have found that AMD cards have been having issues with WoW since Mists came out. AMD has released an official driver application profile that can be downloaded in conjunctin with your driver that smooths out the issues poeple have been having.

The problem is that they have only released this for PC, not MAC. Because AMD is working on the issue and have stated that they are working on a new driver to resolve these issues more permanatly.

But you could probably post on their forums for more info."

So, I guess we'll just have to wait before the problem is fixed.
Reply Quote
- Technical Support
90 Human Priest
6120
Have you reset your computer's SMC, and did you use the software update to 10.8.2 or did you download the combo installer and use that? The combo is always recommended over the software update download, as the delta installers almost always miss vital files that should be update but aren't. And resetting the SMC can solve a lot of problems that have cropped up over time and give you what oftentimes feels like a clean slate to work from.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote
90 Human Paladin
13770
Thanks for the response, but yeah, I used the combo updater and one of the first things that I did was reset the SMC and PRAM.
Reply Quote
Support Forum Agent
Hey Marc,

Can you check your repair-on demand.log and see if it is spamming the repair function to repair data during game play?

This is located in /Users/Shared/Battle.net/Agent/Agent.1363/Logs. Make sure you remove any computer/usernames in the log.
Reply Quote
90 Human Paladin
13770
This is what was in my repair-on demand.log

#-----------------------------------------------------------
# System started at 2012-09-25 21:31:26.1172
#
#-----------------------------------------------------------
21:31:51.7448 Repair of Interface\AddOns\Blizzard_GlyphUI\Blizzard_GlyphUI.lua: failed due to incomplete patch chain.
21:31:51.8484 Repair of Interface\FrameXML\StaticPopup.lua: failed due to incomplete patch chain.
21:31:52.5176 Repair of Interface\FrameXML\FriendsFrame.lua: failed due to incomplete patch chain.
21:31:52.5633 Repair of Interface\FrameXML\InterfaceOptionsFrame.lua: failed due to incomplete patch chain.

#-----------------------------------------------------------
# System started at 2012-10-05 07:14:50.5954
#
#-----------------------------------------------------------
08:38:23.6650 Repair of Interface\FrameXML\FriendsFrame.lua: failed due to incomplete patch chain.
08:40:22.1584 Repair of Interface\AddOns\Blizzard_GlyphUI\Blizzard_GlyphUI.lua: failed due to incomplete patch chain.
08:40:22.1607 Repair of Interface\FrameXML\StaticPopup.lua: failed due to incomplete patch chain.
08:40:22.1637 Repair of Interface\FrameXML\InterfaceOptionsFrame.lua: failed due to incomplete patch chain.
Reply Quote
- Technical Support
90 Human Priest
6120
Marc, you don't by chance play the game before it's completely patched do you? By that I mean you click the Play button when there is still downloading going on.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Reply Quote
90 Dwarf Paladin
10540
HORRIBLE FPS compared yesterday. I have played MOP since release and the graphics were actually impressive and the gameplay smooth. (MBPro RetDisp). I woke up this morning to HORRIBLE FPS (14 with add ons 21 with all disabled). What happened in the restart yesterday? Did my computer break overnight? Someone please help me understand what is going on. My eyes are KILLING me with these frame rates and nothing that I know of on my end changed in 9 hours.
Edited by Tånkher on 10/8/2012 8:47 AM PDT
Reply Quote
90 Human Paladin
13770
No, I always wait until the launcher says "Game is up to date" before clicking play.
Reply Quote
90 Undead Rogue
12870
I did play yesterday and had the same problem with FPS. Before I played in 35 fps now with the same configuration the fps is 10. What happening?
Reply Quote
Support Forum Agent
We're tracking these reports in this thread. Please post the requested information there.

http://us.battle.net/wow/en/forum/topic/6794322614#5

Thanks!
Reply Quote
MVP - Technical Support
90 Human Warrior
18580
10/08/2012 08:47 AMPosted by Tånkher
HORRIBLE FPS compared yesterday. I have played MOP since release and the graphics were actually impressive and the gameplay smooth. (MBPro RetDisp). I woke up this morning to HORRIBLE FPS (14 with add ons 21 with all disabled). What happened in the restart yesterday? Did my computer break overnight? Someone please help me understand what is going on. My eyes are KILLING me with these frame rates and nothing that I know of on my end changed in 9 hours.


how many of you are putting laptop to sleep instead of shutting it down?

be aware that OS X STILL has an opengl bug where your fps will drop by as much as 60% after using sleep on any system running 10.7 or 10.8. Apple has blown off fixing this bug for over a year. It's something you just have to account for and get used to. If your fps is terrible. there are two fixes for opengl bug. 1. Change resolution in OS X (not ingame) then change it back. or 2, reboot.

If after doing this, you still have fps problems, we will move from there.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]