graphics clipping since MoP launch *Fixed*

100 Human Warlock
im not entirely sure how i fixed it, i forced a wow repair, launcher downloaded a 350 mb file, i started the game and the problem was still there, went into my advanced graphics options noticed it reverted back to dx9 on its own, changed it to dx11 restarted the game and it was fixed!

Hi i was wondering if anyone else is having this issue?

anything with water or buildings is graphically unatractive to look at.

everything worked fine untill MoP went live.

below is a screenshot of my issue. please help


System Information
Time of this report: 10/3/2012, 21:27:57
Machine name: DEVIN-PC
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
Language: English (Regional Setting: English)
System Manufacturer: LENOVO
System Model: 1024AXU
BIOS: Default System BIOS
Processor: Intel(R) Core(TM) i3-2330M CPU @ 2.20GHz (4 CPUs), ~2.2GHz
Memory: 6144MB RAM
Available OS Memory: 6058MB RAM
Page File: 1618MB used, 10495MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

also has nvidia gtx 520m 1gb dedicated card built in

this is a laptop
Edited by Banqdots on 10/4/2012 2:43 PM PDT
Reply Quote
90 Goblin Hunter
I'm having the exact same issue. I understand what is causing it but have no idea how to change the setting.

Basically what is happening (and you'll notice that as you move close to things the flashing/clipping goes away on those things) is that the game client or your video card is reducing the level of detail on the meshes of 3D objects that are in the distance, because hypothetically we shouldn't need to see the small details on those objects anyways from a distance. The issue is that the distance setting is too low and so we are seeing these reduced quality models too closely.

I wasn't having this issue at all until the pandaria pre-patch when we started seeing fancy new graphics, so I'm guessing that either this setting was added to the pandaria game client, or that the game client started leaving this setting up to the video card? I'm hoping somebody has an idea how to either change the threshhold on the level of detail setting, or full on disable it, I don't mind the slight fps decrease that will come with disabling it! It is making Pandaria look really ugly when I know it's not :-(
Reply Quote
100 Human Warlock
i believe i have my distance set to high
Reply Quote
90 Goblin Hunter
Good to know you got it fixed, that gives me some hope! I'll try fussing with it some more :-)

Edit: This fixed it for me too, wish I had just tried it for giggles weeks ago! Guess I wasn't annoyed enough until now! Pandaria is properly beautiful now :-D
Edited by Mubble on 10/4/2012 6:42 PM PDT
Reply Quote
100 Human Warlock
glad i could help!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)