[quest bugged] The Mariner's Revenge

90 Dwarf Hunter
9315
At Soggy's Gambit, in the Dread Wastes, I came across a bug in the quest The Mariner's Revenge. I was disconnected from the network when I was on The Mist-Hopper Jr. After re-establishing my connection, I was in the water. I abandoned the quest, and returned to re-accept it.
Quest worked as intended until I reached the southern docks, and the quest giver vanishes. The boat never spawned, no matter how many times I abandon then re-take the quest, the boat has not re-spawned.

I have talked with a represenative about the problem, and followed their instructions, but the problem was still there. I even went as far as to delete and re-install my client. I submitted a ticket in-Game, and short of addressing the problem on the Forums, I am out of options.

I hope that the problem is addressed, and fixed soon.
Edited by Domungus on 10/4/2012 10:48 AM PDT
Reply Quote
90 Dwarf Hunter
9315
The issue was resolved hours after my original post, after I petitioned a GM and they helped me manually.

I figure I'm not the only one who had this problem, and wanted to let anyone following this thread know that the issue had been resolved manually by someone at Blizzard.
Reply Quote
90 Draenei Paladin
5705
I am having the very same problem today!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]