Low FPS/Performance Issues [formerly @known issues (10/8) update]

(Locked)

15 Pandaren Monk
11090
Anj that is very interesting as my imac was recently at the apple store for a free hard drive replacement program and they cleaned it up while they had it open.

I noticed no change with my graphic issues

in fact I have no problems with any other games

just blizzard

hmmm
90 Human Warlock
9960
Just a note -- the FPS capping is for overheating issues, which can sometimes lead to the same problems that the rest of us have been experiencing. Did I cap mine? Yes. Helps keep my fans from going crazy in high population areas. Did it fix the issue? No. Just makes less noise now in graphically intense zones.
90 Blood Elf Paladin
5400
Experiencing the extremely low FPS only issue.

iMac 2.93 Ghz i7
8 GB 1333 MHz DDR3
ATI Radeon HD 5750 1024 MB
Mid 2010
Hardwired Broadband 50 mbps internet

Q 1:
Nov 29 2012
-Bought WoW Cataclysm
-Bought WoW MoP
-Fresh install of both, no add-ons
-Character is level 80
-With programs installed, while patches were downloading, played with all settings on ultra in Cataclysm content
-Levelled from 80 to 86 at 60+ fps
-At this point, Mac is running OS X Lion

Went on a business trip and returned

Dec 6, 2012
-Noticed that launcher didn't complete Landfall patch on its own
-Completed Landfall patch
-Logged in after fresh restart:
-- 5-7 FPS in all content with graphics on Ultra, 32-bit application, Windowed
-- 5-8 FPS with sunshafts and SSAO disabled
-- 25-30 FPS with all graphics on lowest
-- FPS is identical across all windowed modes

Q 2 and 3:
What FPS and in what Windowed modes?
As above.

Q 4:
When does it happen?
The 5-7 FPS is evident even in the log-in screen.

Q 5:
Have I completed the steps from the Mac low performance article?
Will update this once OS Mountain Lion has been loaded and SMC reset.

Q 6:
http://pastebin.com/WqBuavgz

Q 7:
32, 64, or both clients?
FPS drops to 21-30 at all graphics setttings on low when using the 64-bit client.

System Information:

Software:

System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
64-bit Kernel and Extensions: Yes
Time since boot: 11:39

Hardware:

Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,3
Processor Name: Intel Core i7
Processor Speed: 2.93 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 8 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM112.0057.B00
SMC Version (system): 1.59f2

Graphics/Displays:

ATI Radeon HD 5750:

Chipset Model: ATI Radeon HD 5750
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68a1
Revision ID: 0x0000
ROM Revision: 113-B9710C-238
EFI Driver Version: 01.00.417
Displays:
iMac:
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI

I'll update effects of
-installing Mountain Lion
-resetting SMC
It's definitely heat in my case.

I replaced my hard drive a while back. The newer one is not iMac-specific so I had to use SSD Fan Control. At least for my aging iMac, temperature control is very necessary. If the fans are not regulated then it's guaranteed the game will stutter after a few minutes.

Btw, I only play WoW so I can't compare gaming performance before and after I cleaned the iMac.

However, I'm not saying overheating is the problem for most Mac users. There is definitely something else going on with the WoW Mac-client prompting many users to post about performance issues. Blizzard needs to investigate this further...
90 Undead Rogue
7125
I have a 15" Macbook Pro Retina, 16GB RAM, 512GB SSD drive, Core i7 CPUs.

I had NO FPS issues until today's maintenance. I was happily getting 60-90 FPS - now I'm at 8-16.
85 Draenei Hunter
13000
I also had no slowdown until today. went from ~34 dps to 9-11

Software:

System Software Overview:

System Version: OS X 10.8.2 (12C2034)
Kernel Version: Darwin 12.2.1
Time since boot: 1:52

Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32

Graphics/Displays:

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI
85 Draenei Hunter
13000
Yeah, I can't play like this. It's terrible, and my laptop isn't even a week old yet.
90 Undead Rogue
7125
I have noticed my fans are not running which is VERY suspect. I run gfxCardStatus which tells me my Nvidia card has been selected but I hear no fans ... they usually keep the MBP Retina nice and cool even when it's working hard - but not even running at all now.

I wonder if WoW is only utilizing the Intel GPU (which would suck)?
90 Undead Rogue
7125
And yes - it is unplayable, and yes it's after Blizzard's maintenance. Hopefully someone important at Blizzard plays on a MBP w/ or w/out Retina and is equally as upset.
Support Forum Agent
Hey all,

Thanks for the feedback thus far on this. We're going thru the feedback and see what we can find out about this issue and recreate it.

For now if you have low FPS issues, create a new thread and we'll try to work 1x1 to investigate. If we need additional data, we'll open a new thread for tracking.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]