terrible random fps drops

(Locked)

100 Tauren Druid
22000
I too have been having this issue, I decided to set aside a few hours tonight to try and fix it, I can say I have had no luck.

I am running a AMD Phenom 1090T Black Edition, 16GB 1600 Corsair RAM, 2x HD 6970s tested in both XFire and non XFire setups and using a Windows 8 64-bit OS.

I tried: completely removing and uninstalling my catalyst drivers, then installing them again. Removed a hard drive that had been causing me slow down issues (it helped to do that anyway, but didn't affect WoW really) then I followed some advice from a thread that was about the same issue back in 2011, and I did a selective startup, getting rid of any unnecessary processes and ran the game from 0 cache, addons or WTF.

Guess what, still there!!

So, at this point, tired, frustrated, and a little bit angry that my machine which scores just fine on much higher graphic benchmarks, cannot run WoW steadily at at least 60 FPS.

I rarely try and place blame so directly but... BLIZZARD, FIX YOUR S**T!!!
100 Blood Elf Death Knight
10790
Glad to know I'm not the only person out there; been a long time WoW player and this has never happened to me. Not even on other Blizzard games does this happen. Where's a Blue post when you need it?
I'm having the same problems.
94 Blood Elf Rogue
8325
I hope this is fixed asap. I can deal with the other minor bugs, but this is affecting gameplay.
100 Tauren Shaman
15870
Guess this is the thread to watch. My fps took a header into a dung heap too.

I want to go back to playing Ultra across the board and enjoying 30-50 FPS.

I'm currently down to Low and getting around 25 FPS when I fly off away from everything else.

Getting under 10 FPS in LFR raids.
90 Worgen Druid
6920
Glad to see I'm not the only one seeing this.

I keep getting FPS drops from 80 to single digits. Always at random, and last for 5+minutes.

I only experience this on my Windows 7 machine. When I play on my Mac, works fine.
1 Draenei Mage
0
My FPS is usually 90+ and latley it drops to 20 even on the lowest possible setting in WoW,
100 Orc Death Knight
9270
Bump

Framerate on my rig is generally 100 to 200 FPS, in raids the lowest it generally drops is around 70.

In raids now... 3 fps.

Nothing has changed on my end. Fix this Blizz... I got raids to do!
100 Night Elf Druid
13575
As the saying goes, you can't polish a turd. That turd being wow. I have spent many, many hours researching this problem and it's been an issue for at least 2 years now.
For example, I'll get a very solid 40-60 FPS in 25 person raids and then it will drop down, sometimes below 10fps. I'm running an AMD 6 core and GTX 460 (oc'd to 860). Never more than a ~50% load on my GPU.
I've considered upgrading to an i7 system, but I'm really having my doubts now. Seems to effect lots of systems not specific to CPU brand.
It's almost as if the game can only go as fast as the communication between your computer and the server. Like we're playing the game via remote desktop.
22 Orc Warlock
0
bump. brand new rig, having the same fps drop issues.
90 Pandaren Hunter
6590
bump. brand new rig, having the same fps drop issues.
Other than "Update your drivers" you won't get an answer here. It's the way the horrible game engine works. If I walk into the trade district in stormwind or the shrine in the vale, I'll drop down to 20-30 fps with all the people on the screen and I'm running an i5 2500k @ 4.5ghz, a 660 ti, 8gb of ram and the games on an SSD.
90 Night Elf Druid
11475
I'm having this issue right now and its horrible! I also tried reinstalling drivers and doing every update possible/ checking hardware/ etc. It happens at random times I cant pinpoint the cause but I go down to 1 Framerate per second!!!! I cant figure out the problem :( I know its an issue with the game but idk what to do about it.
100 Dwarf Monk
14255
I've gone without addons to see a few times and it still happened. Yes i recover usually it lasts about 8 seconds or so. But, it's just how often it's starting to happen.

I'm starting to think it's something related to the animations.


Seems to me like it has something to do with being in Cross Realm Zones.


That's exactly it this issue wasn't occurring until CRZ was introduced. A decent way of testing this would be if Blizzard allowed us to disable CRZ. If we could do this it would likely prove one way or the other. Considering we are not allowed to disable or opt out of CRZ it really does add more to it is CRZ but because Blizzard is so proud of it we are stuck with it even though a large amount of the population never wanted this change to the game to begin with.
90 Blood Elf Mage
9140
I get this at random times while adventuring in low population zones... and more frequently in dungeons and raids... so often in dungeons and raids that it makes it almost unplayable. This is definitely more prevalent lately than it had been previously.
90 Human Priest
10710
same problem with me. hope they fix it soon, i want to start arenas without having this !@#$up
90 Human Death Knight
4490
Have a look at my post, this might help some of you fixed my issues.
http://us.battle.net/wow/en/forum/topic/10082368234?page=1#3
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]