An Internal Error Occurred

Support Forum Agent
From what I've seen, some people move files to the desktop thinking it creates a shortcut. While you may not see any immediate consequences, when a patch drops, this does in fact break the game, since it is not in the right location to patch.

Part of this happens because the original desktop shortcut was removed in 5.0.0, so users are trying to recreate a shortcut, not realizing a copy of the game is being made and not a shortcut (Alias).
Reply Quote
90 Blood Elf Paladin
7965
i just had the same problem with 5.1 patch. thank you so much. and yeah my World of Warcraft.app was on my desktop so i moved it back and it worked fine. thanks for the help
Reply Quote
90 Human Paladin
5300
I moved mine back to my wow folder, and now when i reopen it, it starts to re-install mop, i did the terminal command and i got :/Applications/World of Warcraft:
Cache
Data
Interface
Launcher.db
Logs
SetupOSX.mpq
Updates
WTF
WoW-x.x.x.x-4.0.0.12911-Downloader.app
WoW.mfil
WoW.pfil
WoW.tfil
World of Warcraft Launcher.app
World of Warcraft-64.app
World of Warcraft.app

Any ideas?
Reply Quote
Support Forum Agent
If it is reinstalling MoP, then it may mean that it may detected a lot of bad data needs to reinstall. The latest update of Blizzard Tools (Agent/Blizzard Launcher) added a repair functionality to the clients.

I would let it download all the data it is needed. Then If you want a desktop shortcut, just create an Alias instead of moving files.
Reply Quote
19 Blood Elf Mage
150
Impossible
Reply Quote
90 Blood Elf Paladin
10600
I had the exact same issue... At launch, (only if I was using the Launcher and not either one of the .exe files) I would get the error message: "An internal error ocurred, please restart. If problems persist contact customer support".
So I pretended like I want to download the game files all over again and pointed the installer to my already existing directory of 'World of Warcraft' and let it do its thing for like 3 minutes (it looked like it froze for a little bit - be patient), but it finally checked the integrity of all other files within the directory and the installer came with the load bar to 100% green, ready for me to hit "Play' > I did and the game launched successfully.
To double check, I exited the game, went to the WOW directory and tried to launch it using "World of Warcraft Launcher" > WORKED like a charm > Shezam!
Reply Quote
20 Dwarf Hunter
215
help i just can't get it right I lauch world of warcraft form the file but it sayas internal error i just wanna play agian please help i beg of you help me
Reply Quote
Support Forum Agent
Try our Internal Error article to see if this helps.
Reply Quote
20 Human Paladin
20
I too have the same problem only got to play one day :(.I found my app in my documents i didn't put this there that's where it was the whole time and the shortcut on my desktop was created by the setup. Anyway I moved the file to the program file folder world of warcraft and now it works. So try to find your app file and put it in the folder.
Edited by Iandrew on 9/27/2013 11:11 PM PDT
Reply Quote
10 Dwarf Hunter
0
Thanks this works fine
Reply Quote
30 Human Hunter
250
I own a HP windows laptop. However I am getting the same message :/ Better get to it.
Reply Quote
30 Human Hunter
250
Yep I fixed it
I was running the program from the wrong WoW folder. How stupid am I?...
Reply Quote
90 Draenei Shaman
6890
This helped alot. Thanks i moved the shortcut i made back in there haha. works perfect.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]