Two-person mount bug

100 Human Paladin
17765
For two days I've had issues jumping on a multiple-person mount (areas: Vale of Eternal Blossoms, Townlong Steppes) - no matter what the mount is (tundra mammoth, sandstone drake, obsidian nightwing, 2-seater chopper) I can't get on. I have the green "mount" arrow but nothing happens. Reloading UI doesn't work; once moving away from original area did, but other times this isn't helping. Logging out is no help.

Found something that worked: I challenged the other player to a duel. With the dueling flag up, I was able to mount his sandstone drake. This worked once. It didn't work the next time I tried it.
Edited by Vallynne on 10/5/2012 4:20 PM PDT
Reply Quote
90 Worgen Hunter
11645
Yeh, I am having the same issue
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]