Why can't I Log In?!

2 Draenei Priest
0
Hello,

I created a Battle TAG and i tried to add a friend and they tried to add me and it has not worked?

When i try to add them, it says "Player not found"

When they tried to add me, it said something to the effect of, 'Sent" but as yet i have not received anything?

Am i doing something wrong?
Edited by Angavar on 10/4/2012 5:23 AM PDT
Reply Quote
2 Draenei Priest
0
And Now i can't log into my account at all?

"There was a problem logging into your account. You may not have world of warcraft attached to your account, or you may be logging into a region different from the one you created the account in"

What has caused this?

I have changed nothing except create a battle tag *frown*
Reply Quote
2 Draenei Priest
0
Update.....

Seeing as though i could still log into remote chat. A guildie suggested changing my email address.

This worked. I was able to log in.

And now i have the Battle Tag Feature on my profile ingame.

Adding a Battle Tag to my account definitely had something to do with the problem.

The End.
Reply Quote
Support Forum Agent
So this resolved for you?

I suspect what happened was changing your email refreshed your account. That's exactly what needed to happen :P

Changing emails, passwords, address info, etc., is not guaranteed to force a refresh, but it usually does.
Reply Quote
2 Draenei Priest
0
Yes, thank you Orlyia it is fixed.

Cheers :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]