Having trouble looting items...

90 Human Rogue
14380
Hi!

So I've been having this problem since Mists released. When I go to loot something, SOMETIMES (both when I'm in a party and when I am not), I click the item to loot it, and it doesn't loot. I've had the error in the past where if you loot too quickly it keeps your crouched and you have to wait a bit before being able to loot again, but this is different. It happens on random mobs, or when I tried to loot an onyx egg. Just now I tried to loot something from DMF for the enchanting quest and I decided to post here. Any suggestions? I've updated my video card and make sure all my addons are up to date, and apparently the issue has happened to a few of my guildies, too.

Thanks much :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]