Missing 5 mounts!

90 Troll Mage
15160
So I transferred my mage on kil'jaeden WoW1 account to Illidan Wow3 account (did not change factions). Several hours later I find that 5 of my mounts suddenly become missing. Now my armory page still says I have these mounts but in-game they are missing. The mounts are all 3 Blizzard store mounts, the Collectors Edition Mount and the Annual Pass Mount. Can you please fix this Blizzard.

Also I have a ticket i created 2-3 Days ago, still no answer on that. Any word on that please?
Edited by Zorixon on 10/3/2012 7:16 AM PDT
Reply Quote
100 Undead Warlock
12125
The Annual Pass, Collector's Edition and store mounts are all tied to a specific license, not a battle.net account. So if you didn't upgrade WoW3 to a CE and don't have the Annual Pass on that account, you can't access the mounts there. At least that's my understanding.
Reply Quote
90 Gnome Warlock
5920
10/03/2012 07:15 AMPosted by Zorixon
The mounts are all 3 Blizzard store mounts, the Collectors Edition Mount and the Annual Pass Mount. Can you please fix this Blizzard.


Those mounts are bound to the WoW account that you got them on not the Battle.net account. That is working as intended.
Reply Quote
90 Troll Mage
15160
These mounts are Account-Wide. I have checked. And if they are not intended to, why are they missing from BOTH accounts.
Reply Quote
90 Gnome Warlock
5920
10/03/2012 07:49 AMPosted by Zorixon
These mounts are Account-Wide. I have checked. And if they are not intended to, why are they missing from BOTH accounts.


Are you sure? My understanding is that when you transfer from one account to another that those mounts will not transfer. Are you positive they are not on the old account that you transfered off of? If they are not then that would be a bug and I would put in a ticket asking about it.
Reply Quote
90 Troll Mage
15160
Also just to clarify they are under the same battle.net account.
Reply Quote
90 Troll Mage
15160
Are you sure? My understanding is that when you transfer from one account to another that those mounts will not transfer. Are you positive they are not on the old account that you transfered off of? If they are not then that would be a bug and I would put in a ticket asking about it.
I play the WoW1 account alot as its my main account. It by rights should still have the mounts. However they are now missing.
Reply Quote
100 Undead Warlock
12125
Edit because you posted while I was posting :

Wait on your ticket. You should have the mounts on the originating account still. The fact that you don't sounds like a bug.
Edited by Diamora on 10/3/2012 8:09 AM PDT
Reply Quote
90 Gnome Warlock
5920
10/03/2012 08:05 AMPosted by Zorixon
Are you sure? My understanding is that when you transfer from one account to another that those mounts will not transfer. Are you positive they are not on the old account that you transfered off of? If they are not then that would be a bug and I would put in a ticket asking about it.
I play the WoW1 account alot as its my main account. It by rights should still have the mounts. However they are now missing.


Then yeah that isn't right... sorry that does suck. I would wait on your ticket. A Blue here might be able to look at it for you, but that is never a guarantee. I do hope you get it worked out soon.
Reply Quote
90 Troll Mage
15160
yep, not right. :(
Reply Quote
90 Troll Mage
15160
Mounts still missing >_<
Reply Quote
Support Forum Agent
10/03/2012 07:15 AMPosted by Zorixon
Also I have a ticket i created 2-3 Days ago, still no answer on that. Any word on that please?


The only ticket that I can find that was submit around two days ago was about an entirely different issue and has already been addressed, Zorixon. The only ticket I can find on this issue was submit around 45 minutes ago.

Was there another ticket?

Mounts still missing >_<


It does appear that you should qualify for the MoP collector's edition mount and the Tyrael's Charger, I'm not entirely certain why you wouldn't have it. Can you log out of the account entirely then let me know?
Reply Quote
90 Troll Mage
15160
10/03/2012 04:28 PMPosted by Vrakthris
Can you log out of the account entirely then let me know?
Logged out entirely, then back in. Mounts are still missing. I did have them before I did the transfer, then 2hrs after the transfer was done they all disappeared.
Reply Quote
Support Forum Agent
10/03/2012 04:32 PMPosted by Zorixon
Logged out entirely, then back in. Mounts are still missing. I did have them before I did the transfer, then 2hrs after the transfer was done they all disappeared.

I didn't say "then log back in" I said please log out and then let me know. :)
Edited by Vrakthris on 10/3/2012 4:35 PM PDT
Reply Quote
25 Night Elf Druid
0
10/03/2012 04:32 PMPosted by Zorixon
Can you log out of the account entirely then let me know?
Logged out entirely, then back in. Mounts are still missing. I did have them before I did the transfer, then 2hrs after the transfer was done they all disappeared.


He's asking you to log out, and stay out.

So he can jump on your account.

Let him know.
Reply Quote
Support Forum Agent
10/03/2012 04:35 PMPosted by Thunderwulf
So he can jump on your account.


That shouldn't be necessary but I can usually give the account a nudge, to update it, but it is most effective when the account is logged out entirely. :D
Reply Quote
90 Troll Mage
15160
Ah my bad >_< (on illidan don't wanna lose my spot)

Right completely logged off
Edited by Zorixon on 10/3/2012 4:37 PM PDT
Reply Quote
Support Forum Agent
Alright, you should be set. Please let me know if they show up in your mail or in the pet/mount list now.
Reply Quote
90 Troll Mage
15160
K, logged back in, atm Mounts are still missing in my mount list, and no mail.
Reply Quote
Support Forum Agent
Alright, can you try creating a new character and see if they show up in the mail?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]