Mouse issue - Help please!

90 Pandaren Monk
8055
My mouse is having problems with wow. Outisde of wow it is perfectly fine, but when i load up wow in order to click anything i must right click it first then click on it, and sometimes that doesn't work. a reboot fixed it at first but now even after several reboots and clearing the cache/wtf out in wow it is still not working.

macbook pro 2010
2.4 ghz
4 gig ram

Mouse - Razer Naga
Reply Quote
Support Forum Agent
Have you've tried to reset your UI and see if it helps? https://us.battle.net/support/en/article/resetting-your-ui-mac
Reply Quote
90 Pandaren Monk
8055
Yeah i've reset my ui, swapped between fullscreen and windowed and windowed fullscreen, reset my video options, swapping between windowed fullscreen and windowed helped once but doesn't seem to be helping now, or rebooting. still won't click.
Reply Quote
90 Pandaren Monk
8055
it's getting worse with the patch, it goes in and out sometimes it works sometimes it doesn't i still have no idea what could be wrong with it :/ My mouse just randomly stops clicking properly or highlighting stuff on mouseouver :/ Resetting my ui doesn't help clearing the catch/wtf doesn't work. but it's only with wow that it seems to be happening :/
Reply Quote
Support Forum Agent
And you have the latest razer synapse drivers for your mouse?
Reply Quote
90 Pandaren Monk
8055
yes i do
Reply Quote
Support Forum Agent
What happens when you use your trackpad for clicking, does the issue persist? This will help us narrow down the issue. Also please post full system specs. Thanks!

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information: http://i45.tinypic.com/foodww.png
    4. Paste the contents of the copied system information here (Command-V)
Reply Quote
MVP - Technical Support
97 Draenei Mage
6645
In game can you run this :

/dump GetCVar("useDesktopMouseSpeed")

And advise what it reports the setting is (will appear in the general window on the left)
Reply Quote
90 Pandaren Monk
8055
Software:

System Software Overview:

System Version: Mac OS X 10.7.5 (11G63)
Kernel Version: Darwin 11.4.2
64-bit Kernel and Extensions: Yes
Time since boot: 3:58

Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro6,2
Processor Name: Intel Core i7
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MBP61.0057.B0F
SMC Version (system): 1.58f16
Sudden Motion Sensor:
State: Enabled

Graphics/Displays:

NVIDIA GeForce GT 330M:

Chipset Model: NVIDIA GeForce GT 330M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0a29
Revision ID: 0x00a2
ROM Revision: 3560
gMux Version: 1.9.21
Displays:
Color LCD:
Display Type: LCD
Resolution: 1440 x 900
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

Intel HD Graphics:

Chipset Model: Intel HD Graphics
Type: GPU
Bus: Built-In
VRAM (Total): 288 MB
Vendor: Intel (0x8086)
Device ID: 0x0046
Revision ID: 0x0012
gMux Version: 1.9.21

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI
Reply Quote
90 Pandaren Monk
8055
/dump GetCVar("useDesktopMouseSpeed")
says "0" in the chat box, doesn't improve the mouse issue, if anything now it's gone from not mousing over to just not clicking but mousing over lol, i have no clue what's wrong with it :(
Reply Quote
90 Pandaren Priest
12155
I have the same problem today, ever since the patch was applied. Wasn't the patch supposed to fix problems that were happening when interacting with certain things? Now that its applied, I can't turn in quests or accept new quests.
Reply Quote
MVP - Technical Support
97 Draenei Mage
6645
/dump GetCVar("useDesktopMouseSpeed")
says "0" in the chat box, doesn't improve the mouse issue, if anything now it's gone from not mousing over to just not clicking but mousing over lol, i have no clue what's wrong with it :(


That wasn't meant to do anything other then show what you have a certain in game variable set to.

Try adding this line in your config.wtf file at World of warcraft folder -> WTF :

SET useDesktopMouseSpeed “1″

You can edit it in TextEdit if it asks.
Reply Quote
1 Blood Elf Paladin
0
Steelseries Legendary Mouse

I move forward by holding down both right/left click on the mouse and use strafe button on the side of the mouse. When using the strafe button the mouse intermittently stops moving forward and only strafes left and right untill I release the right/left click. I just started playing MoP today and it only started happening in this xpac.
Reply Quote
90 Worgen Warlock
7095
yea dude . . im getting the same problem. . outside of wow it works perfectly,but in wow ramdomly or most of the time the mouse seems to not respond for anything,. . i go straight to my desk top and it works. . go back into wow and it f's up. . . can someone help
Reply Quote
90 Troll Hunter
4275
I'm having the exact same problem ... I play Dota 2 and this mouse has no issues, but for some reason in WoW the buttons are all unresponsive. The only button working all the time is mouse 1, mwheelup and mwheeldown. Mouse 2 and mouse 3 are working half the time. Please someone figure this out ... I don't think buying another mouse will fix the problem.
Reply Quote
Support Forum Agent
I'll send this feedback up to the team for review and see what we can find out. Thanks.
Reply Quote
- Technical Support
90 Human Priest
6220
The only button working all the time is mouse 1, mwheelup and mwheeldown. Mouse 2 and mouse 3 are working half the time.


Are mouse button 2 and 3 single key binds, or are they combined key binds? A combined button bind would be something like CMD-F or Shift-G. OS X treats multibutton mice as if they were keyboards, thus if you are already pressing one or more buttons when you attempt to press Button 2 or Button 3, you may end up with a button press that is not processed (unresponsive) due to hitting the limit to the number of simultaneous key presses your main keyboard can process at once.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
Edited by Tiapriestess on 12/17/2012 7:55 PM PST
Reply Quote
Support Forum Agent
What mouse specially are we having issues with. Please list the make and model, as well as your system specs.

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information: http://i45.tinypic.com/foodww.png
    4. Paste the contents of the copied system information here (Command-V)
Reply Quote
90 Troll Hunter
4275
I'm using windows 7. Was using an intellimouse explorer 3.0. Just bought a gigabyte m6800. Both mice are behaving the exact same way, and in other games (namely dota2), there are no issues. Mouse3 is bound to auto run, and Mouse2 is default (moving camera angle).
Reply Quote
Support Forum Agent
If you're on Windows, you will want Technical Support (Windows) forums: http://us.battle.net/wow/en/forum/1011701/

Mac forums won't be able to offer Windows friendly solutions sometimes.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]