Macbook pro in game screen recorder broken?

90 Night Elf Priest
4635
the in game screen recorder for Mac's is all greyed out. I cannot change the settings at all. Its almost as if i have an option selected saying i have mac in gamer recorder disabled....but i looked for buttons like that and none exist. My in game recorder was working flawlessly prior to MoP. just wondering if this is a known issue or I have some setting messed up?

I can try and post a pic if more info is needed, let me know! thanks!
Reply Quote
Support Forum Agent
This is a known issue. You have to use the 32-bit client for recording.

http://us.battle.net/wow/en/forum/topic/6489880421

EDIT: Padim informed me the upcoming version of PTR has the revamped changes for the movie recorder on 64-bit. Please try it out when you have time.
Edited by Machkhan on 10/30/2012 10:47 AM PDT
Reply Quote
90 Draenei Shaman
12910
I switched to the 32-bit client and have access to record videos, but the recorded videos are awful. Sound works, but the video is garbage.

http://www.youtube.com/watch?v=U20Egz6vbns&feature=youtu.be

Any idea why this is happening?

Thanks!
Reply Quote
Support Forum Agent
Is this with the live client or the PTR 5.2 client?
Reply Quote
100 Orc Shaman
21185
I'm experiencing the same issue with the current live client. I've tried recording at various resolutions, frame rates, compression codecs, and switching between fullscreen and windowed modes to no avail.
Reply Quote
90 Worgen Druid
10125
Im having the same video issues. Just a bunch of scrambled colors on the 32 bit live client
Reply Quote
Support Forum Agent
This may be resolved in the 5.2 update. Have you had a chance to check the PTR client for sure?
Edited by Machkhan on 3/6/2013 11:13 AM PST
Reply Quote
90 Human Paladin
12825
5.2 went live today. I have had the same problem with my MacbookPro as others have reported. Sound worked fine, but video is scrambled. That was using the 32 bit client since the 64 bit client did not have the option to record. I can report that the 64 bit client can now record movies, but the result is the same. Sound but scrambled video. I also tried changing settings. There could be one I am missing but no luck so far finding it.
Reply Quote
90 Pandaren Monk
8540
I too have tried to record a video on 64-bit since the patch with the same results. I got so excited when I saw the new patch came out. I figured since they allowed 64-bit to record again they had all systems go. WRONG! I will try 32-bit and see if they at least fixed that(not holding my breath). I enjoyed that feature so much, but now it makes me want to pull my hair out.

Looks like 32-bit is still messed up as well. Fix it or take it out IMO.
Edited by Buddistbelly on 3/6/2013 10:22 AM PST
Reply Quote
Support Forum Agent
Thanks for the reports. We'll investigate further and see why this continues to happen. I'll ping back if I hear any updates or require additional information.

Thanks!
Reply Quote
90 Goblin Priest
10080
I'm hoping this issue gets resolved soon as well. I'm experiencing the same good sound but scrambled video issue. That and the recording stops as soon as it starts recording for some reason. This happens in both 32 and 64-bit clients.

Live 5.2 client obviously now.

Running on an iMac 27" (Mid 2011), 16 GB RAM, i7 3.4GHz processor.
OS X 10.8.3

It's a wonderful feature. I miss it.
Edited by Crossbuster on 3/21/2013 11:46 PM PDT
Reply Quote
Support Forum Agent
This seems to be occurring due to having high/ultra shadows when you log into the game. Try lowering your shadow quality when you log in, save the change, and exit. Enter once more and you should be able to record movies, as long as you do not use high/ultra shadows.
Reply Quote
90 Human Paladin
12825
I checked and my Shadows were set to Ultra. I changed it to Good and logged out, then logged back in. I don't see any difference in the movie that I then made when I logged back on my character.
Reply Quote
90 Human Paladin
12825
Update. I exited the game client completely, restarted the client and logged in. This time the movie recording worked!!! So don't just log out. Changed Shadows from Ultra to Good, then exit the game completely. I next tried the same process with Shadows set to High. This did not work, i.e. same results as before with Shadows set to Ultra. I then changed it back to Good, exited and logged back in. Worked that time. By the way I have Graphics set to Ultra and everything other than Shadows is set to High or Ultra.

So now the question is whether this is fixable or do we just have to set shadows to Good to record a movie?
Edited by Danyal on 4/12/2013 4:45 PM PDT
Reply Quote
66 Undead Warrior
0
Awesome. I was having the same issue, but changing the shadows fixed it for me as well.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]