Razer naga and modifier keys.

90 Blood Elf Death Knight
10675
Please bare with me. I'm not great with computers. So i just got a razer naga mouse yesterday. been trying to get it to work with the Numpad, and some modifier keys. Buttons 1-12 work with the Numpad as they should. When i try to use Shift and the naga it doest recognize that shift is being used. I have also tried with alt,control.

I believe i have all the latest software and drivers installed for the mouse. im running OS 10.7.5.

I changed the naga buttons to a,b,c and tried to type in chat with them a,b,c work fine. WHen i hit shift to Capitalize them it doesn't recognize shift being pressed. I'm guessing it is something stupuf that i'm over looking. But i just cannot seem to figure it out. I have been goggling and reading on it for over 6 hours now. any help will be greatly appreciated.
Edited by Dirdie on 11/24/2012 7:15 AM PST
Reply Quote
90 Blood Elf Death Knight
10675
I believe i got it working, with a program called wow keyboard fix
Reply Quote
90 Tauren Druid
7015
Can you specifically refer me to the site? and did it work alright then?
Reply Quote
90 Pandaren Monk
7720
https://us.battle.net/support/en/article/keyboard-and-mouse-troubleshooting-mac#7
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]