Crackling sound AND wildly fluctuating FPS

So, I've already posted about my FPS issue in the sticked thread, but now over the past week or so the fluctuating FPS is combined with crackling/popping sound. Usually I can tell when the FPS is about to start its roller coaster by the sound cutting out and crackling. Every setting is set to low or disabled. I have done the WTF/cache process. I have reset the SMC. I have uninstalled and re-installed the game. None of this fixes the issues. There are no issues with any other program/game I run on this computer - only WoW is a problem.

Software:

System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Time since boot: 3:44

Hardware:

Hardware Overview:

Model Name: iMac
Model Identifier: iMac12,2
Processor Name: Intel Core i7
Processor Speed: 3.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 4 GB
Boot ROM Version: IM121.0047.B1F
SMC Version (system): 1.72f2

Graphics/Displays:

AMD Radeon HD 6970M:

Chipset Model: AMD Radeon HD 6970M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6720
Revision ID: 0x0000
ROM Revision: 113-C2960H-188
EFI Driver Version: 01.00.544
Displays:
iMac:
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.Canadian
Keyboard Layout: ANSI
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
I would start by noting down the exact time and date it happens.

Then start looking at logs to see what's happening at about that time to cause this. I would also have Activity Monitor up to see if I could spot any processes using a ton of cpu time at the time of the fluctuating FPS.

IE The Logs in the wow folder. As well as the ones from Console.app (out of Applications -> Utilities)

I'll let you know if I remember anything like your case.
Reply Quote
Support Forum Agent
Also, when you uninstalled and reinstalled, did you redownload addons into it?

I would also try running the repair tool to make sure all files are ok.

________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
Reply Quote
I don't use any addons. I'll try the repair tool. Thanks.
Reply Quote
The sound is better - still skips a bit, but the terrible crackling seems to be gone. No change to the FPS problem.
Reply Quote
90 Troll Mage
8440
I AM HAVING THE SAME EXACT PROBLEM!

Every now and than the sound will crackle and my FPS will go BONKERS for around 6 or 7 seconds, sometimes longer sometimes shorter. It doesnt happen when I perform a specific action. Its completely random. Sometimes it wont happen for a half hour.

This affects my ENTIRE computer only when WoW is running. I did everything you guys have said to do about as well and it just doesn't work. I even reformatted the machine.

Im running a 2011 iMac 27inch with a 6970 GPU and 12 gigs of RAM.

Just figured id let you know ive been struggling with the same problem.
Reply Quote
90 Troll Mage
8440
A find i just made - I left wow open with activity monitor open as well and I waited for a spike, WoWs CPU usage shot up to 120%
Reply Quote
90 Troll Mage
8440
Ok last update. Do not run it in 64-bit.

Its the 64 bit client that is causing the spikes.

I have been running the 32 bit client for hours now without a hiccup.
Reply Quote
I've run both the 64 and the 32 and the issues are the same for me. It makes no difference. I ran WoW windowed with the activity monitor so I could see if I saw similar results to yours, but WoW's CPU usage was fairly consistent at about 50% on average. If I was in a city it went up to about 80%, and twice spiked to 120% for a brief second - there did not appear to be any change to game performance when that happened for me. During the hour and a bit I played, the game performance was consistent regardless of the %CPU - FPS fluctuated between 37 (what I have it capped at) and 15, and the sound crackling is back, so the repair tool didn't work, unless I have to do it every time I play. Next time I log in I'll try repairing again to see if it's any better.
Reply Quote
90 Troll Mage
8440
Thats odd! Im on day two with the 32 bit client and do not have a single issue.

Perhaps we have a similar issue.. but its not the SAME issue?
Reply Quote
Thats odd! Im on day two with the 32 bit client and do not have a single issue.

Perhaps we have a similar issue.. but its not the SAME issue?


It's likely related somehow. Tried the repair tool again this morning, but both issues persist. I've pretty much given up at this point that it'll ever get better. So discouraged ... I used to love this game, but now I almost hate it :(
Reply Quote
90 Dwarf Hunter
10310
Run WoW in 32 bit if you would not mind, 64 bit seems to be having some issues here and there. I would check your sound options and WoW to just make sure there is nothing set funny.

As for the random fps drops I recommend the 32 bit client as well, and make sure you do not have vertical sync on. I know recently this has caused major frame drops for people from time to time.

Hope this helps,
Bithal
Reply Quote
Thanks for your suggestions, Bithal, but I'm already running the 32 bit, vertical synch is disabled, and the sound is set to recommended.
Reply Quote
90 Troll Mage
8440
After 3 days with the 32 bit client I have had the issue come back only twice now. Its obviously still there but its much better for me in 32 bit. We need to solve this.
Reply Quote
83 Blood Elf Paladin
3945
I just wanted to pitch in and say I'm having the exact same problem, on the exact same iMac model/specifications as Jenyala.

I tried Antman's suggestion of using the 32-bit client and it does cut down on occurrences but for me it is still fairly frequent, and just as intense when it happens. I have a couple other observations to add:

It seems to happen most intensely in certain zones. For the most part these are very busy zones in newer content, like Jade Forest, Vashj'ir, Deepholm, and Uldum. Same for any of the dungeons in these zones.

However I also had chronic severe cases of it and first really noticed it when going through Shadowmoon Valley on my Death Knight, which is to say I haven't been through many lowbie areas since I started playing again on this Mac.

Second observation: if I disable Vsync, the problem becomes much more intense to the point of being unbearable even with the 32-bit client. I usually run with Vsync because I tend to notice screen tearing more than others, but I thought I'd mention it since while Bithal is correct about Vsync normally generating frame dips, particularly when the screen content is drastically changing over a few frames(i.e. fast turning), that's not the problem we're experiencing and in relation to this problem Vsync seems to help for some reason, at least for me.

Third observation: I set sound quality to low, and channels to minimum, and that combined with the 32-bit client greatly alleviated the problem outside of said problem zones and dungeons. I didn't notice a difference of any kind between using or not using hardware sound processing.
Reply Quote
90 Tauren Paladin
9535
I have to bring this up because I've been having the same problems with the same system as the OP and It's driving me crazy. Each time I try to play WoW it turns into a 2hours chore trying to find a fix for this problem. Sound crackling affects the whole system when wow is running.
Reply Quote
90 Blood Elf Paladin
4250
Sorry to bring back an old thread, but I'm having the exact same issue with the exact same model.

I tried everything: re-installing the game, clearing all the caches, setting the permissions, using the repair tools, deleting the WTF and Interface folders etc.

Sometimes it's just the sound stuttering, sometimes it's both the sound and the video that freeze at the same time.

Very frustrating!
Reply Quote
MVP - Technical Support
90 Human Warrior
18100
have you tried things like toggling hardware sound on and off, or reverb on. or reducing sound channels (or increasing them?) or turning ambient sound off, etc? what combinations of settings give the worst problems and what give the least?
Reply Quote
90 Blood Elf Paladin
4250
02/23/2013 08:10 PMPosted by Omegal
have you tried things like toggling hardware sound on and off, or reverb on. or reducing sound channels (or increasing them?) or turning ambient sound off, etc? what combinations of settings give the worst problems and what give the least?


I turned everything to low or off (hardware sound off, ambient sound off, 24 channels, sound quality low) and it gets better. If I also turn music off it's also better.

Overall it's clearly linked to the sound. When there are a lot of spell effects (say in battlegrounds with a lot of enemies), then the sound gets so choppy that the video lags. I get video freezes that last maybe 2-3 seconds.
Reply Quote
90 Human Paladin
0
It happens for me on a PC with Realtek HD Audio integrated sound. I tried disabling hardware sound and reverb, but I still get wild fps issues and sound scratches when ever I turn the camera. If I disable all sound I don't get any issues.

I'm not sure what this means if it still happens with hardware sound disabled. I mean even if it was handled through software it still goes through the sound Hardware so I guess it's not entirely off the hook.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]