Cannot Access Certain Mounts & Mini Pets

I cannot seem to access certain paid in-game goods for whatever reason... My account is still active, it has not lapsed for months upon end, and none of my past payments have failed. So, in short, I do not see any real issue as to why I cannot utilize the following items:

=Mounts=

• Celestial Steed
• Imperial Quilen
• Heart of the Aspects
• Tyrael's Charger (My annual pass never lapsed and it was paid in full.)

=Mini Pets= (I can see both of these pets in my Companion Panel, one of which has been named by me, but both are grayed out.)

• Lucky Quilen Cub
• Soul of the Aspects

As a note, my progress in the achievement "We're Going to Need More Saddles" is at 131/150. I am currently at 127 mounts in my mount panel - which is 4 missing.

Is there any idea on what I should do to fix this? I have already opened a ticket with the Blizzard GMs and they basically told me just to file it as a bug report. This may very well be the correct answer, though I cannot help but feel that something was upended regarding my account.
Reply Quote
12/09/2012 03:28 PMPosted by Ebonrook
As a note, my progress in the achievement "We're Going to Need More Saddles" is at 131/150. I am currently at 127 mounts in my mount panel - which is 4 missing.

I se a couple possibilities as to this - the first, are the four mounts you can no longer access counted in that 127? If not, that'd bump you to 131.

Other option - do you have different characters who have access to class- or profession-specific mounts? My warlock can ride 145 different mounts and shows achievement progress as 145/150, my hunter has 143 mounts available (no felsteed/dreadsteed) but has the same achievement progress of 145/150.
Reply Quote
100 Blood Elf Warlock
19200
Looking at your Armory:
You don't own a Celestial Steed, Heart of the Aspects or Tyrael's Charger.

You do however own a Soul of the Aspects, you've named it Hope and it's level 2. You also own the Lucky Quilen Cub and Imperial Quilen. If you're not able to see or access them you need to reset your UI (NOT a /reload). Log out of the game completely and go to your WoW install folders. Delete the folder named Cache and rename the WTF and Interface folders (simply adding old to the name works). Then restart the game and check again.

The pets & mounts you're sure you own you'll need to contact Billing & Support services to inquire as to why they have been removed from your account.
Reply Quote
100 Blood Elf Warlock
19200
And Tajit is correct, class specific mounts don't count.
Also, if you have both versions of a faction specific mount you only get 'credit' on the appropriate faction.
Reply Quote
@ Arizza:

I do own the mounts in question, they just do not show up for whatever reason. I have done a clearing of the Cache, WTF, and Interface folder and nothing has happened.
Reply Quote
100 Blood Elf Priest
11835
Have you recently transferred the character from one battle.net account to another?
Reply Quote
100 Troll Death Knight
10505
Try this, make a new level 1 character of the Alliance (human or something) and just log into it. Then do the same for Horde if you have any Horde specific ones. Then log into your main and try summoning it again. Had a GM tell me to do that for mine. XD
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]