Problems with Weak Auras. Options menu bugged

90 Pandaren Shaman
7995
Hello all. Posting here to see if anyone can help me out here.

While configuring my UI, the Weak Auras menu bugged out and will not show anything other than the header. This happened after minimizing the window to edit some things on Gnosis' options window, and then maximizing WA back.

I've tried /reload, restarting the game, and restarting my computer; with Gnosis disabled. But the problem remains on all characters. I also posted a ticket to the authors of WA on WoWAce but it hasn't been responded to. (Though I might just be a little impatient.)

Does anyone know how to fix this? Possibly without losing my saved configurations.

Here is a picture of the bugged options window: http://i.imgur.com/s5ZN6.jpg
Reply Quote
90 Undead Warrior
11800
I hope you're still reading this thread, although it's very likely that you aren't and/or have already circumvented the issue by doing a clean reinstall.

I had the same issue and found a fix that seems to work fine for now.

Make sure the game is not running and then go in your WoW folder:

D:\Games\World of Warcraft\WTF\Account\YOURACCOUNT\SavedVariables

There should be a list of .lua and backup files for many of the addons you use. Go down to Weakauras.lua, open it in a text editor (notepad++ is what I use, but notepad and wordpad should work too) and the first few lines should be something like this:

WeakAurasSaved = {
["login_squelch_time"] = 5,
["registered"] = {
},
["frame"] = {
["xOffset"] = -213.9195556640625,
["width"] = 629.9999389648438,
["height"] = 40.00001525878906,
["yOffset"] = -133.94873046875,
},

The ["height"] parameter is set to a very small number, which is why you can't see the whole menu. Set it to something higher, like 600. Save the changes. When you open the game again and log in, just type /weakauras to open the menu and it should be fine. This obviously doesn't fix the actual bug, but it's a good band-aid until the author can find what's causing the issue.
Edited by Shawarma on 12/21/2012 3:01 AM PST
Reply Quote
90 Draenei Priest
12520
I hope you're still reading this thread, although it's very likely that you aren't and/or have already circumvented the issue by doing a clean reinstall.

I had the same issue and found a fix that seems to work fine for now.

Make sure the game is not running and then go in your WoW folder:

D:\Games\World of Warcraft\WTF\Account\YOURACCOUNT\SavedVariables

There should be a list of .lua and backup files for many of the addons you use. Go down to Weakauras.lua, open it in a text editor (notepad++ is what I use, but notepad and wordpad should work too) and the first few lines should be something like this:

WeakAurasSaved = {
["login_squelch_time"] = 5,
["registered"] = {
},
["frame"] = {
["xOffset"] = -213.9195556640625,
["width"] = 629.9999389648438,
["height"] = 40.00001525878906,
["yOffset"] = -133.94873046875,
},

The ["height"] parameter is set to a very small number, which is why you can't see the whole menu. Set it to something higher, like 600. Save the changes. When you open the game again and log in, just type /weakauras to open the menu and it should be fine. This obviously doesn't fix the actual bug, but it's a good band-aid until the author can find what's causing the issue.
Thank you, this solved my problem, and I hope the OP reads this topic again.
Reply Quote
100 Worgen Priest
8430
I hope you're still reading this thread, although it's very likely that you aren't and/or have already circumvented the issue by doing a clean reinstall.

I had the same issue and found a fix that seems to work fine for now.

Make sure the game is not running and then go in your WoW folder:

D:\Games\World of Warcraft\WTF\Account\YOURACCOUNT\SavedVariables

There should be a list of .lua and backup files for many of the addons you use. Go down to Weakauras.lua, open it in a text editor (notepad++ is what I use, but notepad and wordpad should work too) and the first few lines should be something like this:

WeakAurasSaved = {
["login_squelch_time"] = 5,
["registered"] = {
},
["frame"] = {
["xOffset"] = -213.9195556640625,
["width"] = 629.9999389648438,
["height"] = 40.00001525878906,
["yOffset"] = -133.94873046875,
},

The ["height"] parameter is set to a very small number, which is why you can't see the whole menu. Set it to something higher, like 600. Save the changes. When you open the game again and log in, just type /weakauras to open the menu and it should be fine. This obviously doesn't fix the actual bug, but it's a good band-aid until the author can find what's causing the issue.


TY worked perfectly!
Edited by Storz on 1/13/2013 3:05 PM PST
Reply Quote
95 Human Paladin
7325
Thanks! I couldn't find the folder you specified the first time I had this problem, I fixed it by deleted the saved setting which unfortunately deleted all my auras so i had to remake them. Glad i was able to find this thread again and found the WTF folder.
Reply Quote
90 Human Warlock
8985
Thanks. This helped get me back up to speed.

I would like to make persons aware that if they use custom sounds that updating WA overwrites... If you like to edit sounds and spend hours making just the right, hysterical, over-the-top alarms you will want to back your audio up.
Reply Quote
100 Tauren Druid
17940
Thank you so much! Solved my problem!
Reply Quote
90 Troll Priest
19390
This did not fix the problem in weak auras 2. Going to test it in weak auras 1 now.
Reply Quote
90 Human Paladin
0
This is getting to be a couple weeks since the last post, but I still felt like responding just to say thank you to Shawarma for saving me a lot of time.
Reply Quote
100 Troll Warlock
6235
Still a problem, still a solution
Reply Quote
100 Dwarf Shaman
16755
There's a handle in the lower-left corner of the window you can drag to resize it.

(You're welcome Stanzilla.)
Edited by Hammertotem on 9/12/2014 5:02 PM PDT
Reply Quote
100 Orc Warlock
15715
After reading everything and then scrolling down to the end to what Hammertotem said, I kind of just want to punch myself in the face for all the time I wasted on this. GG WP.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]