When I put in the disk and start the installer it says" The installer does not need to be applied it requires a version of wow exe older than5.0.0.0 but you already have version 5.1.0.16357... so I went to battle.net and "add game" and put in the code...do I just log in and I magically have cataclysm now or what? Not sure where to engage the actual download from the disk.