shift + click not working

90 Human Warrior
8420
All of my shift keybinds and macros are working fine but since the latest update I can't shift click items into the chat. I can't shift right click to gem my gear either.

I tried relogging, reseting chat, and removing add ons but nothing has worked so far. Please help!

I play on a macbook pro
Edited by Sgtjonson on 2/7/2013 4:00 PM PST
Reply Quote
Blizzard Employee
Are you using a mouse, two finger tap (trackpad), or command-click to do the right click?
Reply Quote
90 Blood Elf Priest
7245
I have the same problem. It's happening using two finger tap. Two finger tap doesn't seem to be an issue at any other time, though.
Reply Quote
Blizzard Employee
Can you post your system specs, so I know what setup you have?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
Reply Quote
90 Human Death Knight
11495
I'm having a similar problem, but I can shift click items in my inventory to chat, just not from any of my profession windows (like for linking mats). The entire recipe/pattern link will work.

Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,1
Processor Name: Intel Core i7
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 8 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM111.0034.B02
SMC Version (system): 1.54f36

ATI Radeon HD 4850:

Chipset Model: ATI Radeon HD 4850
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x944a
Revision ID: 0x0000
ROM Revision: 113-B9110C-425
EFI Driver Version: 01.00.383
Displays:
iMac:
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Boot Volume: Mac HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 20 minutes
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]