Stuck on "Updating Blizzard Launcher".

90 Dwarf Paladin
9630
The bar fills up about 2/3 of the way, and then stops. I checked for the "agent" process in activity monitor, but I don't see one. Never had this problem before - just started happening on Wednesday.

MacBook Pro 5,3
OS X 10.6.8 (Snow Leopard)

Just wondering if there's anything to try before I attempt an upgrade to Mountain Lion (not sure if this would solve the problem or not).

Thanks!

Update: Figured it out - deleted the battle.net folder in Users>Shared and now I'm good. Woo!
Edited by Sparrkles on 2/8/2013 2:10 PM PST
Reply Quote
90 Blood Elf Mage
7295
I've had the exact same issues, also starting around Wednesday. I tried a complete reinstall, and it's still happening. Then I saw this thread and found that deleting the battle.net folder worked, however it's only a temporary fix. It looks like I have to do this every time I play.

iMac mid 2007
Mac OS X Lion 10.7.5

Thanks in advance!

EDIT: I've found that if I force close while it's updating and re-open that it'll launch, though I have to do this every time.
Edited by Volpheid on 2/10/2013 9:10 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]