Sudden Lagging with new patch

85 Worgen Druid
1485
I used to have no issues at all with lagging, especially on the lowest settings. However, ever since the new patch has been introduced it seemed like I have the worst lag, to the point of the game freezing and crashing. This happens when I go into raids/PVP, and any sort of dueling or fighting.

Is this a common issue now?
SPECS:

MacBook Pro 13'', mid 2010.

Processor 2.4 GHz Intel Core 2 Duo
Memory 4 GB 1067 MHz DDR3
Graphics NVIDIA GeForce 320M 256 MB
Serial Number W80451V4ATP
Software Mac OS X Lion 10.7.5 (11G63b)
13.3-inch (1280 x 800)
NVIDIA GeForce 320M 256 MB graphics

320 GB SATA Disk
Your Mac contains 2 memory slots, each of which accepts a 1067 MHz DDR3 memory module.
Edited by Nimu on 3/2/2013 11:20 AM PST
Reply Quote
90 Human Rogue
11855
I haven't had issues for quite a while, until the new patch came out. Now, it's lagging out so badly that it eventually kicks my internet offline for a few minutes until it reboots. I doubt this is a graphics issue, I went from ultra/high to low and saw no change.... Dunno what's causing it.
Reply Quote
85 Worgen Druid
1485
same, exactly....:(. I can't even play WoW anymore because of this issue. :/
Reply Quote
90 Pandaren Monk
5255
Having this problem too, it's at its worse in heroics, LFR, and other instanced content. Hope we hear from a blue.
Reply Quote
Support Forum Agent
Is this recent, as of a few days ago, or when patch 5.1 was introduced back in November? There is background download for patch 5.2 that some users may experience some lagging on lower bandwidth connections. Does your launcher mention any data for the next patch being downloaded?
Edited by Machkhan on 3/3/2013 12:31 PM PST
Reply Quote
85 Worgen Druid
1485
Pretty sure it began when the new patch came out. I could play fine before I downloaded the latest content which was I believe 5.2. It is definitely a lag, and my Frame rate goes down from 80 to like 10...I have very good internet, high speed business class. I didn't see any mention of patches further than 5.2 being downloaded yet.
Reply Quote
Support Forum Agent
Do you know if you have wow-update-base-16516.MPQ in /Applications/World of Warcraft/Data?

What size is it?

Also, have you tried doing the troubleshooting steps outlined in our World of Warcraft Low Performance article?
Reply Quote
85 Worgen Druid
1485
yes I do. It is 1.13 GB. and no, I'll look into that...
Reply Quote
85 Worgen Druid
1485
I have read and completed all options suggested on the troubleshooting page. I even opened up my laptop and dusted off everything. I am still receiving the same laggy results :(. I hope I can get this problem resolved, as again, I can not even play WoW right now...
Reply Quote
Support Forum Agent
A new patch was released today. Did you try making sure you're 100% updated?

If the issues persist still, then something else may be causing an issue. I have a 320M Mac and and I haven't had issues like this.

Since we've tried all the steps on that page, have you tried to do a full uninstall/reinstall of WoW to see if it helps?
Reply Quote
85 Blood Elf Death Knight
1845
I am having this same problem. Playing on a Macbook Pro Retina, and having huge lag problems. Fine in certain areas (56 FPS is the Undercity), but horrible in most places (as soon as I left the Undercity, dropped to 5-10 FPS in flightpath, and never recovered. Interestingly, when playing in Windowed mode, the frame rate seems to recover somewhat, but switch back to fullscreen mode and the FPS drops like a stone. I have also done all the steps on that article.
Reply Quote
100 Blood Elf Paladin
15115
I've been having the same problem as well although my fps isn't quite as low as 10, it's been hovering around 20. My first thought was because I upgraded my OS from 10.6.8 to 10.8. I've done all the software and firmware updates I can so I'm wondering if the lower fps is due to something else.
Reply Quote
MVP - Technical Support
100 Draenei Mage
7170
Since a patch has just hit to me the obvious thing to check would be addons if the Display Lua in the Help section of the Interface options is turned on or off.

If it's off and you have an addon that hooks something that's used regularly by everything else and is erroring out the logging process could be dragging your FPS down.

Try testing with /disableaddons to turn all addons off in game.
________________________________________________
Mac Tech Support Cerulean Cosmic Bovine from NZ
Not on active forum posting duty from Fri 6 PM NZST to Sun 6 PM NZST (IRL Work comes first)

https://twitter.com/bluspacecow
Reply Quote
I was extremely disappointed to see the terrible graphics performance with 5.2

it's happened before, when cata came out I actually installed windows and had a dual boot setup. the playability was that bad in macOS. however, somewhere along the line things got fixed.

with 5.0 macOS playability was very strong.

however, with the new patch it's gone right through the floor again.

all my setting are appropriate. they are the same as they were pre-5.2

what's going on?

I could barely play in a LFR group.

EDIT: fps prepatch was something over 30, I have it capped at 30. uncapped it would go between 30 and 50/60. in LFR last night it was 5 and it seemed much lower with constant freezes.
Edited by Zahruk on 3/6/2013 4:02 AM PST
Reply Quote
Support Forum Agent
Have y'all tried what Blu suggested? A lot of times after a patch drops, low performance can be caused by addons not being updated or optimized with the latest patch.
Reply Quote
100 Human Warlock
8475
Noticed lag with addons off as well since patch. Thought it was server-side and not my client as it was patch day and lots of players would be on.

I normally cap my fps at 40 anyway for consistency/tearing but only getting average 21 since patch. In large areas I'm sometimes down to 12fps.
Reply Quote
Support Forum Agent
Were the addons off as in disabled, or did you reset your ui? Disabled isn't the same as a UI reset.
Edited by Machkhan on 3/6/2013 8:18 AM PST
Reply Quote
100 Human Warlock
8475
Hey Machkhan buddy. Nice to see you're still here!

I've been at this a long time. Playing WoW some time and I'm used to deleting addon folders, caches, preferences, working with the /console etc with every patch when I encounter a problem (sometimes installing a fresh copy of WoW). I also have 25 years experience with Apple/Mac hardware and software (and President of our local Apple User Group).

I did notice a slight lag increase since patch day. But I assumed that was the norm as many users logged on to play. I'm now seeing other users complaining.

I'll do my part and check over everything when I get back to my iHouse so I can provide some meaningful information for you and other mac users to work with. Apologies I can't provide more information from the office.
Reply Quote
I have noticed lag spiking high and fps taking a nosedive when certain graphical effects are active.

The green circle (can't remember the name right now) that heals, with all the arrows and stuff in it. Usually drops fps by 40+.

DK anti-magic bubble and Death & Decay both give a 25-30 fps drop, it will be 45+ if both are active.

If you want to completely shut down your screen, 0fps, do Will of the Emperor fight. Every breath phase, with the fog, goes to 0 fps. Normal fps resumes upon the fog going away.

On my usual settings, I go down to 35-40 fps on that fight in 5.1 patch. I dropped all settings to minimum and had no change. After the raid, I moved the cache, Interface and WTF folders out, logged back in and had a DK friend drop D&D, had the fps drop from 99 to 62 (tested in the fields outside the shrine in the vale). As that was the same as the drop while I had my usual addons active, I don't think this is addon related.

iMac i3, 3.2 GHz, 12 GB RAM, ATI Radeon HD 5670, OS 10.8.2 fully patched.
Reply Quote
03/06/2013 09:39 AMPosted by Cocheti
I have noticed lag spiking high and fps taking a nosedive when certain graphical effects are active.


this is happening

grinds to a halt during LFR when there's an explosion of effects

that didn't happen prior to 5.2
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]